geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajiv M <rmadasser...@gmail.com>
Subject Re: Error while publishing to geronimo 1.0 using the current eclipse plugin
Date Tue, 10 Jan 2006 19:00:53 GMT
But, Geronimo is not supported on JDK 1.5 officially.. right Sachin?
The other day I tried creating an app using the plug-in and got the exact
same error. My environment was JDK 1.5 set at system level. I believe it was
used by eclipse also since i didnt find any jre folders inside eclipse. My
point is even if we used JDK 1.5 for development and deployment we would
still get this issue. Again i solved it by setting the system JDK to 1.4.2

~rajiv

On 1/10/06, Sachin Patel <sppatel2@gmail.com> wrote:
>
> This "may" be a defect in WTP or the Geronimo plugin.  You should be
> able to run eclipse under any JRE.  When creating the Geronimo
> runtime, you should then be able to define and pick another JRE (1.4)
> and that JRE should be the one used to launch the server.  From what
> you state this looks like what you are doing since your app is using
> 1.4.2, but launch the server is not using that version.
>
> I'll look into this.  In the meantime as a workaround, you should be
> able to double click on the Geronimo server in the servers view,
> which will open up the server editor.  From their you could choose
> Edit Configuration and from that dialog reassign the server to launch
> with 1.4.2.
>
> - sachin
>
>
>
> On Jan 10, 2006, at 9:19 AM, Tobias Mueller wrote:
>
> > Thank you,
> >
> > the project was developed using JDK 1.4.2
> > But eclipse was running under 1.5
> > Starting eclipse with 1.4.2 solved the problem.
> >
> > On 1/10/06, Rajiv M <rmadassery77@gmail.com> wrote:
> >> I think you have JDK 1.5, pls retry with JDK 1.4.2
> >>
> >>
> >>
> >> On 1/10/06, Tobias Mueller <tobias.mueller@gmail.com> wrote:
> >>> Hi,
> >>>
> >>> while publishing a ear to geronimo 1.0 using the current eclipse
> >>> plugin I get the following error:
> >>> java.lang.Exception: Error unmarshaling return; nested exception is:
> >>>        java.lang.ClassNotFoundException:
> >>>
> >> org.apache.geronimo.common.DeploymentException$CleanseException
> >> (no
> >>> security manager: RMI class loader disabled)
> >>>
> >>> What is wrong? Is there a jar missing for deployment?
> >>>
> >>> Tobias
> >>>
> >>> --
> >>> Tobias Mueller
> >>> mailto:tobias.mueller@gmail.com
> >>> Mobil: +49 172 71 34 914
> >>> http://www.infobean.de
> >>> ICQ#: 111 918 585
> >>> aim:addbuddy?screenname=muellerAIM
> >>>
> >>
> >>
> >>
> >> --
> >> ~~~Truth is out there.~~~
> >
> >
> > --
> > Tobias Mueller
> > mailto:tobias.mueller@gmail.com
> > Mobil: +49 172 71 34 914
> > http://www.infobean.de
> > ICQ#: 111 918 585
> > aim:addbuddy?screenname=muellerAIM
>
>


--
~~~Truth is out there.~~~

Mime
View raw message