geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phani Madgula <phanibalaji.madg...@gmail.com>
Subject Re: Shutdown problem
Date Mon, 23 Jan 2006 14:10:09 GMT
Hi,

thanks for info...It all worked now..

Can you please tell me what "--uri <identifier>" option for deployer stand
for?

The documenation says

 --uri <identifier>
Where <identifier> is a Universal Resource Identifier (URI) that specifies
how the deployer is to contact the server. If this flag is not specified,
the deployer will attempt to contact the server using the standard port on
localhost. The identifier must have the following form:
deployer:geronimo:jmx:rmi:///jndi/rmi:[//host[:port]]/JMXConnector
where <host> is replaced with the host name or TCP/IP address of the system
where the server is running and <port> is replaced with the port number
where the server is listening. If unspecified, localhost and the default
port will be used.

Thanks
phani



On 1/23/06, Manu George <manu.t.george@gmail.com> wrote:
>
> I forgot to mention substitute the value of your server port (5555) for
> the --port parameter
>
> On 1/23/06, Manu George <manu.t.george@gmail.com> wrote:
> >
> > Hi Phani,
> >                   You need to specify the port or the Shutdown command
> > will default to the port 1099. The command is
> > java -jar bin/shutdown.jar --user system --password manager --port 1099
> >
> > Regards
> > Manu
> >
> > On 1/23/06, Phani Madgula < phanibalaji.madgula@gmail.com> wrote:
> > >
> > > Hi,
> > >
> > > This is just for information sake. I guess, it is a problem too..
> > >
> > > When I start the server on a non-default RMI port[5555], and try to
> > > shutdown using "shutdown" command, it is not shutting down.
> > > It is saying
> > >
> > >
> > > C:\IBM\geronimo-1.0\bin>shutdown
> > > Using GERONIMO_BASE:   C:\IBM\geronimo-1.0
> > > Using GERONIMO_HOME:   C:\IBM\geronimo-1.0
> > > Using GERONIMO_TMPDIR: C:\IBM\geronimo-1.0\var\temp
> > > Using JRE_HOME:        C:\IBM\JDK
> > > Username: system
> > > Password:
> > >
> > > Locating server on port 1099...
> > > Could not communicate with the server.  The server may not be running
> > > or the port number may be incorrect.
> > >
> > >
> > >
> > > However, I am able to shutdown using console.
> > >
> > > Thanks
> > >
> > > phani
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> >
> >
>

Mime
View raw message