geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: Eclipse Plugin trouble
Date Mon, 23 Jan 2006 15:38:03 GMT
Hi, I forgot to ask you.  Could you provide the exact scenario in  
which you saw the problem.  I want to be sure that all areas of WTP  
are covered by this defect.

Thank you.

- sachin



On Jan 22, 2006, at 12:03 PM, Edson Carlos Ericksson Richter wrote:

> Yes, that's my problem.
> Until this gets fixed, I'll export apps as WAR into /deploy folder  
> - works like a charm.
>
> Thanks,
>
> Richter
>
>
> Sachin Patel escreveu:
>
>> There is a known bug in WTP
>>
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=124016
>>
>> and I'm not sure what the exact scenario you're running but I'm   
>> willing to bet the above problem is the cause.  This defect is  
>> marked  as hot and will be fixed in WTP 1.0.1 (about a week or  
>> so).  In the  meanwhile the workaround is on a clean workbench,  
>> the first thing you  should do is define the server yourself (New  
>> -- Server).
>>
>> - sachin
>>
>>
>>
>> On Jan 22, 2006, at 11:40 AM, Edson Carlos Ericksson Richter wrote:
>>
>>> Thank you. I'll try that. But in meanwhile, I can't start  
>>> Geronimo  by using Eclipse plugin. It stay starting forever (or  
>>> better, until  "Timout after 240000s" message). Of course the  
>>> message is wrong,  because I didn't in front of the machine more  
>>> than a hour (240000s  = 66,6666667 hours!!!).
>>>
>>> ;-)
>>>
>>> Richter
>>>
>>>
>>> Sachin Patel escreveu:
>>>
>>>> Hi,
>>>>
>>>> The message means (and is not very intuitive) that the object   
>>>> that  you've clicked doesn't have a client (such as a web  
>>>> browser)  that can  be launched on the selected object. If you  
>>>> want to  launch a  particular servlet then expand the web  
>>>> project to select  a servlet,  and do the steps that you did  
>>>> this will deploy and  then open up a web  browser and launch  
>>>> that particular servlet.
>>>>
>>>> If you just wish to deploy the web project without running   
>>>> anything,  then if you are in the J2EE perspective, right click  
>>>> on  the geronimo  server listed in the servers view, then add  
>>>> remove  projects, and move  the web app over to the right side.   
>>>> If the  server is not running,  hit start and after start this  
>>>> will deploy  the app.  Otherwise it  should deploy the app just  
>>>> by associating  the project to the server.
>>>>
>>>> - sachin
>>>>
>>>>
>>>>
>>>> On Jan 22, 2006, at 7:21 AM, Edson Carlos Ericksson Richter wrote:
>>>>
>>>>> I know Eclipse plugin is not released yet, but my question   
>>>>> probably  is result from some my mistake.
>>>>> I'm on 20060120-1443.
>>>>>
>>>>> I right click on webapp, and ask "Run -> Run as server", then  
>>>>> I   select Apache Geronimo (previously configured), and then I  
>>>>> get a   dialog:
>>>>>
>>>>> "Could not find a client that is able to lauch selection"
>>>>>
>>>>> Probably I'm doing something terrible wrong in my configuration.
>>>>> Just to inform, this release keep starting Geronimo forever   
>>>>> (even  after "Geronimo startup complete on console window").
>>>>>
>>>>>
>>>>> Richter
>>>>
>>>>
>>>>
>>>>
>>>
>>
>>
>


Mime
View raw message