geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Sisson <jrsis...@gmail.com>
Subject Re: Geronimo build question
Date Wed, 11 Jan 2006 23:18:08 GMT
Rob,

The build instructions probably shouldn't say JDK1.4.x they should say 
JDK1.4.2 (preferably JDK1.4.2_08 or later).

Can you also send me the output of the "java -version" command.

Thanks,

John

Rob Kenworthy wrote:

> Hi,
>
> John Sisson has asked me to send an email to this list as a result of 
> my posting on theserverside 
> (http://www.theserverside.com/tss?service=direct/0/PostNewsReply/postReply&sp=l38463&sp=F&sp=l196734#196680)

>
>
> I am having problems doing a simple Geronimo build of 1.0 final.
>
> Here is the info that John requested:
>
> Q: Are you using the 1.0 final release or a release candidate?
> A: 1.0 Final release.
>
> Q: What platform are you building on (Windows XP, Linux..)?
> A: Windows 2000
>
> Q: Do you want to build from the command line or were you wanting to 
> use an IDE to debug etc?
> A: Command line. The BUILDING.txt file says to use Maven 1.0.2 or 
> later and use JDK 1.4.x. So I set my path to the bin directory of 
> Maven and set JAVA_HOME appropriately. Then run Maven from the 
> geronimo directory. I figure that is all I should need to do.
>
> The errors I am getting are unsatisfied class dependencies for a file 
> called GenerateServiceXml.java. The dependencies are actually in one 
> of the maven jars, but it doesn't seem to be in the classpath. I did 
> try renaming the file to ...java.bak and ran it again. It got much 
> further, but other class compilations depend on 
> GenerateServiceXml.java, so it blew up again.
>
> Any help would be appreciated.
>
> Thanks,
> Rob
>
>
>


Mime
View raw message