geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ranjan, Rakesh \(Cognizant\)" <Rakesh.Ran...@cognizant.com>
Subject FW: deployment problems
Date Fri, 06 Jan 2006 05:53:13 GMT


Hi Krish,
For your case, I think u should put some version in the jar file name.
You should rename test.jar to some name containing the version.
Like test-1.0.jar

Then the dependency will be like this :

<dependency>
     <uri>test/test/1.0/jar</uri>
</dependency>


Rakesh Ranjan


-----Original Message-----
From: Ranjan, Rakesh (Cognizant)
Sent: Thursday, January 05, 2006 6:43 PM
To: 'user@geronimo.apache.org'
Subject: RE: deployment problems


Hi krishnakumar,

Dependency format has been changed in Geronimo-1.0 version. You are
using the older dependency format.

Suppose the jar 'my-1.0.jar' file is in the directory
$GERONIMO_HOME\repository\myFolder\jars\my-1.0.jar,
then the dependency format will be like this :

<dependency>
     <uri>myFolder/my/1.0/jar</uri>
 </dependency>


Regards,
Rakesh Ranjan


-----Original Message-----
From: Krishnakumar B [mailto:www.bkk@gmail.com]
Sent: Thursday, January 05, 2006 6:26 PM
To: user@geronimo.apache.org
Subject: deployment problems

hi,

i am unable to get some applications that was working in M5 to work on
1.0

If i deploy EAR plans with dependency it says jars not found in
repository.

<dependency>
	<uri>test/jars/test.jar</uri>
</dependency>

 Error: Unable to distribute gerjms.rar:
 org.apache.geronimo.kernel.repository.MissingDependencyException:
 uri jms/jars/test.jar not found in repository

     uri jms/jars/test.jar not found in repository

If i remove the dependency the plan is deployed. Are dependency
elements not required in plans for 1.0?

Also i am not able to get connectors to work. I have deployed a
connector that is running. My EAR plan has an ext-module section with

<ext-module>
	<connector>JMSRA_1</connector>
 	<external-path>jms/rars/gerjms.rar</external-path>

When deploying this plan its not able to find jms/rars/gerjms.rar.

  Error: Unable to distribute gerjms.ear: a connector is missing in
  repository: jms/rars/gerjms.rar

This used to work in earlier builds but i am not able to get this to
work in builds for 1.0.

Thanks in advance for any help.

Regards
Krishnakumar B

This e-mail and any files transmitted with it are for the sole use of the intended recipient(s)
and may contain confidential and privileged information.
If you are not the intended recipient, please contact the sender by reply e-mail and destroy
all copies of the original message.
Any unauthorized review, use, disclosure, dissemination, forwarding, printing or copying of
this email or any action taken in reliance on this e-mail is strictly
prohibited and may be unlawful.

  Visit us at http://www.cognizant.com

Mime
View raw message