geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vamsavardhana Reddy <c1vams...@gmail.com>
Subject Re: deployment problems
Date Thu, 05 Jan 2006 13:58:28 GMT
Hi KK,

Format for specifying dependencies has changed in 1.0.  The following
formats can be used.

  <dependency>
    <groupId> gid </groupId>
    <artifactId> artId </artifactId>
    <version> ver </version>
    <type> type </type>
</dependency>

<dependency>
<uri> gid/artId/ver/type </uri>
</dependency>

If type is omitted, the default value 'jar' is used.

-Vamsi

On 1/5/06, Krishnakumar B <www.bkk@gmail.com> wrote:
>
> hi,
>
> i am unable to get some applications that was working in M5 to work on 1.0
>
> If i deploy EAR plans with dependency it says jars not found in
> repository.
>
> <dependency>
>         <uri>test/jars/test.jar</uri>
> </dependency>
>
> Error: Unable to distribute gerjms.rar:
> org.apache.geronimo.kernel.repository.MissingDependencyException:
> uri jms/jars/test.jar not found in repository
>
>      uri jms/jars/test.jar not found in repository
>
> If i remove the dependency the plan is deployed. Are dependency
> elements not required in plans for 1.0?
>
> Also i am not able to get connectors to work. I have deployed a
> connector that is running. My EAR plan has an ext-module section with
>
> <ext-module>
>         <connector>JMSRA_1</connector>
>         <external-path>jms/rars/gerjms.rar</external-path>
>
> When deploying this plan its not able to find jms/rars/gerjms.rar.
>
>   Error: Unable to distribute gerjms.ear: a connector is missing in
>   repository: jms/rars/gerjms.rar
>
> This used to work in earlier builds but i am not able to get this to
> work in builds for 1.0.
>
> Thanks in advance for any help.
>
> Regards
> Krishnakumar B
>

Mime
View raw message