geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony Kong" <antho...@bisinfo.com.au>
Subject RE: Build issue (using HEAD version in svn)
Date Wed, 25 Jan 2006 04:42:01 GMT
Hi, david,

============================

Maven-eclipse-plugin basically generates the .classpath and .project for me
such that I can open the project in Eclipse.

============================

I am using 

$ java -version
java version "1.4.2_10"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_10-b03)
Java HotSpot(TM) Client VM (build 1.4.2_10-b03, mixed mode)

And 
 __  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.1-beta-2

============================

Svn HEAD version:

If I used "maven -o new" the problem is different now. The following error
message comes up:

test:test:
    [echo] icms-maven-plugin set maven.test.skip to false by default
    [junit] Running org.apache.geronimo.activation.handlers.MailcapTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
    [junit] [ERROR] Test org.apache.geronimo.activation.handlers.MailcapTest
FAILED
    [junit] Running org.apache.geronimo.activation.handlers.TextHtmlTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
    [junit] [ERROR] Test
org.apache.geronimo.activation.handlers.TextHtmlTest FAILED
    [junit] Running org.apache.geronimo.activation.handlers.TextPlainTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
    [junit] [ERROR] Test
org.apache.geronimo.activation.handlers.TextPlainTest FAILED
    [junit] Running org.apache.geronimo.activation.handlers.TextXmlTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
    [junit] [ERROR] Test org.apache.geronimo.activation.handlers.TextXmlTest
FAILED


"Maven eclipse" error message can be seen in previous email

============================

1.0 source code:

If I run "maven eclipse" using the 1.0 source code, it runs fine.

If I run "maven new" using the 1.0 source code, it ends up with a long
stacktrace when it reached the goal "multiproject:install-callback". 

The first exception is 

5344 [main] ERROR org.apache.geronimo.plugin.packaging.PackageBuilder  -
org.apache.geronimo.common.DeploymentException:
org.apache.geronimo.kernel.repository.MissingDependencyException: uri
geronimo-spec/geronimo-spec-corba/2.3-rc4/jar not found in repository


================================

Sorry, I have written this long mail. I hope it is not too confusing.

A summary:
			svn HEAD       1.0
-----------------+----------+------------
Maven eclipse      Not OK	    OK	
Maven new		 Not OK      not OK

Cheers,
AK
 

-----Original Message-----
From: David Jencks [mailto:david_jencks@yahoo.com] 
Sent: Wednesday, 25 January 2006 9:17 AM
To: user@geronimo.apache.org
Subject: Re: Build issue

I have no idea what maven eclipse does, but that jar is built in geronimo.

Have you run maven new?  If you have run it once you can probably usually
run maven -o new and save a lot of time :-)

thanks
david jencks

On Jan 24, 2006, at 2:07 PM, Anthony Kong wrote:

>  Hi,
>
> I did not find this info in the archive, and that's why this email.  
> If you
> have a pointer to an existing resource, do let me know.
>
> I have encountered this error messag when I run 'maven eclipse' at the 
> top level of the geronimo source code directory. I obtain the source 
> form the svn HEAD.
>
>
> +----------------------------------------
> | Executing (eclipse): Geronimo :: IZPack Installer Build Plugin
> | Memory: 18M/30M
> +----------------------------------------
> DEPRECATED: the default goal should be specified in the <build> 
> section of project.xml ins tead of maven.xml
>
> eclipse:
>
> build:end:
>
> Attempting to download standalone-compiler-custom-3.8.0.jar.
> WARNING: Failed to download standalone-compiler-custom-3.8.0.jar.
>
> BUILD FAILED
> File...... f:\testground\geronimo\maven.xml Element... maven:reactor 
> Line...... 429 Column.... -1 The build cannot continue because of the 
> following unsatisfied
> dependency:
>
> standalone-compiler-custom-3.8.0.jar
>
> Total time   : 8 minutes 28 seconds
> Finished at  : Tuesday, 24 January 2006 12:19:25
>
>
> Where I can obtain this jar file?
>
> Cheers,
> AK
>


Mime
View raw message