geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From l...@logemann.org
Subject Re: ClassNotFound on WAR deploy and status messages
Date Fri, 13 Jan 2006 10:01:06 GMT
Aaron,

this would definitely explain the issue. Of course i didnt checked the server
libraries for spring.jar. On the other hand, what should i do when i want to
use a newer version than the one shipped with Geronimo?

I will try it later today when i am in the office again. I keep you informed.

Thanks for all the other hints. I bet my money on Aarons explanation because
thats the one that is most likely the problem.

Marc

Zitat von Aaron Mulder <ammulder@alumni.princeton.edu>:

> I think you may need a small workaround in your Geronimo WAR plan if
> you're using Spring.  Try adding a <hidden-classes> element with the
> Spring packages:
>
> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.0" ...>
>   <hidden-classes>org.springframework</hidden-classes>
>   ...
> </web-app>
>
> Someone said that the Spring classes were actually added to the server
> classpath at the last minute before 1.0, and that was a mistake
> because it means the Spring classes are in a different class loader
> than the application classes that Spring tries to load.  The element
> above should prevent the web app from seeing the version of Spring in
> the server class path.
>
> Thanks,
>    Aaron
>
> On 1/12/06, Paul McMahan <paulmcmahan@gmail.com> wrote:
>> Hi Marc,  jars under WEB-INF/lib is definitely supported by Geronimo.  Does
>> the problem go away when you restart the server?  Also try starting and
>> stopping the component from the web console via the Applications/Web App
>> WARs portlet.  For a sanity check you might want to find your app deployed
>> under GERONIMO/config-store and make sure that freemarker.jar is in
>> WEB-INF/lib and make sure its the right size, etc.
>> config-store/index.properties can help you find the directory number for
>> your app.
>>
>>  Best wishes,
>>  Paul
>>
>>
>> On 1/12/06, Marc Logemann <list@logemann.org > wrote:
>> > Hi,
>> >
>> > i am trying to "port" our application to geronimo. It runs perfectly on
>> > standalone Jetty and Tomcat. With Geronimo i have some strange issues.
>> >
>> > First when deploying the WAR file (via admin console), everything seems
>> > to work fine because in the console Geronimo says: "deployed
>> > successfully". But when looking at the console, i got a
>> > ClassNotFoundException for one of my classes. Is this the way it should
>> > work?
>> >
>> > Regarding the classloader exception. It marks that it cant load a
>> > freemarker/template/TemplateHashModelEx.class but this
>> class is
>> > definitely shipped with freemarker.jar inside my WEB-INF/lib. BTW i get
>> > this exception so soon, because i am using Spring to bootstrap Beans on
>> > startup.
>> >
>> > The very same WAR file deploys without classloader issues on tomcat and
>> > jetty as said before.
>> >
>> > My deployment plan is pretty simple too:
>> >
>> > <?xml version="1.0" encoding="UTF-8"?>
>> > <web-app
>> >      xmlns="http://geronimo.apache.org/xml/ns/web"
>> >                 xmlns:naming="
>> http://geronimo.apache.org/xml/ns/naming"
>> >      configId="Netversys">
>> >         <context-root>/Netversys</context-root>
>> > </web-app>
>> >
>> > Does anyone have some hints for me?
>> >
>> > thx
>> >
>> > Marc Logemann
>> >
>>
>>
>




Mime
View raw message