geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: fail to build with
Date Wed, 04 Jan 2006 02:09:23 GMT

On Jan 3, 2006, at 5:01 PM, Henry Hwang wrote:

> I employ this 'hack' to get around the problem I described in the  
> beginning
> of this thread.
>
> The problem it seems is that while the build process trying to  
> build the
> configuration ' daytrader-tomcat' under ./config directory, it  
> fails to find
> the rar in the repository:
>
> activemq/activemq-ra/3.2.1/rar
>
> The correct behavior is that maven should have download this from  
> the remote
> repository to the local repo (? Is that right?)

yes
> But somehow this did not
> happen, and the build failed.  I have tried for many times over a  
> period of 2
> weeks to get the latest source and rebuild, but always resulted in  
> the same
> build error.  So this tells me that the problem is probably not
> network-related, but some build dependency issue.

Yes.  It is difficult to be sure you have found all the dependencies  
in a j2ee plan because the geronimo plan can have dependencies to  
rars (and other j2ee artifacts) that refer directly to the maven (or  
geronimo) repository.  These dependencies aren't needed in the  
project.xml in order to build the configuration so long as the  
artifacts are actually in the repo.  In this case we missed activemq  
and the derby-embed-xa connector.  I've added the missing  
dependencies to the daytrader-tomcat and daytrader-jetty configs in  
head, so the build should work now.


>
> My 'hack' was to manually move the whole directory
> './config/daytrader-tomcat' else where so that it does not get  
> built.  Now
> run 'maven new', the build will proceed further before hitting another
> problem due to some dependencies not present (as a result of mving the
> daytrader-tomcat folder).

Unless the missing dependency was on the daytrader car files, can you  
figure out what else was missing and tell us?


> But now if I check back to .maven folder I do see
> the activemq/activemq-ra/3.2.1/rar correctly downloaded.
>
> Next, I mv back the daytrader-tomcat folder and do 'maven new'  
> again.  This
> time, the build completes successfully.
>
> If anyone sees anything wrong with this 'hack', I would appreciate  
> your
> comment.

It worked, so that is good, but it's better to find the missing  
dependencies and add them to the project.xml.

thanks
david jencks
>
> Henry
>
>
> -----Original Message-----
> From: Dain Sundstrom [mailto:dain@iq80.com]
> Sent: Saturday, December 24, 2005 10:25 AM
> To: user@geronimo.apache.org
> Subject: Re: fail to build with
>
>
> On Dec 23, 2005, at 3:27 PM, Nicholas Irving wrote:
>> am I not using the correct repo? http://ibiblio.org/maven/axis/jars/
>> axis-1.4-356167.jar does not seem to exist.
> It is here http://cvs.apache.org/repository/axis/jars/
> axis-1.4-356167.jar
>
> You may have tried to build during a server outage; I'd just try
> building again.
>
> -dain
>


Mime
View raw message