geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Hogstrom <m...@hogstrom.org>
Subject Re: Running SPECjAppServer2004
Date Fri, 09 Dec 2005 17:40:22 GMT
Vasily,

I will endeavor to get a remote setup to emulate what you are doing with SPECj 
but that won't be to next week.  It sounds like you've made some good progress 
and I hope the provided DDs were helpful.  I'd like to incorporate your changes 
and get them put into the sandbox/specj2004 to keep current.

Have you been able to execute all transactions successfully in both the Dealer 
Domain as well as the Mfg domain from a browser?  I would start there to ensure 
the entire benchmark is functional before running the driver.

Can you confirm that all DB interactions are working?

Matt

Zakharov, Vasily M wrote:
> Hello, all.
> 
> I see the following OEJP error when trying to start the
> SPECjAppServer2004 on Geronimo 1.0 M5:
> 
> javax.naming.AuthenticationException: Cannot read the response from the
> server (OEJP/2.0) : null; nested exception is: 
> 	java.io.EOFException
> 	at
> org.openejb.client.JNDIContext.authenticate(JNDIContext.java:196)
> 	at
> org.openejb.client.JNDIContext.getInitialContext(JNDIContext.java:181)
> 	at javax.naming.spi.NamingManager.getInitialContext(Unknown
> Source)
> 	at javax.naming.InitialContext.getDefaultInitCtx(Unknown Source)
> 	at javax.naming.InitialContext.init(Unknown Source)
> 	at javax.naming.InitialContext.<init>(Unknown Source)
> 	at
> org.spec.jappserver.driver.Auditor.getAuditBeans(Auditor.java:115)
> 	at
> org.spec.jappserver.driver.Auditor.validateInitialValues(Auditor.java:18
> 1)
> 	at org.spec.jappserver.driver.Driver.configure(Driver.java:330)
> 	at org.spec.jappserver.driver.Driver.<init>(Driver.java:160)
> 	at org.spec.jappserver.driver.Driver.main(Driver.java:1137)
> 
> Has anybody tried to run SPECjAppServer2004 on Geronimo and/or seen an
> issue similar to this? If yes, have you encountered this problem, and
> have you got past it?  Any advise as to what I should try next would be
> appreciated.
> 
> Additional detail follows.
> 
> I'm trying to deploy and run SPECjAppServer2004 benchmark
> (http://www.spec.org/jAppServer2004/) on Geronimo 1.0 M5 using built-in
> Derby database.
> 
> I've generally followed the SPECjAppServer2004 deployment guide and
> started with downloading Matt Hogstrom's deployment descriptors from
> /geronimo/trunk/sandbox/specjappserver2004/specj2004-deployment-plan.xml
> 
> I had to make some changes to the descriptors though to make them deploy
> successfuly:
> 
> 1. Application parentId="org/apache/geronimo/Server" instead of
> "SPECjAppServerJMS"
> 
> 2. All database references rewritten:
> 
>      <!--<res-ref-name>CorpDataSource</res-ref-name>
>      <jndi-name>jdbc/SPEC</jndi-name>-->
>      <ref-name>jdbc/SPEC</ref-name>
>      <resource-link>CorpDataSource</resource-link>
> 
>    replaced with:
> 
>      <ref-name>CorpDataSource</ref-name>
>      <resource-link>SPEC</resource-link>
> 
>    here SPEC is the name of a Derby database I created.
> 
> 	3. OrdersDataSource renamed to OrdsDataSource.
> 
> After these changes I was able to deploy the SPECjAppServer2004 main
> application EAR.
> 
> Then I installed Tomcat on another (client) machine and deployed
> SPECjAppServer2004 Emulator.war file there.
> 
> Then I tried to run the SPECjAppServer2004 Driver on the same client
> machine - as per SPECjAppServer2004 documentation the Emulator and the
> Driver must run on a machine other than the one Geronimo is running on.
> 
> The Driver connected to Emulator/Tomcat successfuly, and also located
> Geronimo, but couldn't connect to deployed SPECjAppServer2004 beans, due
> to a problem with OpenEJB shown above.
> 
> I also already described that problem in this list in detail in my
> postings under "JNDI remote authentication problem" subject. I overcome
> first of the problems successfuly (with a help from John Sisson), but
> the second problem (shown above) stopped me completely.
> 
> Thank you.
> 
> With best regards,
>    Vasily Zakharov, Intel Managed Runtime Division
> 
> 
> 
> 


Mime
View raw message