geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krishnakumar B <www....@gmail.com>
Subject Admin Objects reeference in WAR
Date Thu, 08 Dec 2005 08:16:29 GMT
hi,

I am trying to create a reference to Admin Objects ( Queue ) in WAR. I get a
Unable to resolve resource reference ( No matching resource found )
during deployment.

My ra.xml contains

<adminobject>
<adminobject-interface>javax.jms.Queue</adminobject-interface>
<adminobject-class>com.test.connector.QueueImpl</adminobject-class>
<config-property>
<config-property-name>PhysicalName</config-property-name>
<config-property-type>java.lang.String</config-property-type>
</config-property>
</adminobject>

geronimo-ra.xml contains

<adminobject>
        <adminobject-interface>javax.jms.Queue</adminobject-interface>
        <adminobject-class>com.test.connector.QueueImpl</adminobject-class>
        <adminobject-instance>
            <message-destination-name>ivtQ</message-destination-name>
            <config-property-setting
name="PhysicalName">TEST.QUEUE</config-property-setting>
        </adminobject-instance>
</adminobject>

web.xml contains

<resource-ref id="ResourceRef_1134025819148">
    	<res-ref-name>jms/ivtQ</res-ref-name>
    	<res-type>javax.jms.Queue</res-type>
    	<res-auth>Container</res-auth>
    	<res-sharing-scope>Shareable</res-sharing-scope>
 </resource-ref>

and

geronimo-web.xml contains

<naming:resource-ref xmlns="http://geronimo.apache.org/xml/ns/naming">
        <naming:ref-name>jms/ivtQ</naming:ref-name>
        <naming:resource-link>ivtQ</naming:resource-link>
</naming:resource-ref>

The Admin Object GBeans are started and running

 [GBeanInstanceState] GBeanInstanceState for:
geronimo.server:J2EEApplication=null,J2EEServer=geronimo,JCAResource=test/jms.rar,j2eeType=JCAAdminObject,name=ivtQ
State changed from stopped to starting
[GBeanInstanceState] GBeanInstanceState for:
geronimo.server:J2EEApplication=null,J2EEServer=geronimo,JCAResource=test/jms.rar,j2eeType=JCAAdminObject,name=ivtQ
State changed from starting to running

One of the posts says Connector should be part of EAR. I am deploying
Connector and WAR separately.

Any help or ideas would be great...

Regards
Krishnakumar B

Mime
View raw message