geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: Eclipse 3.1.1 plugin problems --cannot publish apps
Date Thu, 22 Dec 2005 21:35:33 GMT
Nevermind, I found the problem.  In the future, eclipse plugin errors/ 
exceptions can be found in the .log in the workspace metadata.  So  
you shouldn't just look for errors in the geronimo log.

I just published and found a NPE attempting to discover the  
deploymentFactory.  Something must have changed in the runtime that  
broke me... I'll look into it.


- sachin



On Dec 22, 2005, at 4:21 PM, Sachin Patel wrote:

> Ok, then please describe your steps, from project creation, to  
> deployment.
>
> - sachin
>
>
>
> On Dec 22, 2005, at 4:16 PM, Lin Sun wrote:
>
>> I am not seeing any error in the geronimo server log.   Any other  
>> logs I can check?
>>
>> Thanks, Lin
>>
>> --- Sachin Patel <sppatel2@gmail.com> wrote:
>>
>>> What is the error you are getting?
>>>
>>> - sachin
>>>
>>>
>>>
>>> On Dec 22, 2005, at 3:15 PM, Lin Sun wrote:
>>>
>>>> I tried a simple hello war program and cannot publish it via the
>>>> eclipse plugin.
>>>>
>>>> I am using:
>>>>
>>>> Geronimo 1.0, built a few days ago
>>>> Eclipse SDK 3.1.1
>>>> WTP 1.0 RC 5 and its prerequisites
>>>> Eclipse plug-in, built a few days ago
>>>>
>>>> Anyone able to publish some war file via the plugin?
>>>>
>>>> Thanks, Lin
>>>>
>>>> --- Sachin Patel <sppatel2@gmail.com> wrote:
>>>>
>>>>> The editors are being rewritten properly to move to a EMF based
>>>>> editors.  I recently started this, so most likely the editors are
>>>>> broken.
>>>>>
>>>>> The XML Source view and the design view are not synchronized.  The
>>>>> design view always shows the in-memory view of the model, and the
>>>>> source view shows the serialized version of the model.   
>>>>> Modifying the
>>>>> XMLSource view does not reflect the model, unless the model is
>>>>> completley reloaded by closing and reopening the editors.   
>>>>> Having a
>>>>> synchronized source view is possible, but will be a very  
>>>>> challenging
>>>>> task I have not yet looked into tackling.  Any code donations for
>>>>> this functionality will be greatly appreciated.
>>>>>
>>>>> As far as the deploy error, Geronimo M5 is not supported.  The
>>>>> plugins package the 1.0 deployment jars, and there will be no
>>>>> backward compatibility support to M5.  The Geronimo Eclipse plugin
>>>>> will only support every released version of the Geronimo, but not
>>>>> milestone drivers.
>>>>>
>>>>> - sachin
>>>>>
>>>>>
>>>>>
>>>>> On Dec 22, 2005, at 12:32 PM, Rajiv M wrote:
>>>>>
>>>>>> Hello,
>>>>>>
>>>>>> I tried a web app on the following environment - a jsp which  
>>>>>> uses a
>>>>>> mySQL JDBC resource
>>>>>> Geronimo 1.0 MD5
>>>>>> Eclipse SDK 3.1.1
>>>>>> WTP 1.0 RC 5
>>>>>> Eclipse plug-in latest build from Geronimo site.
>>>>>>
>>>>>> I observed the following issues:
>>>>>> 1. If i try to add a resource via Naming tab, on the first  
>>>>>> click I
>>>>>> get an error, which does not describe anything but to verify
>>>>>> workspace ".log". A missing resource exception is logged here..
>>>>>>
>>>>>> 2. Any resource added in the resource dialog are not getting
>>>>>> reflected in the Naming screen when clicked OK.
>>>>>>
>>>>>> 3. Resource references present in the XML Source view disappear
>>>>>> when Naming view is selected
>>>>>> 4. App does not deploy and fails at config store creation. There
>>>>>> are no exception traced in server.log but an exception is  
>>>>>> logged in
>>>>>> the workspace log
>>>>>>
>>>>>> ~Rajiv
>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>> 	
>>>> 		
>>>> __________________________________
>>>> Yahoo! for Good - Make a difference this year.
>>>> http://brand.yahoo.com/cybergivingweek2005/
>>>
>>>
>>
>>
>>
>> 	
>> 		
>> __________________________________
>> Yahoo! for Good - Make a difference this year.
>> http://brand.yahoo.com/cybergivingweek2005/
>


Mime
View raw message