geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guglielmo.Licht...@instinet.com
Subject Re: Messing with the terminal
Date Fri, 25 Nov 2005 18:14:33 GMT
I guess it's just that cat repeats all the characters to the terminal and 
the terminal re-interprets
the escape sequences.

This would actually be a convenient way to test terminal behavior - you 
can type escape sequences
into a file and go "cat <file>" to see what it will do ...





Guglielmo Lichtner
11/25/2005 10:11 AM


        To:     user@geronimo.apache.org
        cc:     ammulder@gmail.com, user@geronimo.apache.org
        Subject:        Re: Messing with the terminal

I just want to add that the escape sequences show up under tail -f (I use 
less with shift-f), but
typing "cat <log>" just prints "x% done" (only one of them) - not sure 
why.





Guglielmo.Lichtner@instinet.com
11/25/2005 09:39 AM
Please respond to user

 
        To:     user@geronimo.apache.org
        cc:     ammulder@gmail.com, user@geronimo.apache.org
        Subject:        Re: Messing with the terminal



It looks like it works now. I didn't change anything. It's possible that 
yesterday the output that was whizzing by 
was coming from the server's jvm, not the deployer's which would explain 
why it couldn't be redirected. 

BTW, the startup sequence is cute, meaning 10%/20%/30%... etc. but when 
redirect the output to a file you can 
see the vt100 escape sequences you are using (or whatever they are) and it 
looks bad. IMHO I don't think it's 
worth it. 

However, if someone decides to write a vt100-compatible admin console into 
the running server that would be 
very cool. 

Thanks 
Guglielmo 




Aaron Mulder <ammulder@alumni.princeton.edu> 
Sent by: ammulder@gmail.com 
11/24/2005 05:05 PM 
Please respond to user 
        
        To:        user@geronimo.apache.org 
        cc:         
        Subject:        Re: Messing with the terminal



Does it help to put the "2>&1" before the "> dump"?  Also I think you
should be OK with just "> dump" as opposed to "1> dump".  So :

java -jar bin/deployer.jar deploy plan.xml 2>&1 >dump

Aaron

On 11/24/05, Guglielmo.Lichtner@instinet.com
<Guglielmo.Lichtner@instinet.com> wrote:
>
> I am having extreme difficulty capturing stderr and stdout to redirect 
to
> the file when I do this:
>
> java -jar bin/deployer.jar deploy <plan> 1>dump 2>&1
>
> I have even tried putting it in a shell script and even putting { } 
around
> it (which should have made no difference anyway).
>
> As a result it is impossible for me to capturing a big stack trace which 
is
> coming out.
>
> Is this behavior intended?
>
> *****************************************************************
>  <<>>
>
>  In compliance with applicable rules and regulations, Instinet
>  reviews and archives incoming and outgoing email communications,
>  copies of which may be produced at the request of regulators.
>  This message is intended only for the personal and confidential
>  use of the recipients named above. If the reader of this email
>  is not the intended recipient, you have received this email in
>  error and any review, dissemination, distribution or copying is
>  strictly prohibited. If you have received this email in error,
>  please notify the sender immediately by return email and
>  permanently delete the copy you received.
>
>  Instinet accepts no liability for any content contained in the
>  email, or any errors or omissions arising as a result of email
>  transmission. Any opinions contained in this email constitute
>  the sender's best judgment at this time and are subject to change
>  without notice. Instinet does not make recommendations of a
>  particular security and the information contained in this email
>  should not be considered as a recommendation, an offer or a
>  solicitation of an offer to buy and sell securities.
>
> *****************************************************************
>






Mime
View raw message