geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Snyder <bruce.sny...@gmail.com>
Subject Re: Why naming service is not available when Servlet is initializing?(Tomcat 5.5.9)
Date Fri, 04 Nov 2005 06:28:25 GMT
On 11/3/05, Jian Liao <norwaywoods@gmail.com> wrote:
> All,
>  I'm trying to integrate jetspeed 2 with geronimo(svn head) and tomcat-5.5.9
> as web container.
>  The deployment is successful. But Jetspeed will initialize OJB in
> JetspeedServlet.init() method which needs to obtain resource jdbc/jetspeed
> through JNDI. It just can not get it cause the context is never bind to the
> thread.
>
>  I try it with Jetty and it works because ComponentContextBeforeAfter is
> called.
>
>  I am wondering if I am not allowed to do any JNDI operation in
> Servlet.init()?

Have you tried this in Tomcat running standalone? When you tried it
with Jetty, was Jetty running standalone or within Geronimo?

Bruce
--
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

The Castor Project
http://www.castor.org/

Apache Geronimo
http://geronimo.apache.org/

Mime
View raw message