geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hans Prueller <hans.pruel...@gmx.net>
Subject Re: Unsupported Major.Minor Version?
Date Fri, 25 Nov 2005 06:42:25 GMT
It is strange somehow: the .ear file is build with Apache ANT running a 
1.5 JVM but all compiler options are set so strict 1.4 compatibility,
WASCE/Geronimo itself runs on 1.4.2_07 and produces this error 
regardless of the compat switches of the compiler. When building the
.ear with 1.4 too, it worked!

thank you.

hans

Matt Hogstrom schrieb:
> Hello Hans,
>
> Here is a link to the Sun website that I think describes your problem: 
> http://forum.java.sun.com/thread.jspa?threadID=667600&tstart=120
>
> As you suspected.  It looks to be JDK 1.5 related.
>
> Cheers,
>
> Matt
>
> Hans Prueller wrote:
>> Hi toghether,
>>
>> when I try to deploy my first self-built test.ear project within 
>> Geronimo / WASCE I get the
>> following error message:
>>
>> java -jar .\bin\deployer.jar --user system --password manager deplo
>> y test.ear test-plan.xml
>>    Error: Unable to distribute test.ear: Error thrown during invocation
>>
>>        test/interfaces/Business (Unsupported major.minor version 49.0)
>>
>> Can anybody give me a tip? The .ear file was built by using a jvm1.5 
>> but with
>> strict 1.4 compliance. could that be a problem?
>>
>> regards,
>> Hans
>>
>>
>
>

-- 

*****
virtually hanzz... 
http://hanzz.zapto.org
***** 


Mime
View raw message