geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacek Laskowski <jlaskow...@apache.org>
Subject Re: Petstore : No configuration with id
Date Wed, 02 Nov 2005 21:51:00 GMT
Carla Cremers wrote:

> pushd ../../../../modules/assembly/target/geronimo-1.0-SNAPSHOT 

I didn't know the command - pushd - existed. Thanks!

> maven -o > & maven.out 

What operating system are you working on? It's not MS Windows, is it?

> /home/cremers/java_apps/web_servers/geronimo_tot/nov_1
> /geronimo_nov_1/sandbox/petstore/src/sql/petstore1.3.2.sql
>     [sql] 13 of 13 SQL statements executed successfully
> BUILD SUCCESSFUL
> 
> Getting it to start, 

Excellent!

> though : tried starting Petstore from
> console/Applications/Application Ears : 
> 
> 15:58:18,594 ERROR [GBeanInstanceState] Error while starting; GBean is now in
> th
> e FAILED state:
> objectName="geronimo.config:name="org/apache/geronimo/PetStore1.
> 3.2""

I have never done it before, so I can't comment on the issue. If you 
could pinpoint the root cause I'd be more than happy ;)

> org.apache.geronimo.kernel.GBeanNotFoundException:
> geronimo.config:name="org/apa
> che/geronimo/PetStoreDataSource1.3.2" not found

I'd bet it's because of some earlier errors, but I'm just guessing.

> Tried starting using "maven -o petstore:start" : once with server up, once
> with server down : 

Well, the petstore:start command starts up a Geronimo instance and waits 
till it's up. You don't need to start it up manually before the command 
is executed. Anyway, it should work, too.

> petstore:start:
>     [echo] Waiting for server at:
> /home/cremers/java_apps/web_servers/geronimo_t
> ot/nov_1/geronimo_nov_1/sandbox/petstore/target/geronimo-1.0-SNAPSHOT
> Booting Geronimo Kernel (in Java 1.4.2_03)...
> Geronimo startup failed:
> org.apache.geronimo.kernel.config.NoSuchConfigException: No configuration
> with i
> d: org/apache/geronimo/PetStore1.3.2

Since I'm running it without any troubles, especially such bizarre ones, 
would you rebuild the petstore module once again and run it without 
first executing it via the console? I have no idea what might cause it, 
and the less it's different than I usually do the better.

Jacek

Mime
View raw message