geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nell Gawor <nell_ga...@hotmail.com>
Subject Re: Application Client Stops Running
Date Mon, 10 Oct 2005 20:17:58 GMT
Hi,

I've spent some time looking at this now and I think I've figured out 
what's going on.  What this client application does within its main 
method is run some code that starts the GUI and a thread to listen for 
updates.
Once it starts the thread, the main method exits, returning control to 
the container, which then prints those ominous messages like

 > 12:03:20,584 INFO  [CommandLine] Server shutdown begun
 > 12:03:20,584 DEBUG [GBeanInstanceState] GBeanInstanceState for:
 > geronimo.config:name="org/apache/geronimo/ClientSystem" State changed
 > from running to stopping

But in fact, all the key threads (the GUI thread and the the thread 
listening for updates), continue to run even though control has returned 
to the client container. Which is what I would expect, but those 
messages threw me for a loop and made me think my threads had been killed.

Is there a way to improve these messages so that it doesn't look like 
things are stopping or shutting down until all the threads have exited?

Thanks,
Nell

Nell Gawor wrote:

> <snip>
>
>> --- Nell Gawor <nell_gawor@hotmail.com> wrote:
>>
>> > I am using M5.  In client.log with debug level set to ALL, I am still
>> > not seeing any errors:
>> >
>> > 12:03:00,815 DEBUG [GBeanSingleReference] Waiting to start
>> >
>> geronimo.client:J2EEApplication=client-application,J2EEServer=client,j2eeType=ResourceAdapterModule,name=activemq/rars/activemq-ra-3.2-M1.rar

>>
>> >
>> > because no targets are running for reference J2EEServer matching the
>> > patternspatterns geronimo.client:j2eeType=J2EEServer,name=client
>> > 12:03:00,815 DEBUG [GBeanSingleReference] Waiting to start
>> >
>> geronimo.client:J2EEApplication=client-application,J2EEServer=client,j2eeType=ResourceAdapterModule,name=activemq/rars/activemq-ra-3.2-M1.rar

>>
>> >
>> > because no targets are running for reference J2EEApplication matching
>> > the patternspatterns
>> > 
>> geronimo.client:J2EEServer=client,j2eeType=J2EEApplication,name=client-application

>>
>> >
>> > 12:03:00,815 DEBUG [GBeanInstanceState] GBeanInstanceState for:
>> > geronimo.client:type=ClientContainer State changed from stopped to 
>> starting
>> > 12:03:00,866 DEBUG [GBeanInstanceState] GBeanInstanceState for:
>> > geronimo.client:type=ClientContainer State changed from starting to 
>> running
>> > 12:03:00,866 INFO  [CommandLine] Server startup completed
>> > 12:03:03,199 INFO  [ActiveMQConnection] channel status changed: 
>> Channel:
>> > TcpTransportChannel:
>> > Socket[addr=localhost/127.0.0.1,port=61616,localport=3339] has 
>> connected
>> > 12:03:20,584 INFO  [CommandLine] Server shutdown begun
>> > 12:03:20,584 DEBUG [GBeanInstanceState] GBeanInstanceState for:
>> > geronimo.config:name="org/apache/geronimo/ClientSystem" State changed
>> > from running to stopping
>> > 12:03:20,584 DEBUG [GBeanInstanceState] GBeanInstanceState for:
>> >
>> geronimo.client:J2EEApplication=null,J2EEModule=org/apache/geronimo/ClientSystem,J2EEServer=client,j2eeType=ConfigurationManager,name=ConfigurationManager

>>
>> >
>> > State changed from running to stopping
>> >
>> > There's nothing in the geronimo log around the same timestamp.
>> >
>> > Thanks,
>> > Nell
>> >
>> <snip>
>> > > Nell Gawor escribió:
>> > >
>> > > > Hi,
>> > > >
>> > > > I am experiencing the same problem reported in the below 
>> email.  My
>> > > > application client starts nicely and then just as nicely exits 
>> without
>> > > > indicating any problems... I didn't see any resolution to the 
>> email
>> > > > below -- is this a known problem?
>> > > >
>> > > > Thanks,
>> > > > Nell
>



Mime
View raw message