geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carla Cremers" <crem...@azulsystems.com>
Subject Petstore Redux
Date Fri, 28 Oct 2005 23:29:12 GMT
Trying to get my Petstore up and running after Jacek's last response.  I did

an svn update in the sandbox/petstore, and got new files.  That gave me a

strange error :

 

[echo] Distributing Java Pet Store Supplier Application

[java]     Error: Operation failed: org.apache.xmlbeans.XmlException: Invalid

[java]     deployment descriptor: [error: cvc-complex-type.4: Expected

[java]     attribute: realm-name in element

[java]     default-principal@http://geronimo.apache.org/xml/ns/security-1.0,

 

[java]     error: cvc-complex-type.2.4a: Expected elements

[java]     'description@http://geronimo.apache.org/xml/ns/security-1.0

[java]     realm@http://geronimo.apache.org/xml/ns/security-1.0

[java]     distinguished-name@http://geronimo.apache.org/xml/ns/security-1.0'

[java]     instead of

[java]     'principal@http://geronimo.apache.org/xml/ns/security-1.0' here in

[java]     element role@http://geronimo.apache.org/xml/ns/security-1.0]

[java]

[java]     Descriptor: <xml-fragment

[java]     parentId="org/apache/geronimo/PetStoreDataSource1.3.2"

[java]     configId="org/apache/geronimo/Supplier1.3.2"

[java]     xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.0"

[java]     xmlns:app="http://geronimo.apache.org/xml/ns/j2ee/application-1.0"

[java]     xmlns:sec="http://geronimo.apache.org/xml/ns/security-1.0">

[java]

[java]       <dep:import>

[java]

[java]         <dep:uri>org/apache/geronimo/PetStoreSecurity1.3.2</dep:uri>

[java]

[java]       </dep:import>

[java]

[java]       <app:module>

[java]

[java]         <app:ejb>supplierpo-ejb.jar</app:ejb>

[java]

[java]         <openejb-jar configId="NOT_USED"

[java]     xmlns="http://www.openejb.org/xml/ns/openejb-jar-2.0"

 

Poked at it for while, finally concluded changes had probably been made in

other parts so I did ( BIG MISTAKE ! ) a svn update in the root directory.

Lots and lots of changes to the security stuff.  Ah ha, sez I, all I need

to do is rebuild and I'm in the Petstore business !   Famous last words...

I can't even get back to a geronimo server that will come back up !

 

Right now, I'm doing  "svn update -r (value)" in hopes that I can find a

value for update that will get me to a point that is before the update that

caused the following problem.    Does anybody have a Known Last

Good revision number or a way to find geronimo-spec-j2ee-jacc-1.0-rc5.jar ?

 

 

15:55:23,468 WARN  [DependencyVerifier] WARNING: Failed to download
geronimo-spe

c-j2ee-jacc-1.0-rc5.jar.

 

BUILD FAILED

File......
/home/cremers/.maven/cache/maven-multiproject-plugin-1.3.1/plugin.jel

ly

Element... maven:reactor

Line...... 217

Column.... 9

The build cannot continue because of the following unsatisfied dependency:

 

geronimo-spec-j2ee-jacc-1.0-rc5.jar

 

Total time: 2 minutes 32 seconds

 


Mime
View raw message