geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Iñigo <...@nodo50.org>
Subject Re: unknown or ambigous connectionFactory
Date Thu, 18 Aug 2005 21:54:10 GMT
If I run list-modules I see my data source module listed. I have tried 
changing the parentId with the pool configId but I still get the same 
message. And the same happens whith the jdbc in the lookup. By the way, 
although the ref-link is just MysqlDataSource, the lookup must be 
java:comp/env/jdbc/MysqlDataSource?

Aaron Mulder escribió:

>	What do you see if you run:
>
>java -jar bin/deployer.jar list-modules --started
>
>	In particular, do you see the your data source module listed?  If 
>not, you may need to run:
>
>java -jar bin/deployer.jar start your-module-configId
>
>	(you can also run the list-modules command without --started to 
>see everything in the server whether started or not)
>
>	You might also set the parentId in your geronimo-web.xml to be the 
>configId of the data source module, which will force it to always load the 
>data source before loading your web app.
>
>	Also, in your code, your lookup should use 
>java:comp/env/jdbc/MysqlDataSource  (in your e-mail below you left out the
>jdbc/ part though you had it in the deployment descriptors)
>
>Aaron
>
>  
>


Mime
View raw message