geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Schmidt <schmidt...@gmail.com>
Subject Re: Web Service tests
Date Sun, 12 Jun 2005 06:21:13 GMT
Hi Jeremy,

thanks for your fixes to the problem. The JAX-RPC Service Endpoint 
example works now nicely (apart from a  warning).

However, when I try to deploy the JAX-RPC EJB Endpoint example I still 
get the following error:

[...]
16:10:57,915 ERROR [GBeanInstanceState] Error while starting; GBean is 
now in th
e FAILED state: objectName="openejb:type=WSContainer,name=HelloBean"
java.lang.NoSuchMethodError: 
org.apache.geronimo.webservices.SoapHandler.addWebService(Ljava/lang/String;Lorg/apache/geronimo/webservices/WebServiceContainer;)V
        at org.openejb.server.axis.WSContainer.<init>(WSContainer.java:87)
[...]

Could you indicate if this error was caused by a Geronimo bug or rather 
a bad descriptor (or mapping)?

If you like I can provide the hello-ejb.jar example file from the jBoss 
4 documentation for you to see the error yourself.

Have you got any simple JAX-RPC EJB endpoint example working on Geronimo 
that you could share here?

Thanks,

Stefan

Jeremy Boynes wrote:

> Quick question - are you using the current HEAD build? There were a 
> couple of bugs in our JAF implementation which would lead to similar 
> failures to the first one which I checked fixes in for earlier this week.
>
> -- 
> Jeremy
>
> Stefan Schmidt wrote:
>
>> Hi,
>>
>> I am currently trying to get some JAX-RPC Web services running on 
>> Geronimo. Since there are not too many examples out there I chose to 
>> try the jBoss examples which are described here: 
>> http://docs.jboss.org/jbossas/jboss4guide/r2/html/ch12.html.
>>
>> After inserting a proper url in the HelloService.wsdl (<soap:address 
>> location="http://localhost:8080/hello-servlet/Hello?WSDL"/>) I was 
>> able to deploy the war file with the JSE Web Service.
>>
>> The problem here is if I invoke 
>> http://localhost:8080/hello-servlet/Hello?method=hello&s=test I get 
>> the following SOAP-Fault:
>> [....]
>> <faultcode>soapenv:Server.userException</faultcode>
>> -
>>    <faultstring>
>> org.xml.sax.SAXParseException: Premature end of file.
>> </faultstring>
>> [...]
>>
>> ..when I use the supplied Client I get the following error:
>> [..]
>>     [java]  faultString: Tried to invoke method public abstract 
>> java.lang.String org.jboss.chap12.hello.Hello.hello(java.lang.String) 
>> throws java.rmi.RemoteException with arguments java.lang.String.  The 
>> arguments do not match the signature.; nested exception is:
>>     [java]     java.lang.IllegalArgumentException: object is not an 
>> instance of declaring class
>> [...]
>>
>> In a second attempt I tried to deploy the hello-ejb.jar example which 
>> serves as an EJB endpoint. Unfortunately I get a exception during 
>> deployment:
>> [...]
>> 558 WARN  [BasicLifecycleMonitor] Exception occured while notifying 
>> listener
>> java.lang.NoSuchMethodError: 
>> org.apache.geronimo.webservices.SoapHandler.addWebService
>> (Ljava/lang/String;Lorg/apache/geronimo/webservices/WebServiceContainer;)V 
>>
>>        at 
>> org.openejb.server.axis.WSContainer.<init>(WSContainer.java:87)
>> [...]
>>
>> Both of these Applications work perfectly in jBoss and I can't see 
>> why they shouldn't work in Geronimo.
>>
>> I would be grateful if someone could try to deploy these applications 
>> as well and tell me whether this is rather my problem or a Geronimo 
>> Problem.
>>
>> Thanks in advance.
>>
>> Stefan
>
>
>


Mime
View raw message