geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Schmidt <schmidt...@gmail.com>
Subject Web Service tests
Date Sat, 11 Jun 2005 05:00:45 GMT
Hi,

I am currently trying to get some JAX-RPC Web services running on 
Geronimo. Since there are not too many examples out there I chose to try 
the jBoss examples which are described here: 
http://docs.jboss.org/jbossas/jboss4guide/r2/html/ch12.html.

After inserting a proper url in the HelloService.wsdl (<soap:address 
location="http://localhost:8080/hello-servlet/Hello?WSDL"/>) I was able 
to deploy the war file with the JSE Web Service.

The problem here is if I invoke 
http://localhost:8080/hello-servlet/Hello?method=hello&s=test I get the 
following SOAP-Fault:
[....]
<faultcode>soapenv:Server.userException</faultcode>
-
    <faultstring>
org.xml.sax.SAXParseException: Premature end of file.
</faultstring>
[...]

..when I use the supplied Client I get the following error:
[..]
     [java]  faultString: Tried to invoke method public abstract 
java.lang.String org.jboss.chap12.hello.Hello.hello(java.lang.String) 
throws java.rmi.RemoteException with arguments java.lang.String.  The 
arguments do not match the signature.; nested exception is:
     [java]     java.lang.IllegalArgumentException: object is not an 
instance of declaring class
[...]

In a second attempt I tried to deploy the hello-ejb.jar example which 
serves as an EJB endpoint. Unfortunately I get a exception during 
deployment:
[...]
558 WARN  [BasicLifecycleMonitor] Exception occured while notifying listener
java.lang.NoSuchMethodError: 
org.apache.geronimo.webservices.SoapHandler.addWebService
(Ljava/lang/String;Lorg/apache/geronimo/webservices/WebServiceContainer;)V
        at org.openejb.server.axis.WSContainer.<init>(WSContainer.java:87)
[...]

Both of these Applications work perfectly in jBoss and I can't see why 
they shouldn't work in Geronimo.

I would be grateful if someone could try to deploy these applications as 
well and tell me whether this is rather my problem or a Geronimo Problem.

Thanks in advance.

Stefan

Mime
View raw message