geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: Geronimo fails on startup when Jetty port set to 80
Date Wed, 20 Apr 2005 03:18:40 GMT
Scott Anderson <> wrote on 20/04/2005 09:21:10 

> I went into modules/assembly/src/plan/j2ee-server-plan.xml and changed 
> the Jetty port from 8080 to 80, rebuilt the assembly module, and got the 

> following when I tried to start the server...
> Permission denied
>         at Method)
>         at
>         at
>         at<init>(
>         at 
> org.mortbay.util.ThreadedServer.newServerSocket(
>         at
>         at 
> I ran into the above failure on OS X (10.3.9)/JDK 1.4.2 as well as on 
> Fedora Core 3/JDK 1.5.

Could it be that your userid doesn't have privileges to bind to ports < 
1024?  Try a using a port outside the privileged range and see if it 


> I am also interested in testing whether Geronimo/Jetty can work with 
> Apache 1.3 or 2.0 using mod_jk...
> If anyone has tried this, I'd appreciate hearing if it worked and if 
> there were any gotchas that I would need to account for.
> Scott

This e-mail message and any attachments may contain confidential, 
proprietary or non-public information.  This information is intended 
solely for the designated recipient(s).  If an addressing or transmission 
error has misdirected this e-mail, please notify the sender immediately 
and destroy this e-mail.  Any review, dissemination, use or reliance upon 
this information by unintended recipients is prohibited.  Any opinions 
expressed in this e-mail are those of the author personally.

View raw message