geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Boynes <jboy...@apache.org>
Subject Re: deploying minimal web app
Date Fri, 01 Apr 2005 01:15:33 GMT
Scott Anderson wrote:
> I built a minimal war and ran into deployment issues
> with both Jetty and Tomcat...
> 
> Jetty
> -----
> In my first attempt I noticed that Jetty was ignoring
> the context name I had specified in
> META-INF/context.xml and used the name of the war file
> instead. 

I don't think we support context.xml (or jetty-web.xml). Instead you can 
specify the context path in a Geronimo deployment plan - this can be 
placed inside the war's META-INF directory or supplied as an external 
plan to avoid modifying the war.

> Once I figured this out it also appeared that
> Jetty was ignoring the welcome file specified in
> WEB-INF/web.xml and showing the contents of the war
> directory instead. I noticed in the wiki that there is
> an additional descriptor, geronimo-jetty.xml, that I
> might need to support. I tried this and also
> restarting Geronimo with the configId I had set in
> geronimo-jetty.xml and neither attempt was helpful.

You should not need to do that. You can recover the server by copying 
the file config.list from modules/assembly/src/var/config into the 
var/config directory of your installation (this resets the runnning 
config list to what we orginally built) and then start your war using

$ java -jar bin/deployer.jar start ${configid}

> BTW, something I did must have corrupted the
> deployment module because I soon found I could no
> longer deploy at all..
> 
> Deployment failed
>   Server reports: No deployer present in kernel
> 
> Tomcat
> ------

<snip/>
Sorry, I can't help with Tomcat.

> 
> I am planning on integrating Apache Pluto with
> Geronimo and since I do not have any information on
> how compatible Pluto is with Jetty I think my best bet
> is to work on getting the Tomcat issues solved. I'd
> appreciate any suggestions on getting there from here.
> 

Gluecode integrated and certified Pluto 1.0 with Geronimo/Jetty around 
the M3 timeframe as part of our JOE 1.0 release. All the fixes for that 
were contributed back to Pluto so it should work. You do need to use the 
context based registry (not the one that scans the webapp directory) - 
sorry the name eludes me right now.

I am very interested in getting 1.1 to work but just haven't managed to 
get to it - is that the version you were thinking of using?

--
Jeremy

Mime
View raw message