geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From conflue...@apache.org
Subject [CONF] Apache Geronimo v3.0 > Installing Eclipse
Date Wed, 30 Mar 2011 06:17:00 GMT
<html>
<head>
    <base href="https://cwiki.apache.org/confluence">
            <link rel="stylesheet" href="/confluence/s/2042/9/4/_/styles/combined.css?spaceKey=GMOxDOC30&amp;forWysiwyg=true"
type="text/css">
    </head>
<body style="background: white;" bgcolor="white" class="email-body">
<div id="pageContent">
<div id="notificationFormat">
<div class="wiki-content">
<div class="email">
     <h2><s>Installing Eclipse</s></h2>
     <h4>Page <b>removed</b> by             <a href="https://cwiki.apache.org/confluence/display/~chirunhua@gmail.com">Runhua
Chi</a>
    </h4>
     <br/>
     <div class="notificationGreySide">
         

<p><a href="http://www.eclipse.org/" class="external-link" rel="nofollow">Eclipse</a>
provides an extensible development platform and application frameworks for building software.
The Web Tools Platform (WTP) extends the Eclipse platform tools for developing Web and Java
EE applications. They need to be installed as the prerequisite for the Geronimo Eclipse Plugin
(GEP), which is used for developing, deploying and testing Java EE assets on the Geronimo
server. Eclipse and WTP can be installed in the following manners:</p>

<h2><a name="InstallingEclipse-InstallingEclipseIDEforJavaEEDevelopers"></a>Installing
Eclipse IDE for Java EE Developers</h2>
<p>The prerequisite Eclipse software for GEP can be downloaded as a single download,
which is called the Eclipse IDE for Java EE developers. It can be downloaded from the <a
href="http://www.eclipse.org/downloads/" class="external-link" rel="nofollow">Eclipse Downloads
site</a>.  Download and extract the <b>Eclipse IDE for Java EE Developers</b>
archive (for e.g. <tt>eclipse-jee-galileo-win32.zip</tt>), to a directory of your
choice (for e.g. <tt>C:\eclipse</tt>).  The archive will be extracted to a directory
named eclipse under the directory you specified (for e.g. <tt>C:\eclipse\eclipse</tt>),
referred to as <b>&lt;ECLIPSE_HOME&gt;</b> from now on. Launch Eclipse
by running <tt>&lt;ECLIPSE_HOME&gt;/eclipse</tt>.</p>

<h2><a name="InstallingEclipse-DownloadingandinstallingEclipseandWTPseparately"></a>Downloading
and installing Eclipse and WTP separately</h2>
<p>The Eclipse IDE can be downloaded separately from the <a href="http://www.eclipse.org/downloads/"
class="external-link" rel="nofollow">Eclipse Downloads site</a>. Download and extract
the <b>Eclipse SDK</b> archive (for e.g. <tt>eclipse-SDK-3.5-win32.zip</tt>),
to a directory of your choice (for e.g. <tt>C:\eclipse</tt>), referred to as <b>&lt;ECLIPSE_HOME&gt;</b>.
 The archive will be extracted to the directory <tt>&lt;ECLIPSE_HOME&gt;/eclipse</tt>.
</p>

<p>To install WTP, you can download and install WTP manually or install using the Eclipse
Update Manager. Note that you have to install different versions of WTP for Eclipse Galileo
(3.5), Eclipse Ganymede (3.4.x) and Eclipse Europa (only 3.3.2 or equivalent), and follow
different steps to install WTP. </p>

<h3><a name="InstallingEclipse-DownloadWTPmanually"></a>Download WTP manually</h3>
<p>The Web Tools Platform can be downloaded manually from the <a href="http://download.eclipse.org/webtools/downloads/"
class="external-link" rel="nofollow">Eclipse WTP download</a>, and you will be presented
with multiple versions of the WTP. Download the Web Tools Platform Complete archive for your
specific release. </p>
<ul>
	<li>For Eclipse Galileo, extract the archive (for example, wtp-R-3.1-20090616035105.zip)
to the directory <tt>&lt;ECLIPSE_HOME&gt;/eclipse/dropins</tt>.</li>
	<li>For Eclipse Ganymede, extract the archive (for example, wtp-R-3.0.3-20081113203138.zip)
to the directory <tt>&lt;ECLIPSE_HOME&gt;/eclipse/dropins</tt>.</li>
	<li>For Eclipse Europa, extract the archive (for example, wtp-R-2.0.3-20080710044639.zip)
and copy the <b>features</b> and <b>plugins</b> directories into <tt>&lt;ECLIPSE_HOME&gt;/features</tt>
and <tt>&lt;ECLIPSE_HOME&gt;/plugins</tt> respectively.</li>
</ul>


<p><b>Note</b>: Before install WTP on Eclipse Europa, you must have Eclipse
SDK 3.3.2 or higher, and certain software prerequisites installed. See <a href="http://download.eclipse.org/webtools/downloads/drops/R2.0/R-2.0.3-20080710044639/"
class="external-link" rel="nofollow">Web Tools Platform Release 2.0.3</a> for more
details about the prerequisites.</p>

<h3><a name="InstallingEclipse-InstallWTPusingtheEclipseUpdateManager"></a>Install
WTP using the Eclipse Update Manager</h3>
<p>You will follow different procedures in Eclipse Galileo, Eclipse Ganymede and Eclipse
Europa.</p>
<h4><a name="InstallingEclipse-InstallWTPusingtheEclipseGelileoUpdateManager"></a>Install
WTP using the Eclipse Gelileo Update Manager</h4>
<ol>
	<li>Launch Eclipse from <tt>&lt;ECLIPSE_HOME&gt;/eclipse</tt>.</li>
	<li>Select <b>Help</b> -&gt; <b>Install New Software..</b>
from the menu.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" /> <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/install_new_soft.PNG?version=1&amp;modificationDate=1248672423000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>On the <b>Install</b> panel, click <b>Available Software Sites</b>.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" /> <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/available_soft_download.PNG?version=1&amp;modificationDate=1248672423000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>Select <b><a href="http://download.eclipse.org/webtools/updates" class="external-link"
rel="nofollow">http://download.eclipse.org/webtools/updates</a></b> and click
<b>Enable</b>.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" /> <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/enable_wtp.PNG?version=1&amp;modificationDate=1248672423000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>In the field <b>Work with</b> on the <b>Install</b> panel,
select <b>Web Tools (WTP) Update Site - <a href="http://download.eclipse.org/webtools/updates"
class="external-link" rel="nofollow">http://download.eclipse.org/webtools/updates</a></b>
from the list, and expand <b>Web Tool Platform (WTP) 3.1.0</b>.</li>
	<li>Select <b>Eclipse Java EE Developer Tools</b>, and <b>Eclipse
Web Developer Tools</b>. Click <b>Next</b>.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" /> <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/select_wtp.PNG?version=1&amp;modificationDate=1248672423000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>Review the details and click <b>Next</b>.</li>
	<li>Read and accpet the license agreement, and click <b>Finish</b>.</li>
	<li>When installation is complete, restart Eclipse for the changes to take effect.</li>
</ol>


<h4><a name="InstallingEclipse-InstallWTPusingtheEclipseGanymedeUpdateManager%28p2%29"></a>Install
WTP using the Eclipse Ganymede Update Manager(p2)</h4>
<ol>
	<li>Launch Eclipse from <tt>&lt;ECLIPSE_HOME&gt;/eclipse</tt>.</li>
	<li>Select <b>Help</b> -&gt; <b>Software Updates..</b>
from the menu.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" />  <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/fig1.PNG?version=1&amp;modificationDate=1227587284000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" /></li>
	<li>On the next screen select <b>Available Software</b> tab, and expand
<b>Ganymede</b>.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" />  <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/fig2.PNG?version=1&amp;modificationDate=1227587947000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>Expand <b>Web and Java EE Development</b>, select <b>Java EE
Developer Tools</b> and <b>Web Developer Tools</b>.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" />  <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/fig3.png?version=1&amp;modificationDate=1227588105000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>Click <b>Install</b>.</li>
	<li>When installation is complete, restart Eclipse for the changes to take effect.</li>
</ol>


<h4><a name="InstallingEclipse-InstallWTPusingtheEclipseEuropaUpdateManager"></a>Install
WTP using the Eclipse Europa Update Manager</h4>
<p><b>Note</b>: Before install WTP on Eclipse Europa, you must have Eclipse
SDK 3.3.2 or higher, and certain software prerequisites installed. See <a href="http://download.eclipse.org/webtools/downloads/drops/R2.0/R-2.0.3-20080710044639/"
class="external-link" rel="nofollow">Web Tools Platform Release 2.0.3</a> for more
details about the prerequisites.</p>
<ol>
	<li>Launch Eclipse from &lt;ECLIPSE_HOME&gt;/eclipse.</li>
	<li>Select <b>Help</b> -&gt; <b>Software Updates</b> -&gt;
<b>Find and Install..</b> from the menu.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" />  <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/fig4.PNG?version=1&amp;modificationDate=1227763520000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" /></li>
	<li>On the resulting page, select <b>Search for new features to install</b>,
and click <b>Next</b>.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" />  <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/fig5.PNG?version=1&amp;modificationDate=1227763520000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>Select <b>Europa Discovery Site</b>, and click <b>Finish</b>.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" />  <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/fig6.PNG?version=1&amp;modificationDate=1227766118000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>Select your most convenient download site mirror.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" />  <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/fig7.PNG?version=1&amp;modificationDate=1227766237000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>Expand <b>Web and JEE Development</b>, select <b>Web Standard
Tools (WST)</b> and  <b>J2EE Standard Tools(JST)</b>. Note that you must
have the prerequisite softwares installed before installing WTP, otherwise you will get error
messages.
<br class="atl-forced-newline" />
<br class="atl-forced-newline" />  <span class="image-wrap" style=""><img src="/confluence/download/attachments/20645231/fig8.PNG?version=1&amp;modificationDate=1227841787000"
style="border: 0px solid black" /></span><br class="atl-forced-newline" />
<br class="atl-forced-newline" /></li>
	<li>Review the details and click <b>Next</b>.</li>
	<li>Read and accpet the license agreement, and click <b>Finish</b>.</li>
	<li>When installation is complete, restart Eclipse for the changes to take effect.</li>
</ol>



<h2><a name="InstallingEclipse-InstallingEclipseusingAntscriptfromGEPbuild"></a>Installing
Eclipse using Ant script from GEP build</h2>
<p>You can install Eclipse by building souce code of GEP. See <a href="/confluence/display/GMOxDOC30/How+to+Build+Geronimo+Eclipse+Plugin+from+Source"
title="How to Build Geronimo Eclipse Plugin from Source">How to Build Geronimo Eclipse
Plugin from Source</a> for more information. </p>
     </div>
</div>
</div>
</div>
</div>
</body>
</html>

Mime
View raw message