How to install Geronimo Eclipse Plugin v2.1.3 has been created by Ying Tang (Jan 13, 2009).

Content:

Note that with v2.1.3, the v2.1 Geronimo server adapter feature provides server adapters for both the v2.0.x and v2.1.x Geronino servers. Previously, v2.0.x and v2.1.x server adapaters were provided by separate features. Partly to simplify things, these features were combined into one.

Prerequisites

Sun JDK 5.0 can be downloaded from Sun's J2SE 5.0 Downloads site. The Eclipse IDE for Java EE Developers can be downloaded from the Eclipse Downloads site. Download and extract the Eclipse IDE for Java EE Developers archives to a directory of your choice (for e.g. C:\eclipse). The archive will be extracted to a directory named eclipse under the directory you specified (for e.g. C:\eclipse\eclipse), referred to as <eclipse_home> from now on. Make sure that the JDK in the PATH is Sun JDK 5.0. Launch Eclipse by running <eclipse_home>/eclipse.

To install the Geronimo server, download the Geronimo 2.1.3 server from http://www.apache.org/dist/geronimo/ and extract the archive to a directory of your choice (for e.g. C:\g). The archive will be extracted to a directory geronimo-tomcat6-javaee5-2.1.3 (for e.g. C:\g\geronimo-tomcat6-javaee5-2.1.3) or geronimo-jetty6-javaee5-2.1.3 depending on whether you downloaded Geronimo 2.1.3 distribution with Tomcat or Jetty as the web container. We will refer to this directory as <geronimo_home> from now on.

Installing GEP within WTP

  1. Once you have all the Prerequisites installed, launch Eclipse from <Eclipse_Home>/eclipse.
  2. By default Eclipse will be launched with Java EE perspective.
  3. Select the servers tab as shown in the figure and select New->Server.


    Unable to render embedded object: File (figure1.png) not found.


  4. On the next screen select Download Additional Server Adapters as shown in the figure.


    Unable to render embedded object: File (figure2.png) not found.


  5. Select Geronimo V2.1 Server Adapter v2.1.3 adapter and select Next.


    Unable to render embedded object: File (DownLoadServerAdapters.png) not found.


  6. Accept the license agreement and select Finish.


    Unable to render embedded object: File (figure4.png) not found.


  7. Next screen will ask for confirmation. Select Ok. Once done Geronimo V2.1 server adapter will be downloaded and installed.


    Unable to render embedded object: File (figure5.png) not found.


  8. Once the adapter is installed you will be prompted to restart the server. Select Yes.


    Unable to render embedded object: File (figure6.png) not found.


Installing GEP using Eclipse update manager

A video desktop demonstration of Installing the Apache Geronimo Eclipse Plugin with the Eclipse Update Manager is available.

  1. Once you have all the prerequisites installed. Launch Eclipse from <Eclipse_Home>/eclipse.
  2. By default Eclipse will be launched with Java EE perspective.
  3. Select Help->Software Updates.. from the menu.


    Unable to render embedded object: File (figure7.png) not found.


  4. On the next screen select Available Software tab. Select Add Site.
    Unable to render embedded object: File (AddSite.png) not found.


  5. Copy and paste the following site to Add Site window and Select Ok.


    http://apache.org/dist/geronimo/eclipse/updates/

    Unable to render embedded object: File (figure9.png) not found.


  6. Expand http://apache.org/dist/geronimo/eclipse/updates/ and Select Geronimo v2.1 Server Adapter v2.1.3.


    Unable to render embedded object: File (EclipseUpdateMgrScreen.png) not found.


  7. Once done you have to wait a few seconds while Eclipse resolves dependencies.


    Unable to render embedded object: File (figure11.png) not found.


  8. Once done, the Install window will pop up. Select Next.


    Unable to render embedded object: File (ConfirmInstall.png) not found.


  9. Accept the license and Select Finish.


    Unable to render embedded object: File (ReviewLicense.png) not found.


  10. Installation will start and will take time few minutes. A progress window will display the jars being installed.


    Unable to render embedded object: File (figure14.png) not found.


  11. Once GEP is installed you will be prompted to restart. Select yes.
    Unable to render embedded object: File (figure15.png) not found.

Manual Installation

Using updatesite.zip

  1. Download the package geronimo-eclipse-plugin-2.1.3-updatesite.zip from http://apache.org/dist/geronimo/eclipse/2.1.3/.
  2. Once done, unzip the package to a directory on your machine.
  3. Follow the instructions in Installing GEP using Eclipse update manager section. When adding a an update site in step 5, choose Local, and navigate to the directory where you unzipped the updatesite.zip package in the previous step.

Using deployable.zip

  1. Download the package geronimo-eclipse-plugin-2.1.3-deployable.zip from http://apache.org/dist/geronimo/eclipse/2.1.3/.
  2. Once done, unzip the package to your eclipse installation directory. For Ganymede, unzip to the eclipse/dropins directory. You may get a prompt regarding file replacement. Select All.
  3. Restart eclipse with the -clean option.

Verify GEP installation

  1. Select Help->About Eclipse Platform.


    Unable to render embedded object: File (figure16.png) not found.


  2. You can see a G icon in the About Eclipse Platform. This confirms the successful installation of GEP. Click the icon.


    Unable to render embedded object: File (figure17.png) not found.


  3. On the next screen you can view details- License, Plug-in-Details and set the Columns of the table being displayed.


    Unable to render embedded object: File (figure18.png) not found.

Uninstalling GEP

GEP may be uninstalled in a similar manner in which it was installed.

Uninstall does not work well on Ganymede, especially for GEP. It will uninstall GEP, but then you can't reinstall it, as it doesn't really get uninstalled. The only way to reinstall GEP in Ganymede is to reinstall Ganymede itself! See Eclipse Bugzilla 244935 for details, and hopefully a fix soon!

Powered by Atlassian Confluence (Version: 2.2.9 Build:#527 Sep 07, 2006) - Bug/feature request

Unsubscribe or edit your notifications preferences