geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mcco...@apache.org
Subject svn commit: r644570 - in /geronimo/devtools/eclipse-plugin/trunk/plugins: org.apache.geronimo.st.core/ org.apache.geronimo.st.v11.core/ org.apache.geronimo.st.v11.ui/ org.apache.geronimo.st.v20.core/ org.apache.geronimo.st.v20.ui/ org.apache.geronimo.s...
Date Fri, 04 Apr 2008 01:14:23 GMT
Author: mcconne
Date: Thu Apr  3 18:14:22 2008
New Revision: 644570

URL: http://svn.apache.org/viewvc?rev=644570&view=rev
Log:
GERONIMODEVTOOLS-316 Fix Geronimo Deployment 1.2 cannot be installed error messages

Modified:
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.core/plugin.xml
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.core/plugin.xml
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.ui/plugin.xml
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.core/plugin.xml
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.ui/plugin.xml
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.core/plugin.xml
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.ui/plugin.xml

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.core/plugin.xml
URL: http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.core/plugin.xml?rev=644570&r1=644569&r2=644570&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.core/plugin.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.core/plugin.xml
Thu Apr  3 18:14:22 2008
@@ -58,18 +58,6 @@
         <runtime-component-version type="org.apache.geronimo.runtime" version="2.0"/>
         <runtime-component-version type="org.apache.geronimo.runtime" version="2.1"/>
 
-        <!-- The referenced class "org.eclipse.jst.common.project.facet.core.IClasspathProvider"
doesn't exist.
-        Not sure if this is the cause for https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-316.
-        Experimenting by commenting out the entire element below to see if it resolves the
issue.
-        If any further problems, please revert back. -->
-        <!-- <adapter>
-            <runtime-component id="org.apache.geronimo.runtime"/>
-            <factory
-                class="org.eclipse.jst.server.core.internal.RuntimeClasspathProvider$Factory"/>
-            <type
-                class="org.eclipse.jst.common.project.facet.core.IClasspathProvider"/>
-        </adapter> -->
-
         <supported>
             <runtime-component id="org.apache.geronimo.runtime" version="1.1"/>
             <facet id="org.apache.geronimo.facet" version="1.1"/>

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.core/plugin.xml
URL: http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.core/plugin.xml?rev=644570&r1=644569&r2=644570&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.core/plugin.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.core/plugin.xml
Thu Apr  3 18:14:22 2008
@@ -68,15 +68,17 @@
             runtime-component="org.apache.geronimo.runtime" version="1.1"/>
     </extension>
     
-    <!-- =======================================================================================
-->
-    <!--                                                                             
           -->
-    <!-- Declare the 1.1 version of the "Geronimo Deployment" <project-facet> and
the <action>   -->
-    <!-- that the user can perform on the facet (i.e., install)                      
           -->
-    <!--                                                                             
           -->
-    <!-- =======================================================================================
-->
+    
+    <!-- 
+     | 
+     | Declare the 1.1 version of the "Geronimo Deployment" project-facet and the action
+     | that the user can perform on the facet (i.e., install). Note that the id associated

+     | action must be unique across all plugins. 
+     | 
+     -->
     <extension point="org.eclipse.wst.common.project.facet.core.facets">        
         <project-facet-version facet="org.apache.geronimo.facet" version="1.1">
-            <action type="install" id="geronimo.plan.install">
+            <action type="install" id="geronimo.plan.install.v11">
                 <delegate class="org.apache.geronimo.st.v11.core.operations.GeronimoV11FacetInstallDelegate"/>
                 <config-factory class="org.apache.geronimo.st.v11.core.DeploymentPlanInstallConfig$Factory"/>
             </action>

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.ui/plugin.xml
URL: http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.ui/plugin.xml?rev=644570&r1=644569&r2=644570&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.ui/plugin.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v11.ui/plugin.xml
Thu Apr  3 18:14:22 2008
@@ -32,9 +32,15 @@
  	  	<loader class="org.apache.geronimo.st.v11.ui.editors.GeronimoFormContentLoader" version="2.0"/>
     </extension>
 
+    <!-- 
+     |
+     | Map the action defined for the "Geronimo Deployment" project-facet to a specific class
+     |
+     -->
     <extension point="org.eclipse.wst.common.project.facet.ui.wizardPages">
-  		<wizard-pages action="geronimo.plan.install">
+  		<wizard-pages action="geronimo.plan.install.v11">
     		<page class="org.apache.geronimo.st.v11.ui.wizards.FacetInstallPage"/>
   		</wizard-pages>
 	</extension>  
+
 </plugin>

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.core/plugin.xml
URL: http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.core/plugin.xml?rev=644570&r1=644569&r2=644570&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.core/plugin.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.core/plugin.xml
Thu Apr  3 18:14:22 2008
@@ -72,13 +72,14 @@
     
     <!-- 
      | 
-     | Declare the 1.2 version of the "Geronimo Deployment" <project-facet> and the
<action>    
-     | that the user can perform on the facet (i.e., install)                           
      
+     | Declare the 1.2 version of the "Geronimo Deployment" project-facet and the action
+     | that the user can perform on the facet (i.e., install). Note that the id associated

+     | action must be unique across all plugins. 
      | 
      -->
     <extension point="org.eclipse.wst.common.project.facet.core.facets">
         <project-facet-version facet="org.apache.geronimo.facet" version="1.2">
-            <action type="INSTALL" id="geronimo.plan.install">
+            <action type="install" id="geronimo.plan.install.v20">
                 <delegate class="org.apache.geronimo.st.v21.core.operations.GeronimoV21FacetInstallDelegate"/>
                 <config-factory class="org.apache.geronimo.st.v21.core.DeploymentPlanInstallConfig$Factory"/>
             </action>

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.ui/plugin.xml
URL: http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.ui/plugin.xml?rev=644570&r1=644569&r2=644570&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.ui/plugin.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v20.ui/plugin.xml
Thu Apr  3 18:14:22 2008
@@ -28,15 +28,13 @@
  	  	<loader class="org.apache.geronimo.st.v21.ui.editors.GeronimoFormContentLoader" version="2.0"/>
     </extension>
 
-
     <!-- 
      |
-     | Map the <runtime-component> (defined in org.apache.geronimo.st.core\plugin.xml)

-     | to a specific version of the "Geronimo Deployment" <project-facet>
+     | Map the action defined for the "Geronimo Deployment" project-facet to a specific class
      |
      -->
     <extension point="org.eclipse.wst.common.project.facet.ui.wizardPages">
-  		<wizard-pages action="geronimo.plan.install">
+  		<wizard-pages action="geronimo.plan.install.v20">
     		<page class="org.apache.geronimo.st.v21.ui.wizards.FacetInstallPage"/>
   		</wizard-pages>
 	</extension>  

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.core/plugin.xml
URL: http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.core/plugin.xml?rev=644570&r1=644569&r2=644570&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.core/plugin.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.core/plugin.xml
Thu Apr  3 18:14:22 2008
@@ -105,13 +105,14 @@
 
     <!-- 
      | 
-     | Declare the 1.2 version of the "Geronimo Deployment" <project-facet> and the
<action>    
-     | that the user can perform on the facet (i.e., install)                           
      
+     | Declare the 1.2 version of the "Geronimo Deployment" project-facet and the action
+     | that the user can perform on the facet (i.e., install). Note that the id associated

+     | action must be unique across all plugins. 
      | 
      -->
     <extension point="org.eclipse.wst.common.project.facet.core.facets">
         <project-facet-version facet="org.apache.geronimo.facet" version="1.2">
-            <action type="INSTALL" id="geronimo.plan.install">
+            <action type="install" id="geronimo.plan.install.v21">
                 <delegate class="org.apache.geronimo.st.v21.core.operations.GeronimoV21FacetInstallDelegate"/>
                 <config-factory class="org.apache.geronimo.st.v21.core.DeploymentPlanInstallConfig$Factory"/>
             </action>

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.ui/plugin.xml
URL: http://svn.apache.org/viewvc/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.ui/plugin.xml?rev=644570&r1=644569&r2=644570&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.ui/plugin.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.st.v21.ui/plugin.xml
Thu Apr  3 18:14:22 2008
@@ -32,15 +32,13 @@
  	  	<loader class="org.apache.geronimo.st.v21.ui.editors.GeronimoFormContentLoader" version="2.1"/>
     </extension>
 
-
     <!-- 
      |
-     | Map the <runtime-component> (defined in org.apache.geronimo.st.core\plugin.xml)

-     | to a specific version of the "Geronimo Deployment" <project-facet>
+     | Map the action defined for the "Geronimo Deployment" project-facet to a specific class
      |
      -->
     <extension point="org.eclipse.wst.common.project.facet.ui.wizardPages">
-  		<wizard-pages action="geronimo.plan.install">
+  		<wizard-pages action="geronimo.plan.install.v21">
     		<page class="org.apache.geronimo.st.v21.ui.wizards.FacetInstallPage"/>
   		</wizard-pages>
 	</extension>  



Mime
View raw message