geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ga...@apache.org
Subject svn commit: r637287 - /geronimo/server/branches/2.1/framework/modules/geronimo-plugin/src/main/java/org/apache/geronimo/system/plugin/PluginInstallerGBean.java
Date Fri, 14 Mar 2008 21:55:38 GMT
Author: gawor
Date: Fri Mar 14 14:55:30 2008
New Revision: 637287

URL: http://svn.apache.org/viewvc?rev=637287&view=rev
Log:
changed log.error to log.debug and 'cannot install plugin' to 'plugin is not installable'
(GERONIMO-3807)

Modified:
    geronimo/server/branches/2.1/framework/modules/geronimo-plugin/src/main/java/org/apache/geronimo/system/plugin/PluginInstallerGBean.java

Modified: geronimo/server/branches/2.1/framework/modules/geronimo-plugin/src/main/java/org/apache/geronimo/system/plugin/PluginInstallerGBean.java
URL: http://svn.apache.org/viewvc/geronimo/server/branches/2.1/framework/modules/geronimo-plugin/src/main/java/org/apache/geronimo/system/plugin/PluginInstallerGBean.java?rev=637287&r1=637286&r2=637287&view=diff
==============================================================================
--- geronimo/server/branches/2.1/framework/modules/geronimo-plugin/src/main/java/org/apache/geronimo/system/plugin/PluginInstallerGBean.java
(original)
+++ geronimo/server/branches/2.1/framework/modules/geronimo-plugin/src/main/java/org/apache/geronimo/system/plugin/PluginInstallerGBean.java
Fri Mar 14 14:55:30 2008
@@ -879,7 +879,7 @@
                     }
                 }
                 if (!upgrade) {
-                    log.info("Configuration " + artifact + " is already installed.");
+                    log.debug("Configuration " + artifact + " is already installed.");
                     throw new MissingDependencyException(
                             "Configuration " + artifact + " is already installed.", toArtifact(metadata.getModuleId()),
(Stack<Artifact>) null);
                 }
@@ -888,15 +888,14 @@
 
         // 2. Check that we meet the Geronimo, JVM versions
         if (metadata.getGeronimoVersion().size() > 0 && !checkGeronimoVersions(metadata.getGeronimoVersion()))
{
-            log.error("Cannot install plugin " + toArtifact(metadata.getModuleId()) + " on
Geronimo " + serverInfo.getVersion());
+            log.debug("Plugin " + toArtifact(metadata.getModuleId()) + " is not installable
on Geronimo " + serverInfo.getVersion());
             throw new MissingDependencyException(
-                    "Cannot install plugin on Geronimo " + serverInfo.getVersion(), toArtifact(metadata.getModuleId()),
(Stack<Artifact>) null);
+                    "Plugin is not installable on Geronimo " + serverInfo.getVersion(), toArtifact(metadata.getModuleId()),
(Stack<Artifact>) null);
         }
         if (metadata.getJvmVersion().size() > 0 && !checkJVMVersions(metadata.getJvmVersion()))
{
-            log.error("Cannot install plugin " + toArtifact(metadata.getModuleId()) + " on
JVM " + System.getProperty(
-                    "java.version"));
+            log.debug("Plugin " + toArtifact(metadata.getModuleId()) + " is not installable
on JVM " + System.getProperty("java.version"));
             throw new MissingDependencyException(
-                    "Cannot install plugin on JVM " + System.getProperty("java.version"),
toArtifact(metadata.getModuleId()), (Stack<Artifact>) null);
+                    "Plugin is not installable on JVM " + System.getProperty("java.version"),
toArtifact(metadata.getModuleId()), (Stack<Artifact>) null);
         }
     }
 



Mime
View raw message