geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From djen...@apache.org
Subject svn commit: r563580 [3/3] - in /geronimo/plugins/directory: ./ trunk/ trunk/directory/ trunk/directory/src/main/resources/META-INF/ trunk/directory/src/plan/ trunk/geronimo-directory/ trunk/geronimo-directory/src/main/java/org/apache/geronimo/directory...
Date Tue, 07 Aug 2007 17:34:28 GMT
Copied: geronimo/plugins/directory/trunk/pom.xml (from r563259, geronimo/server/trunk/pom.xml)
URL: http://svn.apache.org/viewvc/geronimo/plugins/directory/trunk/pom.xml?view=diff&rev=563580&p1=geronimo/server/trunk/pom.xml&r1=563259&p2=geronimo/plugins/directory/trunk/pom.xml&r2=563580
==============================================================================
--- geronimo/server/trunk/pom.xml (original)
+++ geronimo/plugins/directory/trunk/pom.xml Tue Aug  7 10:34:27 2007
@@ -25,24 +25,24 @@
     <parent>
         <groupId>org.apache.geronimo.genesis.config</groupId>
         <artifactId>project-config</artifactId>
-        <version>1.2-SNAPSHOT</version>
+        <version>1.2</version>
     </parent>
 
-    <groupId>org.apache.geronimo</groupId>
-    <artifactId>geronimo</artifactId>
-    <name>Geronimo</name>
+    <groupId>org.apache.geronimo.plugins</groupId>
+    <artifactId>directory-parent</artifactId>
+    <name>Geronimo Apache Directory Integration</name>
     <packaging>pom</packaging>
 
-    <version>2.1-SNAPSHOT</version>
+    <version>2.0-SNAPSHOT</version>
 
     <description>
-        Apache Geronimo, the J2EE server project of the Apache Software Foundation.
+        Integration of the Apache Directory Server into Apache Geronimo
     </description>
 
     <scm>
-        <connection>scm:svn:http://svn.apache.org/repos/asf/geronimo/server/trunk</connection>
-        <developerConnection>scm:svn:https://svn.apache.org/repos/asf/geronimo/server/trunk</developerConnection>
-        <url>http://svn.apache.org/viewvc/geronimo/trunk</url>
+        <connection>scm:svn:http://svn.apache.org/repos/asf/geronimo/plugins/directory/trunk</connection>
+        <developerConnection>scm:svn:https://svn.apache.org/repos/asf/geronimo/plugins/directory/trunk</developerConnection>
+        <url>http://svn.apache.org/viewvc/geronimo/plugins/directory/trunk</url>
     </scm>
 
     <properties>
@@ -54,1441 +54,123 @@
               element, and it will need to be changed manually before a release,
               as the maven-release-plugin will not update this value.
         -->
-        <version>2.1-SNAPSHOT</version>
+        <version>2.0-SNAPSHOT</version>
 
         <geronimoSchemaVersion>1.2</geronimoSchemaVersion>
+    </properties>
 
-        <!--
-        Having a single well named property makes automatic updating for the weekly build much easier.
-        -->
-        <openejbVersion>3.0.0-SNAPSHOT</openejbVersion>
-
-        <!--
-        HACK: Used by uddi-db to execute the sql plugin with the Derby driver.
-        -->
-        <derbyVersion>10.2.2.0</derbyVersion>
-
-        <!--
-        HACK: Used by jsp and servlet example configs to point to the tomcat deployer
-        -->
-        <tomcatVersion>6.0.13</tomcatVersion>
-
-        <!--
-        HACK: Used by uddi-jetty and uddi-tomcat config plans
-        -->
-        <tranqlVendorsVersion>1.3</tranqlVendorsVersion>
-        
-        <!--
-        HACK: Used by applications/geronimo-dojo
-        -->
-        <dojoVersion>0.4.3</dojoVersion>
-
-        <cxfVersion>2.0-incubator</cxfVersion>
-
-        <axis2Version>SNAPSHOT</axis2Version>
-        <axiomVersion>1.2.5</axiomVersion>
-    </properties>
-
-    <dependencyManagement>
-        <dependencies>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-activation_1.1_spec</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-ejb_3.0_spec</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-interceptor_3.0_spec</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-j2ee-connector_1.5_spec</artifactId>
-                <version>1.1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-javaee-deployment_1.1MR3_spec</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jacc_1.1_spec</artifactId>
-                <version>1.0-SNAPSHOT</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-j2ee-management_1.1_spec</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <!-- NOTA BENE: use the org.apache.geronimo.javamail/geronimo-javamail_1.4_mail uber jar
-            containing both the spec and the providers in order that users can actually use mail
-            without advanced degrees in geronimo classloading.  DO NOT add or replace this with
-            org.apache.geronimo.specs/geronimo-javamail_1.4_spec -->
-            <dependency>
-                <groupId>org.apache.geronimo.javamail</groupId>
-                <artifactId>geronimo-javamail_1.4_mail</artifactId>
-                <version>1.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jaxr_1.0_spec</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jaxrpc_1.1_spec</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jsp_2.1_spec</artifactId>
-                <version>1.0-SNAPSHOT</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-el_1.0_spec</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jms_1.1_spec</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.axis2</groupId>
-                <artifactId>axis2-saaj-api</artifactId>
-                <version>${axis2Version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-servlet_2.5_spec</artifactId>
-                <version>1.1-SNAPSHOT</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jpa_3.0_spec</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-annotation_1.0_spec</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-jta_1.1_spec</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-ws-metadata_2.0_spec</artifactId>
-                <version>1.1.1</version>
-            </dependency>
-            
-            <!--
-            NOTE: The full source for this artifact is private due to Sun licensing issues.
-                  To view the generated XmlBeans source please see the -src artifact in the repository:
-
-                  http://people.apache.org/repo/m2-snapshot-repository/org/apache/geronimo/schema
-
-                  The full source is here with restricted access:
-                  
-                  https://svn.apache.org/repos/tck/geronimo-tck/schema/geronimo-schema-jee_5/trunk
-            -->
-            <dependency>
-                <groupId>org.apache.geronimo.schema</groupId>
-                <artifactId>geronimo-schema-jee_5</artifactId>
-                <version>1.1-SNAPSHOT</version>
-            </dependency>
-            
-            <!--
-            NOTE: The full source for this artifact is private due to Sun licensing issues.
-                  To view the generated XmlBeans source please see the -src artifact in the repository:
-
-                  http://people.apache.org/repo/m2-snapshot-repository/org/apache/geronimo/schema
-
-                  The full source is here with restricted access:
-
-                  https://svn.apache.org/repos/tck/geronimo-tck/schema/geronimo-schema-j2ee_1.4/trunk
-            -->
-            <dependency>
-                <groupId>org.apache.geronimo.schema</groupId>
-                <artifactId>geronimo-schema-j2ee_1.4</artifactId>
-                <version>1.1-SNAPSHOT</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.components</groupId>
-                <artifactId>geronimo-connector</artifactId>
-                <version>2.0-SNAPSHOT</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.components</groupId>
-                <artifactId>geronimo-connector</artifactId>
-                <version>2.0-SNAPSHOT</version>
-                <classifier>tests</classifier>
-                <scope>test</scope>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.geronimo.components</groupId>
-                <artifactId>geronimo-transaction</artifactId>
-                <version>2.0-SNAPSHOT</version>
-            </dependency>
-
-
-            <dependency>
-                <groupId>org.apache.openjpa</groupId>
-                <artifactId>openjpa</artifactId>
-                <version>1.0.0-SNAPSHOT</version>
-            </dependency>
-
-            <dependency>
-                <groupId>net.sourceforge.serp</groupId>
-                <artifactId>serp</artifactId>
-                <version>1.11.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.xbean</groupId>
-                <artifactId>xbean-finder</artifactId>
-                <version>3.0.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.xbean</groupId>
-                <artifactId>xbean-naming</artifactId>
-                <version>3.0.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.xbean</groupId>
-                <artifactId>xbean-reflect</artifactId>
-                <version>3.1-SNAPSHOT</version>
-            </dependency>
-
-            <dependency>
-                <groupId>jline</groupId>
-                <artifactId>jline</artifactId>
-                <version>0.9.9</version>
-            </dependency>
-
-            <dependency>
-                <groupId>axis</groupId>
-                <artifactId>axis</artifactId>
-                <version>1.4</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>axis</groupId>
-                        <artifactId>axis-saaj</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>asm</groupId>
-                <artifactId>asm</artifactId>
-                <version>2.2.3</version>
-            </dependency>
-
-            <dependency>
-                <groupId>asm</groupId>
-                <artifactId>asm-commons</artifactId>
-                <version>2.2.3</version>
-            </dependency>
-            
-            <!--
-            NOTE: This is included for AMQ 4.1 support only.  Need to use 2.2 to
-                  be compatible with AMQ 4.1, latest 3.0 causes CCE problems.
-            -->
-            <dependency>
-                <groupId>backport-util-concurrent</groupId>
-                <artifactId>backport-util-concurrent</artifactId>
-                <version>2.2</version>
-            </dependency>
-            
-            <dependency>
-                <groupId>com.agical.rmock</groupId>
-                <artifactId>rmock</artifactId>
-                <version>2.0.0-rc-6</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.codehaus.castor</groupId>
-                <artifactId>castor</artifactId>
-                <version>1.0.5</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>adaptx</groupId>
-                        <artifactId>adaptx</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.transaction</groupId>
-                        <artifactId>jta</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>jakarta-regexp</groupId>
-                        <artifactId>jakarta-regexp</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.servlet</groupId>
-                        <artifactId>servlet-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>com.cenqua.clover</groupId>
-                        <artifactId>clover</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>ant</groupId>
-                        <artifactId>ant</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>ldapsdk</groupId>
-                        <artifactId>ldapsdk</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>xerces</groupId>
-                        <artifactId>xerces</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>cglib</groupId>
-                        <artifactId>cglib-full</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-            
-            <dependency>
-                <groupId>cglib</groupId>
-                <artifactId>cglib-nodep</artifactId>
-                <version>2.1_3</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-codec</groupId>
-                <artifactId>commons-codec</artifactId>
-                <version>1.3</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-io</groupId>
-                <artifactId>commons-io</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-logging</groupId>
-                <artifactId>commons-logging</artifactId>
-                <version>1.0.4</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-beansutils</groupId>
-                <artifactId>commons-beansutils</artifactId>
-                <version>1.7.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.objectweb.howl</groupId>
-                <artifactId>howl</artifactId>
-                <version>1.0.1-1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>hsqldb</groupId>
-                <artifactId>hsqldb</artifactId>
-                <version>1.7.2.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>jdom</groupId>
-                <artifactId>jdom</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>log4j</groupId>
-                <artifactId>log4j</artifactId>
-                <version>1.2.14</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.slf4j</groupId>
-                <artifactId>slf4j-api</artifactId>
-                <version>1.3.0</version>
-            </dependency>
-            
-            <dependency>
-                <groupId>org.slf4j</groupId>
-                <artifactId>slf4j-jcl</artifactId>
-                <version>1.3.0</version>
-            </dependency>
-            
-            <dependency>
-                <groupId>org.slf4j</groupId>
-                <artifactId>slf4j-simple</artifactId>
-                <version>1.3.0</version>
-            </dependency>
-            
-            <dependency>
-                <groupId>mockobjects</groupId>
-                <artifactId>mockobjects-jdk1.4-j2ee1.3</artifactId>
-                <version>0.09</version>
-            </dependency>
-
-            <dependency>
-                <groupId>mockobjects</groupId>
-                <artifactId>mockobjects-core</artifactId>
-                <version>0.09</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.bcel</groupId>
-                <artifactId>bcel</artifactId>
-                <version>5.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.derby</groupId>
-                <artifactId>derby</artifactId>
-                <version>${derbyVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.derby</groupId>
-                <artifactId>derbynet</artifactId>
-                <version>${derbyVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.derby</groupId>
-                <artifactId>derbyclient</artifactId>
-                <version>${derbyVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.derby</groupId>
-                <artifactId>derbytools</artifactId>
-                <version>${derbyVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>regexp</groupId>
-                <artifactId>regexp</artifactId>
-                <version>1.3</version>
-            </dependency>
-            
-            <dependency>
-                <groupId>org.apache.ws.scout</groupId>
-                <artifactId>scout</artifactId>
-                <version>1.0rc1</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>axis</groupId>
-                        <artifactId>axis-saaj</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>xmlbeans</groupId>
-                        <artifactId>xbean</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>wsdl4j</groupId>
-                <artifactId>wsdl4j</artifactId>
-                <version>1.6.1</version>
-            </dependency>
-
-            <!-- org.apache.xml.serialize.XMLSerializer is used by castor, hence this is still needed -->
-            <dependency>
-                <groupId>xalan</groupId>
-                <artifactId>xalan</artifactId>
-                <version>2.7.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>xerces</groupId>
-                <artifactId>xercesImpl</artifactId>
-                <version>2.8.1</version>
-            </dependency>
-
-            <!-- This will go away when we move to tomcat6 -->
-            <dependency>
-                <groupId>xml-apis</groupId>
-                <artifactId>xml-apis</artifactId>
-                <version>1.3.03</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.xmlbeans</groupId>
-                <artifactId>xmlbeans</artifactId>
-                <version>2.3.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>xml-resolver</groupId>
-                <artifactId>xml-resolver</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>xpp3</groupId>
-                <artifactId>xpp3</artifactId>
-                <version>1.1.3.3</version>
-            </dependency>
-
-            <dependency>
-                <groupId>xstream</groupId>
-                <artifactId>xstream</artifactId>
-                <version>1.1.3</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.yoko</groupId>
-                <artifactId>yoko-core</artifactId>
-                <version>1.0-incubating-r557035</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.yoko</groupId>
-                <artifactId>yoko-spec-corba</artifactId>
-                <version>1.0-incubating-r557035</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.yoko</groupId>
-                <artifactId>yoko-rmi-spec</artifactId>
-                <version>1.0-incubating-r557035</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.yoko</groupId>
-                <artifactId>yoko-rmi-impl</artifactId>
-                <version>1.0-incubating-r557035</version>
-            </dependency>
-
-            <dependency>
-                <groupId>junit</groupId>
-                <artifactId>junit</artifactId>
-                <version>3.8.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.pluto</groupId>
-                <artifactId>pluto</artifactId>
-                <version>1.0.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.pluto</groupId>
-                <artifactId>pluto-portal</artifactId>
-                <version>1.0.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.pluto</groupId>
-                <artifactId>pluto-descriptors</artifactId>
-                <version>1.0.1</version>
-            </dependency>
-            
-            <dependency>
-                <groupId>org.apache.activemq</groupId>
-                <artifactId>activemq-core</artifactId>
-                <version>4.1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.activemq</groupId>
-                <artifactId>activemq-ra</artifactId>
-                <version>4.1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.activemq</groupId>
-                <artifactId>activeio-core</artifactId>
-                <version>3.0.0-incubator</version>
-            </dependency>
-
-            <dependency>
-                <groupId>jdbm</groupId>
-                <artifactId>jdbm</artifactId>
-                <version>0.20-dev</version>
-            </dependency>
-
-            <dependency>
-                <groupId>oro</groupId>
-                <artifactId>oro</artifactId>
-                <version>2.0.8</version>
-            </dependency>
-
-            <dependency>
-                <groupId>antlr</groupId>
-                <artifactId>antlr</artifactId>
-                <version>2.7.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-discovery</groupId>
-                <artifactId>commons-discovery</artifactId>
-                <version>0.4</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-collections</groupId>
-                <artifactId>commons-collections</artifactId>
-                <version>3.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-primitives</groupId>
-                <artifactId>commons-primitives</artifactId>
-                <version>20041207.202534</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-lang</groupId>
-                <artifactId>commons-lang</artifactId>
-                <version>2.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-el</groupId>
-                <artifactId>commons-el</artifactId>
-                <version>1.0</version>
-                <exclusions>
-                    <!-- Exclude commons-logging (uses 1.3) -->
-                    <!--
-                    HACK: For some crazy reason, if we exclude this here, then
-                          modules/jetty will fail to compile and there is no
-                          way to convince m2 to put the jar back on the classpath
-                          so, until that is resolved we have to disable this
-                          exclusion
-
-                    <exclusion>
-                        <groupId>commons-logging</groupId>
-                        <artifactId>commons-logging</artifactId>
-                    </exclusion>
-                    -->
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-digester</groupId>
-                <artifactId>commons-digester</artifactId>
-                <version>1.8</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-modeler</groupId>
-                <artifactId>commons-modeler</artifactId>
-                <version>2.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-beanutils</groupId>
-                <artifactId>commons-beanutils</artifactId>
-                <version>1.6.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-el</groupId>
-                <artifactId>commons-el</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-cli</groupId>
-                <artifactId>commons-cli</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-fileupload</groupId>
-                <artifactId>commons-fileupload</artifactId>
-                <version>1.1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-jexl</groupId>
-                <artifactId>commons-jexl</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>ognl</groupId>
-                <artifactId>ognl</artifactId>
-                <version>2.6.9</version>
-            </dependency>
-
-            <dependency>
-                <groupId>portlet-api</groupId>
-                <artifactId>portlet-api</artifactId>
-                <version>1.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>jstl</groupId>
-                <artifactId>jstl</artifactId>
-                <version>1.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>dwr</groupId>
-                <artifactId>dwr</artifactId>
-                <version>1.1.3</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.openejb</groupId>
-                <artifactId>openejb-core</artifactId>
-                <version>${openejbVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.openejb</groupId>
-                <artifactId>openejb-client</artifactId>
-                <version>${openejbVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.openejb</groupId>
-                <artifactId>openejb-ejbd</artifactId>
-                <version>${openejbVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.openejb</groupId>
-                <artifactId>openejb-axis</artifactId>
-                <version>${openejbVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.tranql</groupId>
-                <artifactId>tranql</artifactId>
-                <version>1.4.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.tranql</groupId>
-                <artifactId>tranql-connector-ra</artifactId>
-                <version>1.3</version>
-                <type>rar</type>
-            </dependency>
-
-            <dependency>
-                <groupId>org.tranql</groupId>
-                <artifactId>tranql-connector-derby-embed-xa</artifactId>
-                <version>1.3</version>
-                <type>rar</type>
-            </dependency>
-
-            <dependency>
-                <groupId>org.tranql</groupId>
-                <artifactId>tranql-connector-derby-embed-local</artifactId>
-                <version>1.3</version>
-                <type>rar</type>
-            </dependency>
-
-            <dependency>
-                <groupId>org.tranql</groupId>
-                <artifactId>tranql-connector-derby-client-local</artifactId>
-                <version>1.3</version>
-                <type>rar</type>
-            </dependency>
-
-            <dependency>
-                <groupId>org.tranql</groupId>
-                <artifactId>tranql-connector-derby-client-xa</artifactId>
-                <version>1.3</version>
-                <type>rar</type>
-            </dependency>
-
-            <dependency>
-                <groupId>juddi</groupId>
-                <artifactId>juddi</artifactId>
-                <version>0.9rc4</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory</groupId>
-                <artifactId>apacheds-core</artifactId>
-                <version>0.9.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory</groupId>
-                <artifactId>apacheds-shared</artifactId>
-                <version>0.9.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-asn1</groupId>
-                <artifactId>asn1-codec</artifactId>
-                <version>0.3.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-asn1</groupId>
-                <artifactId>asn1-ber</artifactId>
-                <version>0.3.2</version>
-                <exclusions>
-                    <!--
-                    NOTE: Exclude commons-test, no needed for compile, not deployed into any m2 repo.
-                          Where are the sources for this artifact?
-                    -->
-                    <exclusion>
-                        <groupId>commons-test</groupId>
-                        <artifactId>commons-test</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-asn1</groupId>
-                <artifactId>asn1-der</artifactId>
-                <version>0.3.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-shared</groupId>
-                <artifactId>apache-ldapber-provider</artifactId>
-                <version>0.9.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-shared</groupId>
-                <artifactId>ldap-common</artifactId>
-                <version>0.9.2</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-shared</groupId>
-                <artifactId>kerberos-common</artifactId>
-                <version>0.5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-network</groupId>
-                <artifactId>mina</artifactId>
-                <version>0.7.3</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-protocols</groupId>
-                <artifactId>kerberos-protocol</artifactId>
-                <version>0.5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>directory-protocols</groupId>
-                <artifactId>ldap-protocol</artifactId>
-                <version>0.9.2</version>
-            </dependency>
-
-            <!--<dependency>-->
-                <!--<groupId>org.apache.tomcat</groupId>-->
-                <!--<artifactId>annotations-api</artifactId>-->
-                <!--<version>${tomcatVersion}</version>-->
-            <!--</dependency>-->
-
-            <dependency>
-                <groupId>org.apache.tomcat</groupId>
-                <artifactId>jasper</artifactId>
-                <version>6.0.13-G543818</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat</groupId>
-                <artifactId>jasper-el</artifactId>
-                <version>${tomcatVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat</groupId>
-                <artifactId>jasper-jdt</artifactId>
-                <version>${tomcatVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat.extras</groupId>
-                <artifactId>juli</artifactId>
-                <version>${tomcatVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat.extras</groupId>
-                <artifactId>juli-adapters</artifactId>
-                <version>${tomcatVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat</groupId>
-                <artifactId>catalina</artifactId>
-                <version>6.0.13-G543818</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat</groupId>
-                <artifactId>catalina-ha</artifactId>
-                <version>${tomcatVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat</groupId>
-                <artifactId>tribes</artifactId>
-                <version>${tomcatVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat</groupId>
-                <artifactId>coyote</artifactId>
-                <version>${tomcatVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.tomcat</groupId>
-                <artifactId>juli</artifactId>
-                <version>${tomcatVersion}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.codehaus.wadi</groupId>
-                <artifactId>wadi-core</artifactId>
-                <version>2.0-M5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.codehaus.wadi</groupId>
-                <artifactId>wadi-group</artifactId>
-                <version>2.0-M5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.codehaus.wadi</groupId>
-                <artifactId>wadi-tribes</artifactId>
-                <version>2.0-M5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.mortbay.jetty</groupId>
-                <artifactId>jetty</artifactId>
-                <version>6.1.5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.mortbay.jetty</groupId>
-                <artifactId>jetty-ajp</artifactId>
-                <version>6.1.5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.mortbay.jetty</groupId>
-                <artifactId>jetty-sslengine</artifactId>
-                <version>6.1.5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.mortbay.jetty</groupId>
-                <artifactId>jetty-util</artifactId>
-                <version>6.1.5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-api</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
+    <dependencyManagement>
+        <dependencies>
+            <!-- NOTA BENE: use the org.apache.geronimo.javamail/geronimo-javamail_1.4_mail uber jar
+            containing both the spec and the providers in order that users can actually use mail
+            without advanced degrees in geronimo classloading.  DO NOT add or replace this with
+            org.apache.geronimo.specs/geronimo-javamail_1.4_spec -->
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-metacode</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>org.apache.geronimo.javamail</groupId>
+                <artifactId>geronimo-javamail_1.4_mail</artifactId>
+                <version>1.2</version>
             </dependency>
 
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-common-utilities</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>org.apache.geronimo.modules</groupId>
+                <artifactId>geronimo-system</artifactId>
+                <version>2.1-SNAPSHOT</version>
             </dependency>
 
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-rt-core</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>com.sun.xml.bind</groupId>
-                        <artifactId>jaxb-impl</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>org.apache.geronimo.configs</groupId>
+                <artifactId>j2ee-server</artifactId>
+                <version>2.1-SNAPSHOT</version>
+                <type>car</type>
             </dependency>
 
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-rt-bindings-xml</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>commons-logging</groupId>
+                <artifactId>commons-logging</artifactId>
+                <version>1.0.4</version>
             </dependency>
 
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-rt-bindings-soap</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>log4j</groupId>
+                <artifactId>log4j</artifactId>
+                <version>1.2.14</version>
             </dependency>
 
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-rt-databinding-jaxb</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>com.sun.xml.bind</groupId>
-                        <artifactId>jaxb-impl</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>org.slf4j</groupId>
+                <artifactId>slf4j-api</artifactId>
+                <version>1.4.0</version>
             </dependency>
-
+            
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-rt-frontend-jaxws</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>com.sun.xml.bind</groupId>
-                        <artifactId>jaxb-impl</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>org.slf4j</groupId>
+                <artifactId>slf4j-jcl</artifactId>
+                <version>1.4.0</version>
             </dependency>
-
+            
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-rt-frontend-simple</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>org.slf4j</groupId>
+                <artifactId>slf4j-log4j12</artifactId>
+                <version>1.4.0</version>
             </dependency>
-
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-rt-transports-http</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>com.sun.xml.bind</groupId>
-                        <artifactId>jaxb-impl</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>junit</groupId>
+                <artifactId>junit</artifactId>
+                <version>3.8.1</version>
             </dependency>
-
             <dependency>
-                <groupId>org.apache.cxf</groupId>
-                <artifactId>cxf-tools-common</artifactId>
-                <version>${cxfVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.annotation</groupId>
-                        <artifactId>jsr250-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.jws</groupId>
-                        <artifactId>jsr181-api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>com.sun.xml.bind</groupId>
-                        <artifactId>jaxb-impl</artifactId>
-                    </exclusion>
-                </exclusions>
+                <groupId>jdbm</groupId>
+                <artifactId>jdbm</artifactId>
+                <version>0.20-dev</version>
             </dependency>
-
             <dependency>
-                <groupId>org.apache.geronimo.specs</groupId>
-                <artifactId>geronimo-stax-api_1.0_spec</artifactId>
-                <version>1.0</version>
+              <groupId>org.apache.directory.server</groupId>
+              <artifactId>apacheds-server-jndi</artifactId>
+                <version>1.5.1-SNAPSHOT</version>
             </dependency>
-
             <dependency>
-                <groupId>woodstox</groupId>
-                <artifactId>wstx-asl</artifactId>
-                <version>3.2.1</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>stax</groupId>
-                        <artifactId>stax-api</artifactId>
-                    </exclusion>
-                </exclusions>
+              <groupId>org.apache.directory.server</groupId>
+              <artifactId>apacheds-core</artifactId>
+                <version>1.5.1-SNAPSHOT</version>
             </dependency>
 
             <dependency>
-                <groupId>org.apache.ws.commons.schema</groupId>
-                <artifactId>XmlSchema</artifactId>
-                <version>1.3.1</version>
+              <groupId>org.apache.directory.daemon</groupId>
+              <artifactId>daemon-bootstrappers</artifactId>
+              <version>1.1.1-SNAPSHOT</version>
             </dependency>
 
-            <dependency>
-                <groupId>javax.xml.bind</groupId>
-                <artifactId>jaxb-api</artifactId>
-                <version>2.0</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.xml.bind</groupId>
-                        <artifactId>jsr173_api</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
 
             <dependency>
-                <groupId>com.sun.xml.messaging.saaj</groupId>
-                <artifactId>saaj-impl</artifactId>
-                <version>1.3</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.activation</groupId>
-                        <artifactId>activation</artifactId>
-                    </exclusion>
-                </exclusions>
+              <groupId>org.apache.xbean</groupId>
+              <artifactId>xbean-spring</artifactId>
+                <version>3.1-SNAPSHOT</version>
             </dependency>
 
+            
             <dependency>
-                <groupId>com.sun.xml.bind</groupId>
-                <artifactId>jaxb-impl</artifactId>
+                <groupId>org.springframework</groupId>
+                <artifactId>spring</artifactId>
                 <version>2.0.5</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>javax.xml.bind</groupId>
-                        <artifactId>jsr173_api</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>javax.xml.bind</groupId>
-                        <artifactId>activation</artifactId>
-                    </exclusion>
-                </exclusions>
             </dependency>
-
             <dependency>
                 <groupId>org.springframework</groupId>
                 <artifactId>spring-core</artifactId>
-                <version>2.0.4</version>
+                <version>2.0.5</version>
             </dependency>
 
             <dependency>
                 <groupId>org.springframework</groupId>
                 <artifactId>spring-beans</artifactId>
-                <version>2.0.4</version>
+                <version>2.0.5</version>
             </dependency>
 
             <dependency>
                 <groupId>org.springframework</groupId>
                 <artifactId>spring-context</artifactId>
-                <version>2.0.4</version>
-            </dependency>
-
-            <!--JSF 1.2 JARs from Apache MyFaces -->
-            <dependency>
-                <groupId>org.apache.myfaces.core</groupId>
-                <artifactId>myfaces-api</artifactId>
-                <version>1.2.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.myfaces.core</groupId>
-                <artifactId>myfaces-impl</artifactId>
-                <version>1.2.0</version>
-            </dependency>
-
-            <!--Axis2 modules dependencies-->
-            <dependency>
-                <groupId>org.apache.axis2</groupId>
-                <artifactId>axis2-java2wsdl</artifactId>
-                <version>${axis2Version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.axis2</groupId>
-                <artifactId>axis2-kernel</artifactId>
-                <version>${axis2Version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.axis2</groupId>
-                <artifactId>axis2-adb</artifactId>
-                <version>${axis2Version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.axis2</groupId>
-                <artifactId>axis2-jaxws-api</artifactId>
-                <version>${axis2Version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.axis2</groupId>
-                <artifactId>axis2-jaxws</artifactId>
-                <version>${axis2Version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.axis2</groupId>
-                <artifactId>axis2-metadata</artifactId>
-                <version>${axis2Version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.axis2</groupId>
-                <artifactId>axis2-saaj</artifactId>
-                <version>${axis2Version}</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.httpcomponents</groupId>
-                <artifactId>httpcore</artifactId>
-                <version>4.0-alpha5</version>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.ws.commons.axiom</groupId>
-                <artifactId>axiom-api</artifactId>
-                <version>${axiomVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>log4j</groupId>
-                        <artifactId>log4j</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.ws.commons.axiom</groupId>
-                <artifactId>axiom-impl</artifactId>
-                <version>${axiomVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>log4j</groupId>
-                        <artifactId>log4j</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.ws.commons.axiom</groupId>
-                <artifactId>axiom-dom</artifactId>
-                <version>${axiomVersion}</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>log4j</groupId>
-                        <artifactId>log4j</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>org.apache.neethi</groupId>
-                <artifactId>neethi</artifactId>
-                <version>2.0</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>org.apache.ws.commons.axiom</groupId>
-                        <artifactId>axiom-impl</artifactId>
-                    </exclusion>
-                    <exclusion>
-                        <groupId>org.apache.ws.commons.axiom</groupId>
-                        <artifactId>axiom-api</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-           <dependency>
-               <groupId>com.sun.xml.ws</groupId>
-               <artifactId>jaxws-tools</artifactId>
-                <version>2.0</version>
-           </dependency>
-    
-           <dependency>
-               <groupId>com.sun.xml.ws</groupId>
-               <artifactId>jaxws-rt</artifactId>
-                <version>2.0</version>
-           </dependency>
-     
-           <dependency>
-               <groupId>com.sun.xml.bind</groupId>
-               <artifactId>jaxb-xjc</artifactId>
-               <version>2.0.5</version>
-           </dependency>
-
-            <dependency>
-                <groupId>commons-httpclient</groupId>
-                <artifactId>commons-httpclient</artifactId>
-                <version>3.0.1</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>junit</groupId>
-                        <artifactId>junit</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>commons-codec</groupId>
-                <artifactId>commons-codec</artifactId>
-                <version>1.3</version>
-                <exclusions>
-                    <exclusion>
-                        <groupId>junit</groupId>
-                        <artifactId>junit</artifactId>
-                    </exclusion>
-                </exclusions>
-            </dependency>
-
-            <dependency>
-                <groupId>javax.mail</groupId>
-                <artifactId>mail</artifactId>
-                <version>1.4</version>
-            </dependency>
-
-            <dependency>
-                <groupId>javax.activation</groupId>
-                <artifactId>activation</artifactId>
-                <version>1.1</version>
-            </dependency>
-
-            <dependency>
-                <groupId>xalan</groupId>
-                <artifactId>xalan</artifactId>
-                <version>2.7.0</version>
-            </dependency>
-
-            <dependency>
-                <groupId>jaxen</groupId>
-                <artifactId>jaxen</artifactId>
-                <version>1.1-beta-10</version>
-            </dependency>
-
-            <dependency>
-                <groupId>annogen</groupId>
-                <artifactId>annogen</artifactId>
-                <version>0.1.0</version>
+                <version>2.0.5</version>
             </dependency>
 
-            <dependency>
-                <groupId>org.dojotoolkit</groupId>
-                <artifactId>dojo</artifactId>
-                <version>${dojoVersion}</version>
-                <type>tgz</type>
-            </dependency>
         </dependencies>
     </dependencyManagement>
 
@@ -1545,110 +227,6 @@
                     </configuration>
                 </plugin>
 
-
-                <plugin>
-                    <groupId>org.codehaus.mojo.jspc</groupId>
-                    <artifactId>jspc-maven-plugin</artifactId>
-                    <version>2.0-SNAPSHOT</version>
-                    <executions>
-                        <execution>
-                            <goals>
-                                 <goal>compile</goal>
-                            </goals>
-                            <configuration>
-                                <warSourceDirectory>${pom.basedir}/src/main/webapp</warSourceDirectory>
-                            </configuration>
-                        </execution>
-                    </executions>
-                    
-                    <!-- Use the Tomcat 6 JSP compiler, but with our custom Jasper version -->
-                    <dependencies>
-                        <dependency>
-                            <groupId>org.codehaus.mojo.jspc</groupId>
-                            <artifactId>jspc-compiler-tomcat6</artifactId>
-                            <version>2.0-SNAPSHOT</version>
-                            <exclusions>
-                                <exclusion>
-                                    <groupId>org.apache.tomcat</groupId>
-                                    <artifactId>jasper</artifactId>
-                                </exclusion>
-                            </exclusions>
-                        </dependency>
-                        
-                        <dependency>
-                            <groupId>org.apache.tomcat</groupId>
-                            <artifactId>jasper</artifactId>
-                            <version>6.0.13-G543818</version>
-                        </dependency>
-                    </dependencies>
-                </plugin>
-
-                <plugin>
-                    <groupId>org.codehaus.mojo</groupId>
-                    <artifactId>sql-maven-plugin</artifactId>
-                    <version>1.0</version>
-                </plugin>
-                
-                <!--
-                FIXME: Should not configure war to assume jsp by default
-                -->
-
-                <plugin>
-                    <groupId>org.apache.maven.plugins</groupId>
-                    <artifactId>maven-war-plugin</artifactId>
-                    <version>2.0.2</version>
-                    <configuration>
-                        <warSourceDirectory>${pom.basedir}/src/main/webapp</warSourceDirectory>
-                        <webXml>${project.build.directory}/jspweb.xml</webXml>
-                        <archiveClasses>true</archiveClasses>
-                        <archive>
-                            <!-- Do not include META-INF/maven to avoid long file problems on windows -->
-                            <addMavenDescriptor>false</addMavenDescriptor>
-                        </archive>
-                        
-                        <!--
-                        HACK: Include legal files explicity, otherwise they will end up in the wrong path
-                              or in another jar file in the war.
-                        
-                        NOTE: targetPath is broken for webResources (as documented)
-                        -->
-                        <webResources>
-                            <resource>
-                                <directory>${project.build.outputDirectory}</directory>
-                                <includes>
-                                    <include>META-INF/LICENSE*</include>
-                                    <include>META-INF/NOTICE*</include>
-                                    <include>META-INF/DISCLAIMER*</include>
-                                </includes>
-                            </resource>
-                        </webResources>
-                    </configuration>
-                </plugin>
-
-                <plugin>
-                    <groupId>org.apache.maven.plugins</groupId>
-                    <artifactId>maven-ear-plugin</artifactId>
-                    <version>2.3</version>
-                    <configuration>
-                        <archive>
-                            <!-- Do not include META-INF/maven to avoid long file problems on windows -->
-                            <addMavenDescriptor>false</addMavenDescriptor>
-                        </archive>
-                    </configuration>
-                </plugin>
-
-                <plugin>
-                    <groupId>org.apache.maven.plugins</groupId>
-                    <artifactId>maven-rar-plugin</artifactId>
-                    <version>2.2</version>
-                    <configuration>
-                        <archive>
-                            <!-- Do not include META-INF/maven to avoid long file problems on windows -->
-                            <addMavenDescriptor>false</addMavenDescriptor>
-                        </archive>
-                    </configuration>
-                </plugin>
-
                 <plugin>
                     <groupId>org.apache.maven.plugins</groupId>
                     <artifactId>maven-jar-plugin</artifactId>
@@ -1660,80 +238,6 @@
                     </configuration>
                 </plugin>
 
-                <plugin>
-                    <groupId>org.apache.geronimo.plugins</groupId>
-                    <artifactId>geronimo-maven-plugin</artifactId>
-                    <version>${version}</version>
-
-                    <configuration>
-                        <assemblies>
-                            <assembly>
-                                <id>jetty</id>
-                                <groupId>org.apache.geronimo.assemblies</groupId>
-                                <artifactId>geronimo-jetty6-jee5</artifactId>
-                                <version>${version}</version>
-                                <classifier>bin</classifier>
-                                <type>zip</type>
-                            </assembly>
-
-                            <assembly>
-                                <id>jetty-minimal</id>
-                                <groupId>org.apache.geronimo.assemblies</groupId>
-                                <artifactId>geronimo-jetty6-minimal</artifactId>
-                                <version>${version}</version>
-                                <classifier>bin</classifier>
-                                <type>zip</type>
-                            </assembly>
-
-                            <assembly>
-                                <id>tomcat</id>
-                                <groupId>org.apache.geronimo.assemblies</groupId>
-                                <artifactId>geronimo-tomcat6-jee5</artifactId>
-                                <version>${version}</version>
-                                <classifier>bin</classifier>
-                                <type>zip</type>
-                            </assembly>
-
-                            <assembly>
-                                <id>tomcat-minimal</id>
-                                <groupId>org.apache.geronimo.assemblies</groupId>
-                                <artifactId>geronimo-tomcat6-minimal</artifactId>
-                                <version>${version}</version>
-                                <classifier>bin</classifier>
-                                <type>zip</type>
-                            </assembly>
-                            
-                            <assembly>
-                                <id>framework</id>
-                                <groupId>org.apache.geronimo.assemblies</groupId>
-                                <artifactId>geronimo-framework</artifactId>
-                                <version>${version}</version>
-                                <classifier>bin</classifier>
-                                <type>zip</type>
-                            </assembly>
-                        </assemblies>
-
-                        <defaultAssemblyId>jetty</defaultAssemblyId>
-
-                        <optionSets>
-                            <optionSet>
-                                <id>morememory</id>
-                                <options>
-                                    <option>-Xmx512m</option>
-                                    <option>-XX:MaxPermSize=128m</option>
-                                </options>
-                            </optionSet>
-
-                            <optionSet>
-                                <id>debug</id>
-                                <options>
-                                    <option>-Xdebug</option>
-                                    <option>-Xrunjdwp:transport=dt_socket,address=8000,server=y,suspend=n</option>
-                                </options>
-                            </optionSet>
-                        </optionSets>
-                    </configuration>
-                </plugin>
             </plugins>
         </pluginManagement>
 
@@ -1882,14 +386,8 @@
             </activation>
 
             <modules>
-                <module>repository</module>
-                <module>buildsupport</module>
-                <module>testsupport</module>
-                <module>modules</module>
-                <module>maven-plugins</module>
-                <module>applications</module>
-                <module>configs</module>
-                <module>assemblies</module>
+                <module>geronimo-directory</module>
+                <module>directory</module>
             </modules>
         </profile>
 
@@ -1924,88 +422,6 @@
                     </plugin>
                 </plugins>
             </build>
-        </profile>
-
-        <!--
-        NOTE: The staged build is used to get around a problem with Maven
-              and extension plugins.
-
-              See http://issues.apache.org/jira/browse/GERONIMO-2172 for more details.
-        -->
-        <profile>
-            <id>stage-bootstrap</id>
-
-            <activation>
-                <property>
-                    <name>stage</name>
-                    <value>bootstrap</value>
-                </property>
-            </activation>
-
-            <modules>
-                <module>repository</module>
-                <module>buildsupport</module>
-                <module>testsupport</module>
-                <module>modules</module>
-                <module>maven-plugins</module>
-            </modules>
-        </profile>
-
-        <profile>
-            <id>stage-assemble</id>
-
-            <activation>
-                <property>
-                    <name>stage</name>
-                    <value>assemble</value>
-                </property>
-            </activation>
-
-            <modules>
-                <module>applications</module>
-                <module>configs</module>
-                <module>assemblies</module>
-            </modules>
-        </profile>
-
-        <profile>
-            <id>release-environment</id>
-
-            <activation>
-                <property>
-                    <name>env</name>
-                    <value>release</value>
-                </property>
-            </activation>
-
-            <modules>
-                <module>repository</module>
-                <module>buildsupport</module>
-                <module>testsupport</module>
-                <module>modules</module>
-                <module>maven-plugins</module>
-                <module>applications</module>
-                <module>configs</module>
-            </modules>
-        </profile>
-
-        <profile>
-            <id>site-environment</id>
-
-            <activation>
-                <property>
-                    <name>env</name>
-                    <value>site</value>
-                </property>
-            </activation>
-
-            <modules>
-                <module>buildsupport</module>
-                <module>testsupport</module>
-                <module>modules</module>
-                <module>maven-plugins</module>
-                <module>applications</module>
-            </modules>
         </profile>
 
         <profile>



Mime
View raw message