geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jdil...@apache.org
Subject svn commit: r508190 - /geronimo/genesis/trunk/plugins/tools-maven-plugin/src/site/apt/usage.apt
Date Thu, 15 Feb 2007 22:08:05 GMT
Author: jdillon
Date: Thu Feb 15 14:08:04 2007
New Revision: 508190

URL: http://svn.apache.org/viewvc?view=rev&rev=508190
Log:
Quick blurb about require-maven-version

Modified:
    geronimo/genesis/trunk/plugins/tools-maven-plugin/src/site/apt/usage.apt

Modified: geronimo/genesis/trunk/plugins/tools-maven-plugin/src/site/apt/usage.apt
URL: http://svn.apache.org/viewvc/geronimo/genesis/trunk/plugins/tools-maven-plugin/src/site/apt/usage.apt?view=diff&rev=508190&r1=508189&r2=508190
==============================================================================
--- geronimo/genesis/trunk/plugins/tools-maven-plugin/src/site/apt/usage.apt (original)
+++ geronimo/genesis/trunk/plugins/tools-maven-plugin/src/site/apt/usage.apt Thu Feb 15 14:08:04
2007
@@ -103,6 +103,36 @@
 </plugin>
 +----------+
 
+Maven Version Control
+
+ Allow builds to fail quickly if the Maven version is not correct.
+
+* Require a specific Maven version
+
+ This will only allow the build to function if the Maven version is 2.0.4,
+ any other version will cause a build failure.
+ 
+ NOTE: The basic syntax is the same as for require-java-version, except that you can specify
+ values like 1.4.1 (you do not need to, or should, specify 1.41).
+
++----------+
+<plugin>
+    <groupId>org.apache.geronimo.genesis.plugins</groupId>
+    <artifactId>tools-maven-plugin</artifactId>
+    <executions>
+        <execution>
+            <phase>validate</phase>
+            <goals>
+                <goal>require-maven-version</goal>
+            </goals>
+            <configuration>
+                <version>2.0.4</version>
+            </configuration>
+        </execution>
+    </executions>
+</plugin>
++----------+
+
 Other Tools
 
 * Copy legal files



Mime
View raw message