geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jdil...@apache.org
Subject svn commit: r502117 - /geronimo/sandbox/build-support/libraries/system/1/groovy/gbuild/config/projects/Geronimo_CTS/Controller.groovy
Date Thu, 01 Feb 2007 04:32:56 GMT
Author: jdillon
Date: Wed Jan 31 20:32:55 2007
New Revision: 502117

URL: http://svn.apache.org/viewvc?view=rev&rev=502117
Log:
Use the workflow name from anthill to determine which version of java to use, 1.2 needs 1.4,
2.0 needs 1.5

Modified:
    geronimo/sandbox/build-support/libraries/system/1/groovy/gbuild/config/projects/Geronimo_CTS/Controller.groovy

Modified: geronimo/sandbox/build-support/libraries/system/1/groovy/gbuild/config/projects/Geronimo_CTS/Controller.groovy
URL: http://svn.apache.org/viewvc/geronimo/sandbox/build-support/libraries/system/1/groovy/gbuild/config/projects/Geronimo_CTS/Controller.groovy?view=diff&rev=502117&r1=502116&r2=502117
==============================================================================
--- geronimo/sandbox/build-support/libraries/system/1/groovy/gbuild/config/projects/Geronimo_CTS/Controller.groovy
(original)
+++ geronimo/sandbox/build-support/libraries/system/1/groovy/gbuild/config/projects/Geronimo_CTS/Controller.groovy
Wed Jan 31 20:32:55 2007
@@ -41,7 +41,16 @@
         // AH configuration (since 1.2 and 2.0 use differnt versions)
         //
         
-        maven.javaVersion = 1.5  // FIXME
+        def workflow = params.require('anthill.workflow')
+        switch (workflow) {
+            case 'build 1.2':
+                maven.javaVersion = 1.4
+                break
+            
+            case 'build 2.0':
+                maven.javaVersion = 1.5
+                break
+        }
         
         maven.execute()
     }



Mime
View raw message