geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jdil...@apache.org
Subject svn commit: r433469 - /geronimo/trunk/pom.xml
Date Tue, 22 Aug 2006 02:05:27 GMT
Author: jdillon
Date: Mon Aug 21 19:05:27 2006
New Revision: 433469

URL: http://svn.apache.org/viewvc?rev=433469&view=rev
Log:
Require a 1.4* JDK to allow the build to continue, newer (or older) JDK's will cause a meaningful
"This build requires Java version ..." error

Modified:
    geronimo/trunk/pom.xml

Modified: geronimo/trunk/pom.xml
URL: http://svn.apache.org/viewvc/geronimo/trunk/pom.xml?rev=433469&r1=433468&r2=433469&view=diff
==============================================================================
--- geronimo/trunk/pom.xml (original)
+++ geronimo/trunk/pom.xml Mon Aug 21 19:05:27 2006
@@ -978,6 +978,23 @@
 
         <plugins>
             <plugin>
+                <groupId>org.apache.geronimo.genesis.plugins</groupId>
+                <artifactId>tools-maven-plugin</artifactId>
+                <version>1.0.0-SNAPSHOT</version>
+                <executions>
+                    <execution>
+                        <phase>validate</phase>
+                        <goals>
+                            <goal>require-java-version</goal>
+                        </goals>
+                        <configuration>
+                            <version>1.4*</version>
+                        </configuration>
+                    </execution>
+                </executions>
+            </plugin>
+            
+            <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
                 <artifactId>maven-compiler-plugin</artifactId>
                 <configuration>



Mime
View raw message