geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sppa...@apache.org
Subject svn commit: r383940 - in /geronimo/devtools/eclipse-plugin/trunk: ./ maven-plugins/maven-geronimodevtools-plugin/src/main/java/org/apache/geronimo/eclipse/devtools/ plugins/org.apache.geronimo.devtools.eclipse.core/ plugins/org.apache.geronimo.runtime.v1/
Date Tue, 07 Mar 2006 17:52:55 GMT
Author: sppatel
Date: Tue Mar  7 09:52:53 2006
New Revision: 383940

URL: http://svn.apache.org/viewcvs?rev=383940&view=rev
Log:
m2 updates

Modified:
    geronimo/devtools/eclipse-plugin/trunk/maven-plugins/maven-geronimodevtools-plugin/src/main/java/org/apache/geronimo/eclipse/devtools/InstallPluginDependenciesMojo.java
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.devtools.eclipse.core/pom.xml
    geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v1/pom.xml
    geronimo/devtools/eclipse-plugin/trunk/pom.xml

Modified: geronimo/devtools/eclipse-plugin/trunk/maven-plugins/maven-geronimodevtools-plugin/src/main/java/org/apache/geronimo/eclipse/devtools/InstallPluginDependenciesMojo.java
URL: http://svn.apache.org/viewcvs/geronimo/devtools/eclipse-plugin/trunk/maven-plugins/maven-geronimodevtools-plugin/src/main/java/org/apache/geronimo/eclipse/devtools/InstallPluginDependenciesMojo.java?rev=383940&r1=383939&r2=383940&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/maven-plugins/maven-geronimodevtools-plugin/src/main/java/org/apache/geronimo/eclipse/devtools/InstallPluginDependenciesMojo.java
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/maven-plugins/maven-geronimodevtools-plugin/src/main/java/org/apache/geronimo/eclipse/devtools/InstallPluginDependenciesMojo.java
Tue Mar  7 09:52:53 2006
@@ -17,6 +17,8 @@
 package org.apache.geronimo.eclipse.devtools;
 
 import java.io.File;
+import java.io.FileWriter;
+import java.io.IOException;
 import java.util.Iterator;
 import java.util.List;
 
@@ -24,19 +26,21 @@
 import org.apache.maven.artifact.factory.ArtifactFactory;
 import org.apache.maven.artifact.installer.ArtifactInstallationException;
 import org.apache.maven.artifact.installer.ArtifactInstaller;
+import org.apache.maven.artifact.metadata.ArtifactMetadata;
 import org.apache.maven.artifact.repository.ArtifactRepository;
 import org.apache.maven.model.Dependency;
+import org.apache.maven.model.Model;
+import org.apache.maven.model.io.xpp3.MavenXpp3Writer;
 import org.apache.maven.plugin.AbstractMojo;
 import org.apache.maven.plugin.MojoExecutionException;
 import org.apache.maven.plugin.MojoFailureException;
 import org.apache.maven.project.MavenProject;
+import org.apache.maven.project.artifact.ProjectArtifactMetadata;
+import org.codehaus.plexus.util.IOUtil;
 
 /**
- * This maven plugin installs to the local maven repository the eclipse plugin
- * dependencies for a pom from an eclipse distribution. Since the eclipse jars
- * do not follow a maven-style versioning convention the versionType parameter
- * allows the plugin to be configured to determine the versioning style when
- * installing. See the INSTALL_TYPE_X descriptions.
+ * This maven plugin installs to the local maven repository eclipse plugin
+ * dependencies for a pom from an eclipse distribution.
  * 
  * @goal install
  */
@@ -45,30 +49,6 @@
 	private static final String GROUP_ID = "org.eclipse.plugins";
 
 	/**
-	 * Install type option which would install a plugin
-	 * org.eclipse.core.runtime_3.2.0.v20060216.jar as
-	 * org.eclipse.core.runtime-SNAPSHOT.jar
-	 */
-	public static final String INSTALL_TYPE_SNAPSHOT = "SNAPSHOT";
-
-	/**
-	 * Install type option which would install a plugin
-	 * org.eclipse.core.runtime_3.2.0.v20060216.jar as
-	 * org.eclipse.core.runtime-3.2.0-SNAPSHOT.jar
-	 */
-	public static final String INSTALL_TYPE_SNAPSHOT_VERSIONED = "SNAPSHOT-VERSIONED";
-
-	/**
-	 * TODO Need to investigate how the qualifier needs to be tweaked to so that maven can
-	 * do version comparisons on the artifact.
-	 * 
-	 * Install type option which would install a plugin
-	 * org.eclipse.core.runtime_3.2.0.v20060216.jar as
-	 * org.eclipse.core.runtime-3.2.0.v20060216.jar
-	 */
-	public static final String INSTALL_TYPE_QUALIFIED = "QUALIFIED";
-
-	/**
 	 * @parameter expression="${project}"
 	 */
 	private MavenProject project;
@@ -99,11 +79,6 @@
 	 */
 	protected ArtifactRepository localRepository;
 
-	/**
-	 * @parameter expression="SNAPSHOT"
-	 */
-	protected String versionType;
-
 	public InstallPluginDependenciesMojo() {
 		super();
 	}
@@ -152,42 +127,24 @@
 			}
 			depth--;
 		} else {
-			if (shouldInstall(dependency, file)) {
-				install(file, depth);
+			if (file.getName().endsWith(".jar")) {
+				File bundle = getBundle(file, depth);
+				if (getArtifactID(file, bundle).equals(dependency.getArtifactId())) {
+					install(file, bundle);
+					if ("DISTRO".equals(dependency.getVersion()))
+						dependency.setVersion(getBundleVersion(bundle));
+				}
 			}
 		}
 	}
 
-	protected boolean shouldInstall(Dependency dependency, File file) {
-		if (!file.getName().endsWith(".jar"))
-			return false;
-		return dependency == null
-				|| (getBundleName(file).equals(dependency.getArtifactId()));
-	}
-
-	protected void install(File file, int depth) {
-		File bundle = file;
-		boolean isBundleJar = depth > 1 ? false : true;
-
-		if (!isBundleJar)
-			bundle = getBundleDir(file, depth);
+	protected void install(File artifact, File bundle) {
 
-		String artifactId = getBundleName(bundle);
-		String version = "SNAPSHOT";
-
-		if (INSTALL_TYPE_QUALIFIED.equalsIgnoreCase(versionType)) {
-			version = getBundleVersion(bundle);
-		} else if (INSTALL_TYPE_SNAPSHOT_VERSIONED.equalsIgnoreCase(versionType)) {
-			version = getBundleVersion(bundle);
-			String mmrq[] = version.split("\\.");  //assumes plugin version is major.minor.revision.qualifier
-			version = mmrq[0] + "." + mmrq[1] + "." + mmrq[2] + "-SNAPSHOT";
-		}
-
-		if (!isBundleJar)
-			artifactId = artifactId + "." + getArtifactID(file);
+		String artifactId = getArtifactID(artifact, bundle);
+		String version = getBundleVersion(bundle);
 
 		try {
-			doIt(file, GROUP_ID, artifactId, version, "jar");
+			doIt(artifact, GROUP_ID, artifactId, version, "jar");
 		} catch (MojoExecutionException e) {
 			e.printStackTrace();
 		} catch (MojoFailureException e) {
@@ -195,31 +152,34 @@
 		}
 	}
 
-	protected File getBundleDir(File file, int depth) {
-		File pluginDir = file.getParentFile();
-		for (int i = depth - 1; i > 1; i--) {
-			pluginDir = pluginDir.getParentFile();
+	protected File getBundle(File file, int depth) {
+		File bundle = file;
+		if (depth > 1) {
+			bundle = file.getParentFile();
+			for (int i = depth - 1; i > 1; i--) {
+				bundle = bundle.getParentFile();
+			}
 		}
-		return pluginDir;
+		return bundle;
 	}
 
 	public static String getBundleName(File bundle) {
-		String id = getArtifactID(bundle);
+		String id = removeJarExtension(bundle);
 		if (id.indexOf("_") != -1)
 			id = id.substring(0, id.indexOf("_"));
 		return id;
 	}
 
 	public static String getBundleVersion(File bundle) {
-		String id = getArtifactID(bundle);
+		String id = removeJarExtension(bundle);
 		return id.substring(id.indexOf("_") + 1, id.length());
 	}
 
-	public static String getArtifactID(File file) {
-		String name = file.getName();
-		if (file.isFile())
-			name = name.substring(0, name.lastIndexOf(".jar"));
-		return name;
+	public static String getArtifactID(File artifact, File bundle) {
+		String artifactId = getBundleName(bundle);
+		if (bundle.isDirectory())
+			artifactId = artifactId + "." + removeJarExtension(artifact);
+		return artifactId;
 	}
 
 	private void doIt(File file, String groupId, String artifactId,
@@ -227,6 +187,7 @@
 			MojoFailureException {
 
 		Artifact artifact = artifactFactory.createArtifact(groupId, artifactId, version, null,
packaging);
+		generatePOM(artifact, groupId, artifactId, version);
 
 		try {
 			String localPath = localRepository.pathOf(artifact);
@@ -249,6 +210,41 @@
 					+ artifact.getDependencyConflictId() + "': "
 					+ e.getMessage(), e);
 		}
+	}
+
+	private void generatePOM(Artifact artifact, String groupId, String artifactId, String version)
throws MojoExecutionException{
+
+		FileWriter fw = null;
+		try {
+			File tempFile = File.createTempFile("mvninstall", ".pom");
+			tempFile.deleteOnExit();
+
+			Model model = new Model();
+			model.setModelVersion("4.0.0");
+			model.setGroupId(groupId);
+			model.setArtifactId(artifactId);
+			model.setVersion(version);
+			model.setPackaging(".jar");
+			model.setDescription("POM was created from install:install-file");
+			fw = new FileWriter(tempFile);
+			tempFile.deleteOnExit();
+			new MavenXpp3Writer().write(fw, model);
+			ArtifactMetadata metadata = new ProjectArtifactMetadata(artifact, tempFile);
+			artifact.addMetadata(metadata);
+		} catch (IOException e) {
+			throw new MojoExecutionException("Error writing temporary pom file: "
+					+ e.getMessage(), e);
+		} finally {
+			IOUtil.close(fw);
+		}
+
+	}
+
+	public static String removeJarExtension(File file) {
+		String fileName = file.getName();
+		if (fileName.endsWith(".jar"))
+			return fileName.substring(0, fileName.lastIndexOf(".jar"));
+		return fileName;
 	}
 
 }

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.devtools.eclipse.core/pom.xml
URL: http://svn.apache.org/viewcvs/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.devtools.eclipse.core/pom.xml?rev=383940&r1=383939&r2=383940&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.devtools.eclipse.core/pom.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.devtools.eclipse.core/pom.xml
Tue Mar  7 09:52:53 2006
@@ -89,8 +89,8 @@
     </dependency>
     <dependency>
       <groupId>org.eclipse.plugins</groupId>
-      <artifactId>org.eclipse.jem.util</artifactId>
-      <version>${org.eclipse.jem.util_version}</version>
+      <artifactId>org.eclipse.jem.util.util</artifactId>
+      <version>${org.eclipse.jem.util.util_version}</version>
     </dependency>
     <dependency>
       <groupId>org.eclipse.plugins</groupId>

Modified: geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v1/pom.xml
URL: http://svn.apache.org/viewcvs/geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v1/pom.xml?rev=383940&r1=383939&r2=383940&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v1/pom.xml
(original)
+++ geronimo/devtools/eclipse-plugin/trunk/plugins/org.apache.geronimo.runtime.v1/pom.xml
Tue Mar  7 09:52:53 2006
@@ -1,11 +1,12 @@
 <project>
+  <modelVersion>4.0.0</modelVersion>
   <artifactId>org.apache.geronimo.runtime.v1</artifactId>
   <packaging>jar</packaging>
   <version>${org.apache.geronimo.runtime.v1_version}</version>
   <name>${artifactId}</name>
   <parent>
-  <groupId>org.apache.geronimo.devtools</groupId>
-  <artifactId>geronimo-eclipse-plugin</artifactId>
+    <groupId>org.apache.geronimo.devtools</groupId>
+    <artifactId>geronimo-eclipse-plugin</artifactId>
     <version>1.0</version>
   </parent>
   <dependencies>
@@ -13,17 +14,17 @@
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-kernel</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-util</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-deploy-jsr88</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>mx4j</groupId>
@@ -53,12 +54,12 @@
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-common</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-j2ee-schema</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>xmlbeans</groupId>
@@ -68,27 +69,27 @@
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-service-builder</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-connector-builder</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-web-builder</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-naming-builder</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-j2ee-builder</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>openejb</groupId>
@@ -98,12 +99,12 @@
     <dependency>
       <groupId>geronimo</groupId>
       <artifactId>geronimo-security-builder</artifactId>
-      <version>${geronimo_runtime_version}</version>
+      <version>${geronimo_version}</version>
     </dependency>
     <dependency>
       <groupId>stax</groupId>
       <artifactId>stax-api</artifactId>
-      <version>1.0</version>
+      <version>${stax-api_version}</version>
     </dependency>
   </dependencies>
 </project>

Modified: geronimo/devtools/eclipse-plugin/trunk/pom.xml
URL: http://svn.apache.org/viewcvs/geronimo/devtools/eclipse-plugin/trunk/pom.xml?rev=383940&r1=383939&r2=383940&view=diff
==============================================================================
--- geronimo/devtools/eclipse-plugin/trunk/pom.xml (original)
+++ geronimo/devtools/eclipse-plugin/trunk/pom.xml Tue Mar  7 09:52:53 2006
@@ -27,6 +27,10 @@
   <version>1.0</version>
   <description>Parent POM for Geronimo Eclipse Plugin</description>
   <url>http://geronimo.apache.org/devtools</url>
+  
+  <prerequisites>
+    <maven>2.0.3-SNAPSHOT</maven>
+  </prerequisites>
 
   <issueManagement>
     <system>jira</system>
@@ -116,50 +120,51 @@
     <xml_resolver_version>1.1</xml_resolver_version>
     <xbean_version>2.0.0</xbean_version>
     <stax-api_version>1.0</stax-api_version>
+    <junitVersion>3.8.1</junitVersion>
     <!-- Eclipse Plugin Dependencies -->
-    <org.eclipse.osgi_version>SNAPSHOT</org.eclipse.osgi_version>
-    <org.eclipse.debug.core_version>SNAPSHOT</org.eclipse.debug.core_version>
-    <org.eclipse.jdt.launching_version>SNAPSHOT</org.eclipse.jdt.launching_version>
-    <org.eclipse.core.runtime_version>SNAPSHOT</org.eclipse.core.runtime_version>
-    <org.eclipse.core.resources_version>SNAPSHOT</org.eclipse.core.resources_version>
-    <org.eclipse.debug.core_version>SNAPSHOT</org.eclipse.debug.core_version>
-    <org.eclipse.jdt.core_version>SNAPSHOT</org.eclipse.jdt.core_version>
-    <org.eclipse.jdt.launching_version>SNAPSHOT</org.eclipse.jdt.launching_version>
-    <org.eclipse.wst.server.core_version>SNAPSHOT</org.eclipse.wst.server.core_version>
-    <org.eclipse.jst.server.core_version>SNAPSHOT</org.eclipse.jst.server.core_version>
-    <org.eclipse.emf.ecore_version>SNAPSHOT</org.eclipse.emf.ecore_version>
-    <org.eclipse.emf.ecore.edit_version>SNAPSHOT</org.eclipse.emf.ecore.edit_version>
-    <org.eclipse.emf.edit_version>SNAPSHOT</org.eclipse.emf.edit_version>
-    <org.eclipse.emf.ecore.xmi_version>SNAPSHOT</org.eclipse.emf.ecore.xmi_version>
-    <org.eclipse.emf.common_version>SNAPSHOT</org.eclipse.emf.common_version>
-    <org.eclipse.core.commands_version>SNAPSHOT</org.eclipse.core.commands_version>
-    <org.eclipse.jst.j2ee.web_version>SNAPSHOT</org.eclipse.jst.j2ee.web_version>
-    <org.eclipse.jst.j2ee.ejb_version>SNAPSHOT</org.eclipse.jst.j2ee.ejb_version>
-    <org.eclipse.jst.j2ee.jca_version>SNAPSHOT</org.eclipse.jst.j2ee.jca_version>
-    <org.eclipse.jst.j2ee_version>SNAPSHOT</org.eclipse.jst.j2ee_version>
-    <org.eclipse.wst.web_version>SNAPSHOT</org.eclipse.wst.web_version>
-    <org.eclipse.wst.common.modulecore_version>SNAPSHOT</org.eclipse.wst.common.modulecore_version>
-    <org.eclipse.jst.common.frameworks_version>SNAPSHOT</org.eclipse.jst.common.frameworks_version>
-    <org.eclipse.wst.common.project.facet.core_version>SNAPSHOT</org.eclipse.wst.common.project.facet.core_version>
-    <org.eclipse.jst.server.generic.core_version>SNAPSHOT</org.eclipse.jst.server.generic.core_version>
-    <org.eclipse.jst.server.core_version>SNAPSHOT</org.eclipse.jst.server.core_version>
-    <org.eclipse.jst.j2ee.core_version>SNAPSHOT</org.eclipse.jst.j2ee.core_version>
-    <org.eclipse.wst.common.frameworks_version>SNAPSHOT</org.eclipse.wst.common.frameworks_version>
+    <org.eclipse.osgi_version>DISTRO</org.eclipse.osgi_version>
+    <org.eclipse.debug.core_version>DISTRO</org.eclipse.debug.core_version>
+    <org.eclipse.jdt.launching_version>DISTRO</org.eclipse.jdt.launching_version>
+    <org.eclipse.core.runtime_version>DISTRO</org.eclipse.core.runtime_version>
+    <org.eclipse.core.resources_version>DISTRO</org.eclipse.core.resources_version>
+    <org.eclipse.debug.core_version>DISTRO</org.eclipse.debug.core_version>
+    <org.eclipse.jdt.core_version>DISTRO</org.eclipse.jdt.core_version>
+    <org.eclipse.jdt.launching_version>DISTRO</org.eclipse.jdt.launching_version>
+    <org.eclipse.wst.server.core_version>DISTRO</org.eclipse.wst.server.core_version>
+    <org.eclipse.jst.server.core_version>DISTRO</org.eclipse.jst.server.core_version>
+    <org.eclipse.emf.ecore_version>DISTRO</org.eclipse.emf.ecore_version>
+    <org.eclipse.emf.ecore.edit_version>DISTRO</org.eclipse.emf.ecore.edit_version>
+    <org.eclipse.emf.edit_version>DISTRO</org.eclipse.emf.edit_version>
+    <org.eclipse.emf.ecore.xmi_version>DISTRO</org.eclipse.emf.ecore.xmi_version>
+    <org.eclipse.emf.common_version>DISTRO</org.eclipse.emf.common_version>
+    <org.eclipse.core.commands_version>DISTRO</org.eclipse.core.commands_version>
+    <org.eclipse.jst.j2ee.web_version>DISTRO</org.eclipse.jst.j2ee.web_version>
+    <org.eclipse.jst.j2ee.ejb_version>DISTRO</org.eclipse.jst.j2ee.ejb_version>
+    <org.eclipse.jst.j2ee.jca_version>DISTRO</org.eclipse.jst.j2ee.jca_version>
+    <org.eclipse.jst.j2ee_version>DISTRO</org.eclipse.jst.j2ee_version>
+    <org.eclipse.wst.web_version>DISTRO</org.eclipse.wst.web_version>
+    <org.eclipse.wst.common.modulecore_version>DISTRO</org.eclipse.wst.common.modulecore_version>
+    <org.eclipse.jst.common.frameworks_version>DISTRO</org.eclipse.jst.common.frameworks_version>
+    <org.eclipse.wst.common.project.facet.core_version>DISTRO</org.eclipse.wst.common.project.facet.core_version>
+    <org.eclipse.jst.server.generic.core_version>DISTRO</org.eclipse.jst.server.generic.core_version>
+    <org.eclipse.jst.server.core_version>DISTRO</org.eclipse.jst.server.core_version>
+    <org.eclipse.jst.j2ee.core_version>DISTRO</org.eclipse.jst.j2ee.core_version>
+    <org.eclipse.wst.common.frameworks_version>DISTRO</org.eclipse.wst.common.frameworks_version>
     <!-- Non packaged jar bundles -->
-    <org.eclipse.jem.util.util_version>SNAPSHOT</org.eclipse.jem.util.util_version>
+    <org.eclipse.jem.util.util_version>DISTRO</org.eclipse.jem.util.util_version>
     <!-- UI Dependencies -->
-    <org.eclipse.ui_version>SNAPSHOT</org.eclipse.ui_version>
-    <org.eclipse.ui.browser_version>SNAPSHOT</org.eclipse.ui.browser_version>
-    <org.eclipse.ui.editors_version>SNAPSHOT</org.eclipse.ui.editors_version>
-    <org.eclipse.ui.forms_version>SNAPSHOT</org.eclipse.ui.forms_version>
-    <org.eclipse.ui.ide_version>SNAPSHOT</org.eclipse.ui.ide_version>
-    <org.eclipse.ui.workbench_version>SNAPSHOT</org.eclipse.ui.workbench_version>
-    <org.eclipse.ui.workbench.texteditor_version>SNAPSHOT</org.eclipse.ui.workbench.texteditor_version>
-    <org.eclipse.wst.server.ui_version>SNAPSHOT</org.eclipse.wst.server.ui_version>
-    <org.eclipse.jface_version>SNAPSHOT</org.eclipse.jface_version>
-    <org.eclipse.jst.server.generic.ui_version>SNAPSHOT</org.eclipse.jst.server.generic.ui_version>
-    <org.eclipse.swt.fragment_version>SNAPSHOT</org.eclipse.swt.fragment_version>
-    <org.eclipse.emf.edit.ui_version>SNAPSHOT</org.eclipse.emf.edit.ui_version>
+    <org.eclipse.ui_version>DISTRO</org.eclipse.ui_version>
+    <org.eclipse.ui.browser_version>DISTRO</org.eclipse.ui.browser_version>
+    <org.eclipse.ui.editors_version>DISTRO</org.eclipse.ui.editors_version>
+    <org.eclipse.ui.forms_version>DISTRO</org.eclipse.ui.forms_version>
+    <org.eclipse.ui.ide_version>DISTRO</org.eclipse.ui.ide_version>
+    <org.eclipse.ui.workbench_version>DISTRO</org.eclipse.ui.workbench_version>
+    <org.eclipse.ui.workbench.texteditor_version>DISTRO</org.eclipse.ui.workbench.texteditor_version>
+    <org.eclipse.wst.server.ui_version>DISTRO</org.eclipse.wst.server.ui_version>
+    <org.eclipse.jface_version>DISTRO</org.eclipse.jface_version>
+    <org.eclipse.jst.server.generic.ui_version>DISTRO</org.eclipse.jst.server.generic.ui_version>
+    <org.eclipse.swt.fragment_version>DISTRO</org.eclipse.swt.fragment_version>
+    <org.eclipse.emf.edit.ui_version>DISTRO</org.eclipse.emf.edit.ui_version>
    </properties>
 
   <dependencies>
@@ -202,8 +207,11 @@
         <artifactId>maven-geronimodevtools-plugin</artifactId>
         <configuration>
           <urls>
+            <url>http://download.eclipse.org/eclipse/downloads/drops/R-3.1.2-200601181600/eclipse-SDK-3.1.2-macosx-carbon.tar.gz</url>
             <url>http://download.eclipse.org/tools/ve/downloads/drops/R-1.1.0.1-200509071822/JEM-SDK-1.1.0.1.zip</url>
             <url>http://download.eclipse.org/tools/emf/downloads/drops/2.1.2/R200601191349/emf-sdo-xsd-SDK-2.1.2.zip</url>
+            <url>http://download.eclipse.org/tools/gef/downloads/drops/R-3.1.1-200509301327/GEF-SDK-3.1.1.zip</url>
+            <url>http://download.eclipse.org/webtools/downloads/drops/R-1.0.1-200602171228/wtp-sdk-R-1.0.1-200602171228.zip</url>
           </urls>
           <eclipsehome>${settings.localRepository}/eclipse/eclipse/</eclipsehome>
           <versionType>snapshot</versionType>
@@ -238,8 +246,20 @@
       <name>Maven Central Development Repository</name>
       <url>http://snapshots.maven.codehaus.org/maven2</url>
     </repository>
+    <repository>
+      <id>apache-cvs</id>
+      <name>Apache CVS Repository</name>
+      <url>http://cvs.apache.org/repository</url>
+      <layout>legacy</layout>
+    </repository>
+    <repository>
+      <id>maven1-ibiblio</id>
+      <name>Maven1 Repository on iBiblio</name>
+      <url>http://www.ibiblio.org/maven/</url>
+      <layout>legacy</layout>
+    </repository>
   </repositories>
-  
+    
   <pluginRepositories>
     <pluginRepository>
       <id>snapshots</id>
@@ -255,6 +275,7 @@
     <module>plugins/org.apache.geronimo.jetty.j2ee.server.v1</module>
     <module>plugins/org.apache.geronimo.tomcat.j2ee.server.v1</module>
     <module>plugins/org.apache.geronimo.ui</module>
+    <module>plugins/org.apache.geronimo.runtime.v1</module>
     <!--<module>features/org.apache.geronimo.feature</module>
     <module>features/org.apache.geronimo.installableruntime.j2ee.feature</module>
     <module>features/org.apache.geronimo.installableruntime.tomcat.feature</module>-->



Mime
View raw message