geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From djen...@apache.org
Subject svn commit: r377628 - in /geronimo/trunk: assemblies/minimal-tomcat-server/ assemblies/web-jms-tomcat-server/ configs/daytrader-jetty/ configs/daytrader-tomcat/ configs/j2ee-deployer/ configs/j2ee-server/ modules/tomcat/
Date Tue, 14 Feb 2006 05:35:32 GMT
Author: djencks
Date: Mon Feb 13 21:35:29 2006
New Revision: 377628

URL: http://svn.apache.org/viewcvs?rev=377628&view=rev
Log:
GERONIMO-1613.  Remove/move excess dependencies, fix derby problems by import of system-database.

Modified:
    geronimo/trunk/assemblies/minimal-tomcat-server/project.xml
    geronimo/trunk/assemblies/web-jms-tomcat-server/project.xml
    geronimo/trunk/configs/daytrader-jetty/project.xml
    geronimo/trunk/configs/daytrader-tomcat/project.xml
    geronimo/trunk/configs/j2ee-deployer/project.xml
    geronimo/trunk/configs/j2ee-server/project.xml
    geronimo/trunk/modules/tomcat/project.xml

Modified: geronimo/trunk/assemblies/minimal-tomcat-server/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/trunk/assemblies/minimal-tomcat-server/project.xml?rev=377628&r1=377627&r2=377628&view=diff
==============================================================================
--- geronimo/trunk/assemblies/minimal-tomcat-server/project.xml (original)
+++ geronimo/trunk/assemblies/minimal-tomcat-server/project.xml Mon Feb 13 21:35:29 2006
@@ -90,15 +90,6 @@
                 <geronimo.assemble>install</geronimo.assemble>
             </properties>
         </dependency>
-        <!--<dependency>-->
-            <!--<groupId>geronimo</groupId>-->
-            <!--<artifactId>hot-deployer</artifactId>-->
-            <!--<type>car</type>-->
-            <!--<version>${pom.currentVersion}</version>-->
-            <!--<properties>-->
-                <!--<geronimo.assemble>install</geronimo.assemble>-->
-            <!--</properties>-->
-        <!--</dependency>-->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>j2ee-deployer</artifactId>
@@ -145,15 +136,6 @@
             </properties>
         </dependency>
 <!--applications-->
-        <!--<dependency>-->
-            <!--<groupId>geronimo</groupId>-->
-            <!--<artifactId>remote-deploy-tomcat</artifactId>-->
-            <!--<type>car</type>-->
-            <!--<version>${pom.currentVersion}</version>-->
-            <!--<properties>-->
-                <!--<geronimo.assemble>install</geronimo.assemble>-->
-            <!--</properties>-->
-        <!--</dependency>-->
 
         <!-- unpack --> 
         <dependency>
@@ -246,7 +228,6 @@
             <version>${geronimo_spec_qname_version}</version>
             <properties>
                 <geronimo.assemble>library</geronimo.assemble>
-                <!--<geronimo.assemble>repository</geronimo.assemble>-->
             </properties>
         </dependency>
 
@@ -328,17 +309,6 @@
             </properties>
         </dependency>
 
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>geronimo</groupId>
-        #    <artifactId>geronimo-deploy-tool</artifactId>
-        #    <version>${pom.currentVersion}</version>
-        #    <properties>
-        #        <geronimo.assemble>library</geronimo.assemble>
-        #    </properties>
-        #</dependency>
-        -->
-
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-util</artifactId>
@@ -368,16 +338,6 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-j2ee-deployment_1.1_spec</artifactId>
-        #    <version>${geronimo_spec_j2ee_deployment_version}</version>
-        #    <properties>
-        #        <geronimo.assemble>repository</geronimo.assemble>
-        #    </properties>
-        #</dependency>
-        -->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
@@ -410,16 +370,6 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-qname_1.1_spec</artifactId>
-        #    <version>${geronimo_spec_qname_version}</version>
-        #    <properties>
-        #        <geronimo.assemble>repository</geronimo.assemble>
-        #    </properties>
-        #</dependency>
-        -->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-servlet_2.4_spec</artifactId>
@@ -463,14 +413,6 @@
             <version>${asm_version}</version>                                                         
         </dependency>
 
-        <!--
-        <dependency>
-            <groupId>axis</groupId>
-            <artifactId>axis</artifactId>
-            <version>${axis_version}</version>
-        </dependency>
-        -->
-
         <dependency>
             <groupId>commons-collections</groupId>
             <artifactId>commons-collections</artifactId>
@@ -766,74 +708,12 @@
 
         <!-- Specification dependencies to preload into the repository -->
         
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-j2ee_1.4_spec</artifactId>
-        #    <version>${geronimo_spec_j2ee_version}</version>
-        #</dependency>
-        -->
-
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
-        #    <version>${geronimo_spec_j2ee_jacc_version}</version>
-        #</dependency>
-        -->
-
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-activation_1.0.2_spec</artifactId>
-        #    <version>${geronimo_spec_activation_version}</version>
-        #</dependency>
-        -->
-
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-javamail_1.3.1_spec</artifactId>
-        #    <version>${geronimo_spec_javamail_version}</version>
-        #</dependency>
-        -->
-
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-corba_2.3_spec</artifactId>
-        #    <version>${geronimo_spec_corba_version}</version>
-        #</dependency>
-        -->
-
         <!-- Geronimo modules to preload into the repository -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-activation</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-axis</artifactId>
-            <version>${pom.currentVersion}</version>
-         </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-axis-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-         </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-client</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-client-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-         -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-connector</artifactId>
@@ -874,30 +754,11 @@
             <artifactId>geronimo-j2ee-schema</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-jetty</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-jetty-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-jmxremoting</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-mail</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-management</artifactId>
@@ -923,13 +784,6 @@
             <artifactId>geronimo-security-builder</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-service-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-timer</artifactId>
@@ -945,25 +799,11 @@
             <artifactId>geronimo-transaction</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>geronimo</groupId>
-        #    <artifactId>geronimo-util</artifactId>
-        #    <version>${pom.currentVersion}</version>
-        #</dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-web-builder</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-webservices</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        -->
 
     </dependencies>
 </project>

Modified: geronimo/trunk/assemblies/web-jms-tomcat-server/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/trunk/assemblies/web-jms-tomcat-server/project.xml?rev=377628&r1=377627&r2=377628&view=diff
==============================================================================
--- geronimo/trunk/assemblies/web-jms-tomcat-server/project.xml (original)
+++ geronimo/trunk/assemblies/web-jms-tomcat-server/project.xml Mon Feb 13 21:35:29 2006
@@ -80,26 +80,6 @@
                 <geronimo.assemble>install</geronimo.assemble>
             </properties>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>directory</artifactId>
-            <type>car</type>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>install</geronimo.assemble>
-            </properties>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>ldap-realm</artifactId>
-            <type>car</type>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>install</geronimo.assemble>
-            </properties>
-        </dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>system-database</artifactId>
@@ -128,45 +108,6 @@
             </properties>
         </dependency>
 <!-- client -->
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>client-system</artifactId>
-            <type>car</type>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>install</geronimo.assemble>
-                <geronimo.assemble.executable>bin/client.jar</geronimo.assemble.executable>
-            </properties>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>client</artifactId>
-            <type>car</type>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>install</geronimo.assemble>
-            </properties>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>client-security</artifactId>
-            <type>car</type>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>install</geronimo.assemble>
-            </properties>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>client-corba</artifactId>
-            <type>car</type>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>install</geronimo.assemble>
-            </properties>
-        </dependency>
-        -->
 <!--deployers-->
         <dependency>
             <groupId>geronimo</groupId>
@@ -232,17 +173,6 @@
             </properties>
         </dependency>
 <!--applications-->
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>ldap-demo-tomcat</artifactId>
-            <type>car</type>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>install</geronimo.assemble>
-            </properties>
-        </dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>welcome-tomcat</artifactId>
@@ -297,17 +227,6 @@
                 <geronimo.assemble>install</geronimo.assemble>
             </properties>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>uddi-tomcat</artifactId>
-            <type>car</type>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>install</geronimo.assemble>
-            </properties>
-        </dependency>
-        -->
 
         <!-- unpack --> 
         <dependency>
@@ -400,7 +319,6 @@
             <version>${geronimo_spec_qname_version}</version>
             <properties>
                 <geronimo.assemble>library</geronimo.assemble>
-                <!--<geronimo.assemble>repository</geronimo.assemble>-->
             </properties>
         </dependency>
 
@@ -470,7 +388,6 @@
             <version>${geronimo_spec_j2ee_deployment_version}</version>
             <properties>
                 <geronimo.assemble>library</geronimo.assemble>
-                <!--<geronimo.assemble>repository</geronimo.assemble>-->
             </properties>
         </dependency>
         <dependency>
@@ -482,17 +399,6 @@
             </properties>
         </dependency>
 
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>geronimo</groupId>
-        #    <artifactId>geronimo-deploy-tool</artifactId>
-        #    <version>${pom.currentVersion}</version>
-        #    <properties>
-        #        <geronimo.assemble>library</geronimo.assemble>
-        #    </properties>
-        #</dependency>
-        -->
-
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-util</artifactId>
@@ -598,26 +504,6 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-<!--
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-corba_2.3_spec</artifactId>
-            <version>${geronimo_spec_corba_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
--->
-        <!--
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-ejb_2.1_spec</artifactId>
-            <version>${geronimo_spec_ejb_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
-        -->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-j2ee_1.4_spec</artifactId>
@@ -634,16 +520,6 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-j2ee-deployment_1.1_spec</artifactId>
-        #    <version>${geronimo_spec_j2ee_deployment_version}</version>
-        #    <properties>
-        #        <geronimo.assemble>repository</geronimo.assemble>
-        #    </properties>
-        #</dependency>
-        -->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
@@ -660,34 +536,6 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-javamail_1.3.1_spec</artifactId>
-            <version>${geronimo_spec_javamail_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
-        -->
-<!--
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-jaxr_1.0_spec</artifactId>
-            <version>${geronimo_spec_jaxr_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-jaxrpc_1.1_spec</artifactId>
-            <version>${geronimo_spec_jaxrpc_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
--->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-jms_1.1_spec</artifactId>
@@ -712,26 +560,6 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-qname_1.1_spec</artifactId>
-        #    <version>${geronimo_spec_qname_version}</version>
-        #    <properties>
-        #        <geronimo.assemble>repository</geronimo.assemble>
-        #    </properties>
-        #</dependency>
-        -->
-<!--
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-saaj_1.1_spec</artifactId>
-            <version>${geronimo_spec_saaj_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
--->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-servlet_2.4_spec</artifactId>
@@ -775,14 +603,6 @@
             <version>${asm_version}</version>                                                         
         </dependency>
 
-        <!--
-        <dependency>
-            <groupId>axis</groupId>
-            <artifactId>axis</artifactId>
-            <version>${axis_version}</version>
-        </dependency>
-        -->
-
         <dependency>
             <groupId>commons-collections</groupId>
             <artifactId>commons-collections</artifactId>
@@ -828,73 +648,6 @@
             <version>${concurrent_version}</version>
         </dependency>
 
-        <!--
-        <dependency>
-            <groupId>directory</groupId>
-            <artifactId>apacheds-core</artifactId>
-            <version>${apacheds_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory</groupId>
-            <artifactId>apacheds-shared</artifactId>
-            <version>${apacheds_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-asn1</groupId>
-            <artifactId>asn1-ber</artifactId>
-            <version>${asn1_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-asn1</groupId>
-            <artifactId>asn1-codec</artifactId>
-            <version>${asn1_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-asn1</groupId>
-            <artifactId>asn1-der</artifactId>
-            <version>${asn1_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-network</groupId>
-            <artifactId>mina</artifactId>
-            <version>${mina_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-protocols</groupId>
-            <artifactId>kerberos-protocol</artifactId>
-            <version>${kerberos_protocols_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-protocols</groupId>
-            <artifactId>ldap-protocol</artifactId>
-            <version>${ldap_protocols_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-shared</groupId>
-            <artifactId>apache-ldapber-provider</artifactId>
-            <version>${apacheds_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-shared</groupId>
-            <artifactId>kerberos-common</artifactId>
-            <version>${kerberos_common_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>directory-shared</groupId>
-            <artifactId>ldap-common</artifactId>
-            <version>${apacheds_version}</version>
-        </dependency>
-        -->
 
 <!-- geronimo jars -->
 <!-- geronimo spec jars -->
@@ -918,33 +671,6 @@
             <version>${jdom_version}</version>
         </dependency>
 
-
-        <!--
-        <dependency>
-            <groupId>juddi</groupId>
-            <artifactId>juddi</artifactId>
-            <version>${juddi_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>openejb</groupId>
-            <artifactId>openejb-builder</artifactId>
-            <version>${openejb_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>openejb</groupId>
-            <artifactId>openejb-core</artifactId>
-            <version>${openejb_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>openejb</groupId>
-            <artifactId>openejb-pkgen-builder</artifactId>
-            <version>${openejb_version}</version>
-        </dependency>
-        -->
-
         <dependency>
             <groupId>org.apache.derby</groupId>
             <artifactId>derby</artifactId>
@@ -1171,74 +897,12 @@
 
         <!-- Specification dependencies to preload into the repository -->
         
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-j2ee_1.4_spec</artifactId>
-        #    <version>${geronimo_spec_j2ee_version}</version>
-        #</dependency>
-        -->
-
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
-        #    <version>${geronimo_spec_j2ee_jacc_version}</version>
-        #</dependency>
-        -->
-
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-activation_1.0.2_spec</artifactId>
-        #    <version>${geronimo_spec_activation_version}</version>
-        #</dependency>
-        -->
-
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-javamail_1.3.1_spec</artifactId>
-        #    <version>${geronimo_spec_javamail_version}</version>
-        #</dependency>
-        -->
-
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>org.apache.geronimo.specs</groupId>
-        #    <artifactId>geronimo-corba_2.3_spec</artifactId>
-        #    <version>${geronimo_spec_corba_version}</version>
-        #</dependency>
-        -->
-
         <!-- Geronimo modules to preload into the repository -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-activation</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-axis</artifactId>
-            <version>${pom.currentVersion}</version>
-         </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-axis-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-         </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-client</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-client-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-         -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-connector</artifactId>
@@ -1279,30 +943,11 @@
             <artifactId>geronimo-j2ee-schema</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-jetty</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-jetty-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-jmxremoting</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-mail</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-management</artifactId>
@@ -1328,13 +973,6 @@
             <artifactId>geronimo-security-builder</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-service-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-timer</artifactId>
@@ -1350,25 +988,11 @@
             <artifactId>geronimo-transaction</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!-- duplicate dependency - commented out to avoid eclipse project errors
-        #<dependency>
-        #    <groupId>geronimo</groupId>
-        #    <artifactId>geronimo-util</artifactId>
-        #    <version>${pom.currentVersion}</version>
-        #</dependency>
-        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-web-builder</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-webservices</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-        -->
 
     </dependencies>
 </project>

Modified: geronimo/trunk/configs/daytrader-jetty/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/trunk/configs/daytrader-jetty/project.xml?rev=377628&r1=377627&r2=377628&view=diff
==============================================================================
--- geronimo/trunk/configs/daytrader-jetty/project.xml (original)
+++ geronimo/trunk/configs/daytrader-jetty/project.xml Mon Feb 13 21:35:29 2006
@@ -76,41 +76,51 @@
             <version>${geronimo_version}</version>
             <type>car</type>
             <properties>
-                 <geronimo.import>true</geronimo.import>
-             </properties>
+                <geronimo.import>true</geronimo.import>
+            </properties>
+        </dependency>
+        <!--required as parent of this derby db to get derby engine classes -->
+        <dependency>
+            <groupId>geronimo</groupId>
+            <artifactId>system-database</artifactId>
+            <version>${geronimo_version}</version>
+            <type>car</type>
+            <properties>
+                <geronimo.import>true</geronimo.import>
+            </properties>
         </dependency>
 
-    <dependency>
-        <groupId>geronimo</groupId>
-        <artifactId>geronimo-daytrader-derby-db</artifactId>
-        <version>${pom.currentVersion}</version>
+        <dependency>
+            <groupId>geronimo</groupId>
+            <artifactId>geronimo-daytrader-derby-db</artifactId>
+            <version>${pom.currentVersion}</version>
             <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-    </dependency>
-    <dependency>
-        <groupId>geronimo</groupId>
-        <artifactId>daytrader-ear</artifactId>
-        <version>${pom.currentVersion}</version>
-        <type>ear</type>
-    </dependency>
+                <geronimo.dependency>true</geronimo.dependency>
+            </properties>
+        </dependency>
+        <dependency>
+            <groupId>geronimo</groupId>
+            <artifactId>daytrader-ear</artifactId>
+            <version>${pom.currentVersion}</version>
+            <type>ear</type>
+        </dependency>
 
-    <dependency>
-        <groupId>activemq</groupId>
-        <artifactId>activemq-ra</artifactId>
-        <version>${activemq_version}</version>
-         <type>rar</type>
-    </dependency>
+        <dependency>
+            <groupId>activemq</groupId>
+            <artifactId>activemq-ra</artifactId>
+            <version>${activemq_version}</version>
+            <type>rar</type>
+        </dependency>
 
-    <dependency>
-        <groupId>tranql</groupId>
-        <artifactId>tranql-connector-derby-embed-xa</artifactId>
-        <version>${tranql_vendors_version}</version>
-        <type>rar</type>
-    </dependency>
+        <dependency>
+            <groupId>tranql</groupId>
+            <artifactId>tranql-connector-derby-embed-xa</artifactId>
+            <version>${tranql_vendors_version}</version>
+            <type>rar</type>
+        </dependency>
 
 
-<!--inessentials -->
+        <!--inessentials -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-system</artifactId>

Modified: geronimo/trunk/configs/daytrader-tomcat/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/trunk/configs/daytrader-tomcat/project.xml?rev=377628&r1=377627&r2=377628&view=diff
==============================================================================
--- geronimo/trunk/configs/daytrader-tomcat/project.xml (original)
+++ geronimo/trunk/configs/daytrader-tomcat/project.xml Mon Feb 13 21:35:29 2006
@@ -76,43 +76,52 @@
             <version>${geronimo_version}</version>
             <type>car</type>
             <properties>
-                 <geronimo.import>true</geronimo.import>
-             </properties>
+                <geronimo.import>true</geronimo.import>
+            </properties>
+        </dependency>
+        <!--required as parent of this derby db to get derby engine classes -->
+        <dependency>
+            <groupId>geronimo</groupId>
+            <artifactId>system-database</artifactId>
+            <version>${geronimo_version}</version>
+            <type>car</type>
+            <properties>
+                <geronimo.import>true</geronimo.import>
+            </properties>
         </dependency>
 
 
-
-    <dependency>
-        <groupId>geronimo</groupId>
-        <artifactId>geronimo-daytrader-derby-db</artifactId>
-        <version>${pom.currentVersion}</version>
+        <dependency>
+            <groupId>geronimo</groupId>
+            <artifactId>geronimo-daytrader-derby-db</artifactId>
+            <version>${pom.currentVersion}</version>
             <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-    </dependency>
-    <dependency>
-        <groupId>geronimo</groupId>
-        <artifactId>daytrader-ear</artifactId>
-        <version>${pom.currentVersion}</version>
-        <type>ear</type>
-    </dependency>
-
-    <dependency>
-        <groupId>activemq</groupId>
-        <artifactId>activemq-ra</artifactId>
-        <version>${activemq_version}</version>
-         <type>rar</type>
-    </dependency>
-
-    <dependency>
-        <groupId>tranql</groupId>
-        <artifactId>tranql-connector-derby-embed-xa</artifactId>
-        <version>${tranql_vendors_version}</version>
-        <type>rar</type>
-    </dependency>
+                <geronimo.dependency>true</geronimo.dependency>
+            </properties>
+        </dependency>
+        <dependency>
+            <groupId>geronimo</groupId>
+            <artifactId>daytrader-ear</artifactId>
+            <version>${pom.currentVersion}</version>
+            <type>ear</type>
+        </dependency>
+
+        <dependency>
+            <groupId>activemq</groupId>
+            <artifactId>activemq-ra</artifactId>
+            <version>${activemq_version}</version>
+            <type>rar</type>
+        </dependency>
+
+        <dependency>
+            <groupId>tranql</groupId>
+            <artifactId>tranql-connector-derby-embed-xa</artifactId>
+            <version>${tranql_vendors_version}</version>
+            <type>rar</type>
+        </dependency>
 
 
-<!--inessentials -->
+        <!--inessentials -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-system</artifactId>

Modified: geronimo/trunk/configs/j2ee-deployer/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/trunk/configs/j2ee-deployer/project.xml?rev=377628&r1=377627&r2=377628&view=diff
==============================================================================
--- geronimo/trunk/configs/j2ee-deployer/project.xml (original)
+++ geronimo/trunk/configs/j2ee-deployer/project.xml Mon Feb 13 21:35:29 2006
@@ -53,62 +53,10 @@
     </dependency>
 
         <!-- dependencies from gbean-deployer needed as maven adds service builder to the maven.root classloader -->
-<!--        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-system</artifactId>
-            <version>${geronimo_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-common</artifactId>
-            <version>${geronimo_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-deployment</artifactId>
-            <version>${geronimo_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-j2ee</artifactId>
-            <version>${geronimo_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-service-builder</artifactId>
-            <version>${geronimo_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>xmlbeans</groupId>
-            <artifactId>xbean</artifactId>
-            <version>${xmlbeans_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>stax</groupId>
-            <artifactId>stax-api</artifactId>
-            <version>${stax_api_version}</version>
-        </dependency>
--->
+
         <!-- dependencies from plan -->
 
         <!-- common libraries used by all builders -->
-<!--        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-j2ee_1.4_spec</artifactId>
-            <version>${geronimo_spec_j2ee_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-corba_2.3_spec</artifactId>
-            <version>${geronimo_spec_corba_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
--->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-j2ee-schema</artifactId>
@@ -153,14 +101,6 @@
                  <geronimo.dependency>true</geronimo.dependency>
              </properties>
         </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-client-builder</artifactId>
-            <version>${geronimo_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
        <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-naming-builder</artifactId>
@@ -193,25 +133,6 @@
                  <geronimo.dependency>true</geronimo.dependency>
              </properties>
         </dependency>
-<!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-axis-builder</artifactId>
-            <version>${geronimo_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-axis</artifactId>
-            <version>${geronimo_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-    
--->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-webservices</artifactId>
@@ -220,18 +141,7 @@
                  <geronimo.dependency>true</geronimo.dependency>
              </properties>
         </dependency>
-<!--
-        <dependency>
-            <groupId>axis</groupId>
-            <artifactId>axis</artifactId>
-            <version>${axis_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>wsdl4j</groupId>
-            <artifactId>wsdl4j</artifactId>
-            <version>${wsdl4j_version}</version>
-        </dependency>
--->
+
         <!-- WARs using Jetty -->
         <dependency>
             <groupId>geronimo</groupId>
@@ -241,58 +151,9 @@
                  <geronimo.dependency>true</geronimo.dependency>
              </properties>
         </dependency>
-<!--
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-jetty-builder</artifactId>
-            <version>${geronimo_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-jetty</artifactId>
-            <version>${geronimo_version}</version>
-        </dependency>
-        <dependency>
-            <groupId>jetty</groupId>
-            <artifactId>org.mortbay.jetty</artifactId>
-            <version>${jetty_version}</version>
-        </dependency>
--->
+
         <!-- EJBs using OpenEJB -->
-<!--
-        <dependency>
-            <groupId>openejb</groupId>
-            <artifactId>openejb-builder</artifactId>
-            <version>${openejb_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-        <dependency>
-            <groupId>openejb</groupId>
-            <artifactId>openejb-pkgen-builder</artifactId>
-            <version>${openejb_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-        <dependency>
-            <groupId>openejb</groupId>
-            <artifactId>openejb-core</artifactId>
-            <version>${openejb_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-        <dependency>
-            <groupId>tranql</groupId>
-            <artifactId>tranql</artifactId>
-            <version>${tranql_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
--->
+
         <!-- RARs using Geronimo Connector implementation -->
         <dependency>
             <groupId>geronimo</groupId>

Modified: geronimo/trunk/configs/j2ee-server/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/trunk/configs/j2ee-server/project.xml?rev=377628&r1=377627&r2=377628&view=diff
==============================================================================
--- geronimo/trunk/configs/j2ee-server/project.xml (original)
+++ geronimo/trunk/configs/j2ee-server/project.xml Mon Feb 13 21:35:29 2006
@@ -25,6 +25,7 @@
     <name>Server Configuration for the J2EE Server</name>
 
     <dependencies>
+
         <!-- dependency on deployer -->
         <dependency>
             <groupId>geronimo</groupId>
@@ -38,6 +39,7 @@
             <version>${geronimo_version}</version>
             <type>car</type>
         </dependency>
+
         <!-- parent config -->
         <dependency>
             <groupId>geronimo</groupId>
@@ -48,6 +50,7 @@
                  <geronimo.import>true</geronimo.import>
              </properties>
         </dependency>
+
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-core</artifactId>
@@ -104,30 +107,6 @@
                  <geronimo.dependency>true</geronimo.dependency>
              </properties>
         </dependency>
-        <!--<dependency>-->
-            <!--<groupId>openejb</groupId>-->
-            <!--<artifactId>openejb-core</artifactId>-->
-            <!--<version>${openejb_version}</version>-->
-            <!--<properties>-->
-                 <!--<geronimo.dependency>true</geronimo.dependency>-->
-             <!--</properties>-->
-        <!--</dependency>-->
-        <dependency>
-            <groupId>xstream</groupId>
-            <artifactId>xstream</artifactId>
-            <version>${xstream_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-        <dependency>
-            <groupId>xpp3</groupId>
-            <artifactId>xpp3</artifactId>
-            <version>${xpp3_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
         <dependency>
             <groupId>asm</groupId>
             <artifactId>asm</artifactId>
@@ -136,16 +115,6 @@
                  <geronimo.dependency>true</geronimo.dependency>
              </properties>
         </dependency>
-<!--
-        <dependency>
-            <groupId>activemq</groupId>
-            <artifactId>activemq-gbean-management</artifactId>
-            <version>${activemq_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
--->
         <dependency>
             <groupId>activeio</groupId>
             <artifactId>activeio</artifactId>
@@ -154,71 +123,6 @@
                  <geronimo.dependency>true</geronimo.dependency>
              </properties>
         </dependency>
-       <dependency>
-            <groupId>scout</groupId>
-            <artifactId>jaxr-api</artifactId>
-            <version>${scout_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-            </properties>
-        </dependency>
-
-        <dependency>
-            <groupId>scout</groupId>
-            <artifactId>scout</artifactId>
-            <version>${scout_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-            </properties>
-        </dependency>
-
-        <dependency>
-            <groupId>juddi</groupId>
-            <artifactId>juddi</artifactId>
-            <version>${juddi_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-            </properties>
-        </dependency>
-
-        <dependency>
-            <groupId>jdom</groupId>
-            <artifactId>jdom</artifactId>
-            <version>${jdom_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-            </properties>
-        </dependency>
-
-
-        <!-- TODO why are these here rather than in system-database??? -->
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-derby</artifactId>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-            </properties>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.derby</groupId>
-            <artifactId>derby</artifactId>
-            <version>${derby_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-            </properties>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.derby</groupId>
-            <artifactId>derbynet</artifactId>
-            <version>${derby_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-            </properties>
-        </dependency>
-
 
         <dependency>
             <groupId>geronimo</groupId>
@@ -285,11 +189,6 @@
             <artifactId>concurrent</artifactId>
             <version>${concurrent_version}</version>
         </dependency>
-        <!--<dependency>-->
-            <!--<groupId>tranql</groupId>-->
-            <!--<artifactId>tranql</artifactId>-->
-            <!--<version>${tranql_version}</version>-->
-        <!--</dependency>-->
         <dependency>
             <groupId>howl</groupId>
             <artifactId>howl-logger</artifactId>

Modified: geronimo/trunk/modules/tomcat/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/trunk/modules/tomcat/project.xml?rev=377628&r1=377627&r2=377628&view=diff
==============================================================================
--- geronimo/trunk/modules/tomcat/project.xml (original)
+++ geronimo/trunk/modules/tomcat/project.xml Mon Feb 13 21:35:29 2006
@@ -181,23 +181,6 @@
             </properties>
         </dependency>
         <dependency>
-            <groupId>activecluster</groupId>
-            <artifactId>activecluster</artifactId>
-            <version>${wadi_activecluster_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-        <dependency>
-            <groupId>springframework</groupId>
-            <artifactId>spring</artifactId>
-            <version>${wadi_spring_version}</version>
-            <url>http://www.springframework.org/</url>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
-        </dependency>
-        <dependency>
             <groupId>tomcat</groupId>
             <artifactId>catalina</artifactId>
             <version>${tomcat_version}</version>
@@ -403,17 +386,11 @@
             <groupId>wadi</groupId>
             <artifactId>wadi-core</artifactId>
             <version>${wadi_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
         </dependency>
         <dependency>
             <groupId>wadi</groupId>
             <artifactId>wadi-tomcat55</artifactId>
             <version>${wadi_version}</version>
-            <properties>
-                 <geronimo.dependency>true</geronimo.dependency>
-             </properties>
         </dependency>
     </dependencies>
 </project>



Mime
View raw message