geronimo-scm mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jsis...@apache.org
Subject svn commit: r367948 - in /geronimo/branches/1.0: assemblies/j2ee-jetty-server/ assemblies/j2ee-tomcat-server/ modules/axis-builder/ modules/jetty-builder/ modules/timer/ modules/tomcat-builder/
Date Wed, 11 Jan 2006 06:31:43 GMT
Author: jsisson
Date: Tue Jan 10 22:31:27 2006
New Revision: 367948

URL: http://svn.apache.org/viewcvs?rev=367948&view=rev
Log:
GERONIMO-1441 - comment out, consolidate or remove duplicate dependencies that cause "Build
path contains duplicate entry" errors in eclipse 3.1.1 projects.

Modified:
    geronimo/branches/1.0/assemblies/j2ee-jetty-server/project.xml
    geronimo/branches/1.0/assemblies/j2ee-tomcat-server/project.xml
    geronimo/branches/1.0/modules/axis-builder/project.xml
    geronimo/branches/1.0/modules/jetty-builder/project.xml
    geronimo/branches/1.0/modules/timer/project.xml
    geronimo/branches/1.0/modules/tomcat-builder/project.xml

Modified: geronimo/branches/1.0/assemblies/j2ee-jetty-server/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/branches/1.0/assemblies/j2ee-jetty-server/project.xml?rev=367948&r1=367947&r2=367948&view=diff
==============================================================================
--- geronimo/branches/1.0/assemblies/j2ee-jetty-server/project.xml (original)
+++ geronimo/branches/1.0/assemblies/j2ee-jetty-server/project.xml Tue Jan 10 22:31:27 2006
@@ -71,7 +71,7 @@
                 <geronimo.assemble>install</geronimo.assemble>
             </properties>
         </dependency>
-         <dependency>
+        <dependency>
             <groupId>geronimo</groupId>
             <artifactId>j2ee-corba</artifactId>
             <type>car</type>
@@ -401,6 +401,7 @@
             <version>${geronimo_spec_qname_version}</version>
             <properties>
                 <geronimo.assemble>library</geronimo.assemble>
+                <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
 
@@ -470,6 +471,7 @@
             <version>${geronimo_spec_j2ee_deployment_version}</version>
             <properties>
                 <geronimo.assemble>library</geronimo.assemble>
+                <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
         <dependency>
@@ -481,14 +483,16 @@
             </properties>
         </dependency>
 
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-deploy-tool</artifactId>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>library</geronimo.assemble>
-            </properties>
-        </dependency>
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>geronimo</groupId>
+        #    <artifactId>geronimo-deploy-tool</artifactId>
+        #    <version>${pom.currentVersion}</version>
+        #    <properties>
+        #        <geronimo.assemble>library</geronimo.assemble>
+        #    </properties>
+        #</dependency>
+        -->
 
         <dependency>
             <groupId>geronimo</groupId>
@@ -627,14 +631,16 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-j2ee-deployment_1.1_spec</artifactId>
-            <version>${geronimo_spec_j2ee_deployment_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-j2ee-deployment_1.1_spec</artifactId>
+        #    <version>${geronimo_spec_j2ee_deployment_version}</version>
+        #    <properties>
+        #        <geronimo.assemble>repository</geronimo.assemble>
+        #    </properties>
+        #</dependency>
+        -->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
@@ -699,14 +705,16 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-qname_1.1_spec</artifactId>
-            <version>${geronimo_spec_qname_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-qname_1.1_spec</artifactId>
+        #    <version>${geronimo_spec_qname_version}</version>
+        #    <properties>
+        #        <geronimo.assemble>repository</geronimo.assemble>
+        #    </properties>
+        #</dependency>
+        -->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-saaj_1.1_spec</artifactId>
@@ -997,12 +1005,6 @@
         </dependency>
         <dependency>
             <groupId>tomcat</groupId>
-            <artifactId>catalina</artifactId>
-            <version>${tomcat_version}</version>
-            <url>http://jakarta.apache.org/tomcat/</url>
-        </dependency>
-        <dependency>
-            <groupId>tomcat</groupId>
             <artifactId>catalina-optional</artifactId>
             <version>${tomcat_version}</version>
             <url>http://jakarta.apache.org/tomcat/</url>
@@ -1150,35 +1152,46 @@
         </dependency>
 
         <!-- Specification dependencies to preload into the repository -->
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-j2ee_1.4_spec</artifactId>
-            <version>${geronimo_spec_j2ee_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
-            <version>${geronimo_spec_j2ee_jacc_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-activation_1.0.2_spec</artifactId>
-            <version>${geronimo_spec_activation_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-javamail_1.3.1_spec</artifactId>
-            <version>${geronimo_spec_javamail_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-corba_2.3_spec</artifactId>
-            <version>${geronimo_spec_corba_version}</version>
-        </dependency>
+        
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-j2ee_1.4_spec</artifactId>
+        #    <version>${geronimo_spec_j2ee_version}</version>
+        #</dependency>
+        -->
+
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
+        #    <version>${geronimo_spec_j2ee_jacc_version}</version>
+        #</dependency>
+        -->
+
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-activation_1.0.2_spec</artifactId>
+        #    <version>${geronimo_spec_activation_version}</version>
+        #</dependency>
+        -->
+
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-javamail_1.3.1_spec</artifactId>
+        #    <version>${geronimo_spec_javamail_version}</version>
+        #</dependency>
+        -->
+
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-corba_2.3_spec</artifactId>
+        #    <version>${geronimo_spec_corba_version}</version>
+        #</dependency>
+        -->
 
         <!-- Geronimo modules to preload into the repository -->
         <dependency>
@@ -1311,11 +1324,13 @@
             <artifactId>geronimo-transaction</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-util</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>geronimo</groupId>
+        #    <artifactId>geronimo-util</artifactId>
+        #    <version>${pom.currentVersion}</version>
+        #</dependency>
+        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-web-builder</artifactId>

Modified: geronimo/branches/1.0/assemblies/j2ee-tomcat-server/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/branches/1.0/assemblies/j2ee-tomcat-server/project.xml?rev=367948&r1=367947&r2=367948&view=diff
==============================================================================
--- geronimo/branches/1.0/assemblies/j2ee-tomcat-server/project.xml (original)
+++ geronimo/branches/1.0/assemblies/j2ee-tomcat-server/project.xml Tue Jan 10 22:31:27 2006
@@ -134,7 +134,7 @@
                 <geronimo.assemble>install</geronimo.assemble>
             </properties>
         </dependency>
-<!--client-->
+<!-- client -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>client-system</artifactId>
@@ -391,6 +391,7 @@
             <version>${geronimo_spec_qname_version}</version>
             <properties>
                 <geronimo.assemble>library</geronimo.assemble>
+                <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
 
@@ -441,8 +442,6 @@
             </properties>
         </dependency>
 
-
-
 <!--tools -->
         <dependency>
             <groupId>geronimo</groupId>
@@ -462,6 +461,7 @@
             <version>${geronimo_spec_j2ee_deployment_version}</version>
             <properties>
                 <geronimo.assemble>library</geronimo.assemble>
+                <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
         <dependency>
@@ -473,14 +473,16 @@
             </properties>
         </dependency>
 
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-deploy-tool</artifactId>
-            <version>${pom.currentVersion}</version>
-            <properties>
-                <geronimo.assemble>library</geronimo.assemble>
-            </properties>
-        </dependency>
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>geronimo</groupId>
+        #    <artifactId>geronimo-deploy-tool</artifactId>
+        #    <version>${pom.currentVersion}</version>
+        #    <properties>
+        #        <geronimo.assemble>library</geronimo.assemble>
+        #    </properties>
+        #</dependency>
+        -->
 
         <dependency>
             <groupId>geronimo</groupId>
@@ -619,14 +621,16 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-j2ee-deployment_1.1_spec</artifactId>
-            <version>${geronimo_spec_j2ee_deployment_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-j2ee-deployment_1.1_spec</artifactId>
+        #    <version>${geronimo_spec_j2ee_deployment_version}</version>
+        #    <properties>
+        #        <geronimo.assemble>repository</geronimo.assemble>
+        #    </properties>
+        #</dependency>
+        -->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
@@ -691,14 +695,16 @@
                 <geronimo.assemble>repository</geronimo.assemble>
             </properties>
         </dependency>
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-qname_1.1_spec</artifactId>
-            <version>${geronimo_spec_qname_version}</version>
-            <properties>
-                <geronimo.assemble>repository</geronimo.assemble>
-            </properties>
-        </dependency>
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-qname_1.1_spec</artifactId>
+        #    <version>${geronimo_spec_qname_version}</version>
+        #    <properties>
+        #        <geronimo.assemble>repository</geronimo.assemble>
+        #    </properties>
+        #</dependency>
+        -->
         <dependency>
             <groupId>org.apache.geronimo.specs</groupId>
             <artifactId>geronimo-saaj_1.1_spec</artifactId>
@@ -984,12 +990,6 @@
         </dependency>
         <dependency>
             <groupId>tomcat</groupId>
-            <artifactId>catalina</artifactId>
-            <version>${tomcat_version}</version>
-            <url>http://jakarta.apache.org/tomcat/</url>
-        </dependency>
-        <dependency>
-            <groupId>tomcat</groupId>
             <artifactId>catalina-optional</artifactId>
             <version>${tomcat_version}</version>
             <url>http://jakarta.apache.org/tomcat/</url>
@@ -1138,7 +1138,7 @@
             <version>${xfire_version}</version>
         </dependency>
 
-        <!-- for service mix and wadi -->
+        <!-- for wadi -->
         <dependency>
             <groupId>springframework</groupId>
             <artifactId>spring</artifactId>
@@ -1151,35 +1151,46 @@
         </dependency>
 
         <!-- Specification dependencies to preload into the repository -->
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-j2ee_1.4_spec</artifactId>
-            <version>${geronimo_spec_j2ee_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
-            <version>${geronimo_spec_j2ee_jacc_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-activation_1.0.2_spec</artifactId>
-            <version>${geronimo_spec_activation_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-javamail_1.3.1_spec</artifactId>
-            <version>${geronimo_spec_javamail_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>org.apache.geronimo.specs</groupId>
-            <artifactId>geronimo-corba_2.3_spec</artifactId>
-            <version>${geronimo_spec_corba_version}</version>
-        </dependency>
+        
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-j2ee_1.4_spec</artifactId>
+        #    <version>${geronimo_spec_j2ee_version}</version>
+        #</dependency>
+        -->
+
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-j2ee-jacc_1.0_spec</artifactId>
+        #    <version>${geronimo_spec_j2ee_jacc_version}</version>
+        #</dependency>
+        -->
+
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-activation_1.0.2_spec</artifactId>
+        #    <version>${geronimo_spec_activation_version}</version>
+        #</dependency>
+        -->
+
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-javamail_1.3.1_spec</artifactId>
+        #    <version>${geronimo_spec_javamail_version}</version>
+        #</dependency>
+        -->
+
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>org.apache.geronimo.specs</groupId>
+        #    <artifactId>geronimo-corba_2.3_spec</artifactId>
+        #    <version>${geronimo_spec_corba_version}</version>
+        #</dependency>
+        -->
 
         <!-- Geronimo modules to preload into the repository -->
         <dependency>
@@ -1312,11 +1323,13 @@
             <artifactId>geronimo-transaction</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
-        <dependency>
-            <groupId>geronimo</groupId>
-            <artifactId>geronimo-util</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>geronimo</groupId>
+        #    <artifactId>geronimo-util</artifactId>
+        #    <version>${pom.currentVersion}</version>
+        #</dependency>
+        -->
         <dependency>
             <groupId>geronimo</groupId>
             <artifactId>geronimo-web-builder</artifactId>

Modified: geronimo/branches/1.0/modules/axis-builder/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/branches/1.0/modules/axis-builder/project.xml?rev=367948&r1=367947&r2=367948&view=diff
==============================================================================
--- geronimo/branches/1.0/modules/axis-builder/project.xml (original)
+++ geronimo/branches/1.0/modules/axis-builder/project.xml Tue Jan 10 22:31:27 2006
@@ -149,12 +149,6 @@
 
         <dependency>
             <groupId>geronimo</groupId>
-            <artifactId>geronimo-kernel</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>geronimo</groupId>
             <artifactId>geronimo-naming</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>

Modified: geronimo/branches/1.0/modules/jetty-builder/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/branches/1.0/modules/jetty-builder/project.xml?rev=367948&r1=367947&r2=367948&view=diff
==============================================================================
--- geronimo/branches/1.0/modules/jetty-builder/project.xml (original)
+++ geronimo/branches/1.0/modules/jetty-builder/project.xml Tue Jan 10 22:31:27 2006
@@ -184,12 +184,6 @@
 
         <dependency>
             <groupId>geronimo</groupId>
-            <artifactId>geronimo-service-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>geronimo</groupId>
             <artifactId>geronimo-webservices</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>

Modified: geronimo/branches/1.0/modules/timer/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/branches/1.0/modules/timer/project.xml?rev=367948&r1=367947&r2=367948&view=diff
==============================================================================
--- geronimo/branches/1.0/modules/timer/project.xml (original)
+++ geronimo/branches/1.0/modules/timer/project.xml Tue Jan 10 22:31:27 2006
@@ -147,11 +147,13 @@
         </dependency>
 -->
 
-        <dependency>
-            <groupId>mx4j</groupId>
-            <artifactId>mx4j</artifactId>
-            <version>${mx4j_version}</version>
-        </dependency>
-
+        <!-- duplicate dependency - commented out to avoid eclipse project errors
+        #<dependency>
+        #    <groupId>mx4j</groupId>
+        #    <artifactId>mx4j</artifactId>
+        #    <version>${mx4j_version}</version>
+        #</dependency>
+        -->
+        
     </dependencies>
 </project>

Modified: geronimo/branches/1.0/modules/tomcat-builder/project.xml
URL: http://svn.apache.org/viewcvs/geronimo/branches/1.0/modules/tomcat-builder/project.xml?rev=367948&r1=367947&r2=367948&view=diff
==============================================================================
--- geronimo/branches/1.0/modules/tomcat-builder/project.xml (original)
+++ geronimo/branches/1.0/modules/tomcat-builder/project.xml Tue Jan 10 22:31:27 2006
@@ -188,12 +188,6 @@
 
         <dependency>
             <groupId>geronimo</groupId>
-            <artifactId>geronimo-service-builder</artifactId>
-            <version>${pom.currentVersion}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>geronimo</groupId>
             <artifactId>geronimo-webservices</artifactId>
             <version>${pom.currentVersion}</version>
         </dependency>
@@ -442,12 +436,6 @@
             <groupId>wsdl4j</groupId>
             <artifactId>wsdl4j</artifactId>
             <version>${wsdl4j_version}</version>
-        </dependency>
-
-        <dependency>
-            <groupId>xerces</groupId>
-            <artifactId>xercesImpl</artifactId>
-            <version>${xerces_version}</version>
         </dependency>
 
         <dependency>



Mime
View raw message