geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Struberg <strub...@yahoo.de>
Subject Re: [VOTE] [CANCELLED] Release geronimo-jpa_2.2_spec api jar
Date Thu, 28 Feb 2019 07:16:29 GMT
 sure, here we go:
[INFO] --- maven-bundle-plugin:3.5.0:bundle (default-bundle) @ geronimo-jpa_2.2_spec ---
[ERROR] Bundle org.apache.geronimo.specs:geronimo-jpa_2.2_spec:bundle:1.0-SNAPSHOT : Bundle-Activator
not found on the bundle class path nor in imports: org.apache.geronimo.specs.jpa.PersistenceActivator
[ERROR] Error(s) found in bundle configuration
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE



:)
Do you have time to figure out what this is about?Fixing our json spec in the meantime.
txs and LieGrue,strub

    On Wednesday, 27 February 2019, 18:49:13 CET, Raymond Auge <raymond.auge@liferay.com>
wrote:  
 
 Please do some sanity checking on it first ;)
- Ray

On Wed, Feb 27, 2019 at 12:08 PM Mark Struberg <struberg@yahoo.de> wrote:

 great thanks gonna re-roll it tonight.
LieGrue,strub
    On Wednesday, 27 February 2019, 14:57:39 CET, Raymond Auge <raymond.auge@liferay.com>
wrote:  
 
 Hey Mark, I made a commit that does all of the above if you just want to take it.
- Ray

On Wed, Feb 27, 2019 at 12:56 AM Mark Struberg <struberg@yahoo.de> wrote:

Thanks for the catch folks!

Yes we should fix the version. But we should keep it provided scoped.

txs and LieGrue,
strub


> Am 27.02.2019 um 06:45 schrieb Romain Manni-Bucau <rmannibucau@gmail.com>:
> 
> -1 to get osgi dep in compile scope, it must always be provided cause we rely on these
jars in not osgi env too and old locator was always used if available only, not imposed. Think
we should keep this mindset.
> 
> Le mer. 27 févr. 2019 à 00:17, Raymond Auge <raymond.auge@liferay.com> a écrit
:
> If you wish I could commit all of the above.
> 
> - Ray
> 
> On Tue, Feb 26, 2019 at 6:16 PM Raymond Auge <raymond.auge@liferay.com> wrote:
> Hey Mark,
> 
> This is not a -1 but maybe a +0 due to I'd have liked to see a few changes:
> 
> - The exported package versions being updated
> - use official OSGi dependencies rather than the deprecated felix ones
> - the osgi.contract version wasn't amended to add 2.2
> - don't use the old geronimo-osgi-locator in favour of Service Loader Mediator
> 
> Sincerely,
> - Ray
> 
> 
> On Tue, Feb 26, 2019 at 5:07 PM Mark Struberg <struberg@yahoo.de> wrote:
> hi folks!
> 
> I'd like to call a VOTE on releaseing the JPA-2.2 api.
> I've updated all missing parts and did verify with the signets against the official jar.
> 
> Here is the staging repo:
> https://repository.apache.org/content/repositories/orgapachegeronimo-1095
> 
> The source release zip can be found here:
> https://repository.apache.org/content/repositories/orgapachegeronimo-1095/org/apache/geronimo/specs/geronimo-jpa_2.2_spec/1.0/
> the sha1 is 1d9697c65938adae1cd4ef6da78108de9904133f.
> 
> 
> So please VOTE:
> 
> [+1] lets ship it
> [+0] meh, don't care
> [-1] stop there is a $showstopper
> 
> The VOTE is open for 72h
> 
> txs and LieGrue,
> strub
> 
> 
> 
> -- 
> Raymond Augé (@rotty3000)
> Senior Software Architect Liferay, Inc. (@Liferay)
> Board Member & EEG Co-Chair, OSGi Alliance (@OSGiAlliance)
> 
> 
> -- 
> Raymond Augé (@rotty3000)
> Senior Software Architect Liferay, Inc. (@Liferay)
> Board Member & EEG Co-Chair, OSGi Alliance (@OSGiAlliance)




-- 
Raymond Augé (@rotty3000)Senior Software Architect Liferay, Inc. (@Liferay)Board Member
& EEG Co-Chair, OSGi Alliance (@OSGiAlliance)  


-- 
Raymond Augé (@rotty3000)Senior Software Architect Liferay, Inc. (@Liferay)Board Member
& EEG Co-Chair, OSGi Alliance (@OSGiAlliance)  
Mime
View raw message