geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Romain Manni-Bucau (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GERONIMO-6604) Geronimo JWT Auth uses CDI 2.0 (must be 1.2)
Date Mon, 23 Apr 2018 07:32:00 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-6604?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16447674#comment-16447674
] 

Romain Manni-Bucau commented on GERONIMO-6604:
----------------------------------------------

My understanding - based on what JavaEE did for some years - is "interoperability is based
on X" CDI 1.2 here. So rephrased it can be read as "the jwt-auth extension is portable with
any CDI/Servlet container >= 2.0/3.0 so it is not portable with any random Microprofile
server".

The sentence you quoted also let imply that "below 1.2" is not portable to 2.0 should be -
probably a wording issue of the spec?.

> Geronimo JWT Auth uses CDI 2.0 (must be 1.2)
> --------------------------------------------
>
>                 Key: GERONIMO-6604
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-6604
>             Project: Geronimo
>          Issue Type: Wish
>      Security Level: public(Regular issues) 
>            Reporter: Rudy De Busscher
>            Priority: Major
>
> When adding the 
> {code:java}
> geronimo-jwt-auth-impl{code}
> to WildFLy 10.x, the 
> {code:java}
> GeronimoJwtAuthExtension{code}
> is not executed due to the fact is makes references to CDI 2.0.
>  
> Microprofile depends on CDI 1.2, so using 2.0 is wrong.
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message