geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John D. Ament" <johndam...@apache.org>
Subject Re: jwt-auth CDI base version
Date Mon, 23 Apr 2018 14:38:42 GMT
I can look at the code later but what I had to do before is capture all of
the claim injection points and provide specific producers for each.

On Mon, Apr 23, 2018, 10:35 AM Mark Struberg <struberg@yahoo.de> wrote:

> Qualifiers are per CDI spec not AnnotatedTypes.
> So if we rely on this then it's not spec compliant anyway.
>
> LieGrue,
> strub
>
> > Am 23.04.2018 um 14:30 schrieb Romain Manni-Bucau <rmannibucau@gmail.com
> >:
> >
> > the extension modifies @Claim to remove @NonBinding. This requires the
> impl to support to read qualifiers as AnnotatedType and only OWB 2.0.5
> supports it in OWB series ATM
> >
> >
> > Romain Manni-Bucau
> > @rmannibucau |  Blog | Old Blog | Github | LinkedIn | Book
> >
> > 2018-04-23 14:18 GMT+02:00 John D. Ament <johndament@apache.org>:
> > Whats the qualifier issue you're referring to?
> >
> > On Mon, Apr 23, 2018, 8:05 AM Romain Manni-Bucau <rmannibucau@gmail.com>
> wrote:
> > Same here, I just doubt we have an owb impl supporting the qualifier
> model change today so we can stay on OWB 2.0.5 or need to backport it to
> 1.x as well (which can likely be the case as well but can need to be done
> in parallel).
> >
> >
> > Romain Manni-Bucau
> > @rmannibucau |  Blog | Old Blog | Github | LinkedIn | Book
> >
> > 2018-04-23 13:17 GMT+02:00 John D. Ament <johndament@apache.org>:
> > If you already have a PR submitted even better.  We should accept it.
> >
> > On Mon, Apr 23, 2018, 7:07 AM Rudy De Busscher <rdebusscher@gmail.com>
> wrote:
> > Not that hard, except maybe for the NonBinding thing which is removed
> from @Claim.
> >
> > All the rest was done in 20 minutes or so.
> >
> > On 23 April 2018 at 13:03, Jean-Louis MONTEIRO <jeanouii@gmail.com>
> wrote:
> > Overall same view here.
> > How hard is it to make it 1.2 compliant?
> >
> >
> > Le lun. 23 avr. 2018 à 12:25, John D. Ament <johndament@apache.org> a
> écrit :
> > MP has made it very clear they don't care about portable libraries, and
> only care about the vendor provided solutions.  The requirement is that
> vendors provide a CDI 1.2 runtime to use.  Liberty provides a way to switch
> between them (1.2, 2.0).  I think Swarm may have moved to 2.0; not sure.
> >
> > I think Safeguard also compiles against CDI 2.0, but I don't think I'm
> using any 2.0 features in it so it may run properly against 1.2.
> >
> > Personally, if we have a user who wants it for 1.2, and the effort is
> minimal we should appease that user to help build out the community.
> >
> > John
> >
> >
> > On Mon, Apr 23, 2018 at 2:17 AM Romain Manni-Bucau <
> rmannibucau@gmail.com> wrote:
> > Hi guys,
> >
> > current codebase uses cdi 2.0 which means it can be used on tomee,
> meecrowave,  openwebbeans etc...
> >
> > Rudy opened https://issues.apache.org/jira/browse/GERONIMO-6604 to move
> it to cdi 1.2 - BTW "Microprofile depends on CDI 1.2, so using 2.0 is
> wrong." is wrong since some years you can always use a version *>=* of the
> minimum requirement for spec impls.
> > Technically I don't see a strong need to do it but I'd like to get your
> feeling about it to know what we do of the issue.
> >
> >
> > Romain Manni-Bucau
> > @rmannibucau |  Blog | Old Blog | Github | LinkedIn | Book
> >
> >
> >
>
>

Mime
View raw message