geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ariel Lira (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GERONIMO-6590) pom.xml contains illegal character / invalid
Date Thu, 08 Feb 2018 13:46:00 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-6590?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16356953#comment-16356953
] 

Ariel Lira commented on GERONIMO-6590:
--------------------------------------

Same issue with artifactory. Our workaround was to upload a valid pom to local-release repository. 

1) Download wrong pom https://repository.apache.org/content/repositories/releases/org/apache/geronimo/specs/specs/1.1/specs-1.1.pom

2) remove invalid char in line 90

3) deploy this pom to artifactory

> pom.xml contains illegal character / invalid
> --------------------------------------------
>
>                 Key: GERONIMO-6590
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-6590
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: ActiveMQ
>         Environment: Maven, JAVA 1.8, Artifactory
>            Reporter: Jakob Berlin
>            Priority: Blocker
>              Labels: Artifactory, Maven, pom.xml
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> We use Artifactory to cache and summarize remote repositories in our company. We use
org.apache.activemq which has a dependency to org.apache.geronimo.specs:specs:pom:1.1. This
can't be imported to Artifactory (which results in build failure) due a mailformed pom.xml.
> {noformat}
> 2017-09-20 16:01:19,839 [http-nio-8081-exec-17] [ERROR] (o.a.r.d.DbStoringRepoMixin:258)
- IO error while trying to save resource maven_local-releases-external:org/apache/geronimo/specs/specs/1.1/specs-1.1.pom'':
org.artifactory.api.repo.exception.maven.BadPomException: Failed to read POM for 'org/apache/geronimo/specs/specs/1.1/specs-1.1.pom':
expected START_TAG or END_TAG not TEXT (position: TEXT seen ...</developers>\n    `\n
   <p... @91:7) .
> {noformat}
> The pom.xml contains a "`"-character right after the closing develpers-tag and before
the next opening one.
> Please remove the wrong character.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message