geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (GERONIMO-5231) Override JVM libraries with newer versions
Date Fri, 12 Apr 2013 15:00:22 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-5231?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jarek Gawor resolved GERONIMO-5231.
-----------------------------------

       Resolution: Fixed
    Fix Version/s:     (was: 3.0.1)
                   3.0.0

This was done/enabled a while ago. Forgot to close it.


                
> Override JVM libraries with newer versions
> ------------------------------------------
>
>                 Key: GERONIMO-5231
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5231
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: buildsystem
>    Affects Versions: 3.0.0
>            Reporter: Jarek Gawor
>            Assignee: Jarek Gawor
>             Fix For: 3.0.0
>
>
> In some cases, Java EE 6 requires newer library versions then what is provided by Java
SE 6. For example, EE 6 requires annotations 1.1 api but SE 6 provides annotation 1.0 api.
So it is necessary that during a build we override the JVM provided libraries with newer versions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message