geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Jiang <genspr...@gmail.com>
Subject Re: [VOTE] Release yoko-1.4
Date Tue, 02 Apr 2013 02:00:19 GMT
I got the same failures.  But is this a real stop issue ?


On Mon, Apr 1, 2013 at 11:09 PM, Kevan Miller <kevan.miller@gmail.com>wrote:

>
> On Apr 1, 2013, at 10:30 AM, Jarek Gawor <jgawor@gmail.com> wrote:
>
> > I tired compiling Yoko (and jax-ws spec) on Java 7 and it compiled
> > fine with the old (2.0) genesis.
>
> Here are my results:
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-compiler-plugin:2.0.2:compile
> (default-compile) on project yoko-rmi-impl: Compilation failure:
> Compilation failure:
> [ERROR] could not parse error message: warning: [options] bootstrap class
> path not set in conjunction with -source 1.5
> [ERROR]
> /Users/kevan/tmp/release/yoko-1.4/yoko-rmi-impl/src/main/java/org/apache/yoko/rmi/impl/ValueHandlerImpl.java:53:
> warning: ReflectionFactory is internal proprietary API and may be removed
> in a future release
> [ERROR] private ValueDescriptor desc(Class clz, String repid, RunTime
> runtime) {
> [ERROR] ^
> [ERROR]
> [ERROR]
> /Users/kevan/tmp/release/yoko-1.4/yoko-rmi-impl/src/main/java/org/apache/yoko/rmi/impl/ValueDescriptor.java:[349,51]
> ReflectionFactory is internal proprietary API and may be removed in a
> future release
> [ERROR]
> [ERROR]
> /Users/kevan/tmp/release/yoko-1.4/yoko-rmi-impl/src/main/java/org/apache/yoko/rmi/impl/FieldDescriptor.java:[24,29]
> Unsafe is internal proprietary API and may be removed in a future release
> [ERROR]
> [ERROR]
> /Users/kevan/tmp/release/yoko-1.4/yoko-rmi-impl/src/main/java/org/apache/yoko/rmi/util/corba/Field.java:[32,17]
> Unsafe is internal proprietary API and may be removed in a future release
> [ERROR]
> [ERROR]
> /Users/kevan/tmp/release/yoko-1.4/yoko-rmi-impl/src/main/java/org/apache/yoko/rmi/util/corba/Field.java:[37,19]
> Unsafe is internal proprietary API and may be removed in a future release
> [ERROR]
> [ERROR]
> /Users/kevan/tmp/release/yoko-1.4/yoko-rmi-impl/src/main/java/org/apache/yoko/rmi/util/corba/Field.java:[38,8]
> Unsafe is internal proprietary API and may be removed in a future release
> [ERROR]
> [ERROR]
> /Users/kevan/tmp/release/yoko-1.4/yoko-rmi-impl/src/main/java/org/apache/yoko/rmi/util/corba/Field.java:[40,23]
> Unsafe is internal proprietary API and may be removed in a future release
> [ERROR]
> [ERROR]
> /Users/kevan/tmp/release/yoko-1.4/yoko-rmi-impl/src/main/java/org/apache/yoko/rmi/util/corba/Field.java:[45,30]
> Unsafe is internal proprietary API and may be removed in a future release
> [ERROR] -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the
> command
> [ERROR]   mvn <goals> -rf :yoko-rmi-impl




-- 
Shawn

Mime
View raw message