geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GERONIMODEVTOOLS-809) In-use port detection does not work sometimes
Date Wed, 27 Mar 2013 20:25:18 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-809?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13615717#comment-13615717
] 

Jarek Gawor commented on GERONIMODEVTOOLS-809:
----------------------------------------------

Committed improvements in revision 1461837. Besides checking 0.0.0.0 (as done before), GEP
will also now lookup and check the address of the server as configured in Eclipse (getServer().getHost()).

                
> In-use port detection does not work sometimes
> ---------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-809
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-809
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 3.0
>            Reporter: Jarek Gawor
>            Assignee: Jarek Gawor
>
> Before starting a server, GEP checks if the http and naming ports are free. This check
does not work sometimes on some platforms (e.g. Windows). That's because on Windows it is
possible to bind to 0.0.0.0 (any/all network interfaces) and 127.0.0.1 with the same port
at the same time.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message