geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yi Xiao (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GERONIMODEVTOOLS-806) The GEP3 could not install successfully in the customized eclipse which does not contain "org.eclipse.tm.terminal.view" plugin
Date Wed, 31 Oct 2012 04:19:11 GMT

     [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-806?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Yi Xiao updated GERONIMODEVTOOLS-806:
-------------------------------------

    Description: 
As some customized eclipse such as RAD does not contain "org.eclipse.tm.terminal.view" plugin,
when check the dependency of the GEP, it will fail.

It's better change the "org.eclipse.tm.terminal.view" dependency as optional, and check the
existence in GEP code. If not, suggest the user to install the plugin first from http://download.eclipse.org/dsdp/tm/updates/3.2.

  was:
As some customized eclipse such as RAD does not contain "org.eclipse.tm.terminal.view" plugin,
when check the dependency of the GEP, it will fail.

It's better change the "org.eclipse.tm.terminal.view" dependency as optional, and check the
existence in GEP code.

    
> The GEP3 could not install successfully in the customized eclipse which does not contain
"org.eclipse.tm.terminal.view" plugin
> ------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-806
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-806
>             Project: Geronimo-Devtools
>          Issue Type: Improvement
>          Components: eclipse-plugin
>    Affects Versions: 3.0, 3.0-beta-1, 3.0-beta-2
>            Reporter: Yi Xiao
>
> As some customized eclipse such as RAD does not contain "org.eclipse.tm.terminal.view"
plugin, when check the dependency of the GEP, it will fail.
> It's better change the "org.eclipse.tm.terminal.view" dependency as optional, and check
the existence in GEP code. If not, suggest the user to install the plugin first from http://download.eclipse.org/dsdp/tm/updates/3.2.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message