geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GERONIMO-6397) Improve resolver-based error messages for OSGi application
Date Thu, 11 Oct 2012 15:53:03 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-6397?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13474253#comment-13474253
] 

Jarek Gawor commented on GERONIMO-6397:
---------------------------------------

Improvements committed in revision 1397121.

Here's an example how the error messages will look like after the changes:

Test case 1 - package not exported:

2012-10-11 10:26:04,866 ERROR [ApplicationGBean] Error starting org.apache.geronimo.testsuite.jsp-eba_1.0.0
application. The following problems were detected:
    The package dependency foo; version="0.0.0" required by bundle jsp-wab [316] cannot be
satisfied.
        Package foo is not exported by any bundle.

Test case 2 - single export version mismatch:

012-10-11 10:41:29,284 ERROR [ApplicationGBean] Error starting org.apache.geronimo.testsuite.jsp-eba_1.0.0
application. The following problems were detected:
    The package dependency jline; version="2.6.0" required by bundle jsp-wab [316] cannot
be satisfied.
        Bundle org.apache.karaf.shell.console [62] exports jline; version="2.5.0" package
which does not satisfy the dependency.

Test case 3 - multiple export version mismatch:

2012-10-11 10:53:36,157 ERROR [ApplicationGBean] Error starting org.apache.geronimo.testsuite.jsp-eba_1.0.0
application. The following problems were detected:
    The package dependency jline; version="2.6.0" required by bundle jsp-wab [317] cannot
be satisfied.
        Bundle org.apache.servicemix.bundles.jline [53] exports jline; version="0.9.94" package
which does not satisfy the dependency.
        Bundle org.apache.karaf.shell.console [63] exports jline; version="2.5.0" package
which does not satisfy the dependency.

Test case 4 - multiple export, unselected export:

2012-10-11 11:31:59,768 ERROR [ApplicationGBean] Error starting org.apache.geronimo.testsuite.jsp-eba_1.0.0
application. The following problems were detected:
    The package dependency jline; version="(0.9.0,1.0.0]" required by bundle jsp-wab [317]
cannot be satisfied.
        Bundle org.apache.servicemix.bundles.jline [53] exports jline; version="0.9.94" package
which satisfies the dependency but is unselected.
        Bundle org.apache.karaf.shell.console [63] exports jline; version="2.5.0" package
which does not satisfy the dependency.

                
> Improve resolver-based error messages for OSGi application
> ----------------------------------------------------------
>
>                 Key: GERONIMO-6397
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-6397
>             Project: Geronimo
>          Issue Type: Improvement
>      Security Level: public(Regular issues) 
>          Components: Aries
>    Affects Versions: 3.0.0
>            Reporter: Jarek Gawor
>            Assignee: Jarek Gawor
>
> Improve ResolverErrorAnalyzer for OSGi applications. Specifically in cases where a import
package cannot be satisfied provide details if the given package is exported by any bundles
or if there are bundles that export that package with different version, etc.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message