geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johannes Weberhofer <jweberho...@weberhofer.at>
Subject Re: [Vote] Geronimo Eclipse Plugin (GEP) 3.0.0 RC2
Date Sat, 21 Jul 2012 07:10:07 GMT
Dear Yi Xiao!

As I have only 64 environments available, I can not test the build 
process, but I tested the update site which works correct for me.

Unfotunately my openejb-jar.xml files for an geronimo 2.2 server does 
not longer validate. That could have to do with the but I have filed 
under GERONIMODEVTOOLS-802. For previously valid projects I now get the 
following error message.

Best regards,
Johannes

================= Example file: openejb-jar.xml =================
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<ejb:openejb-jar 
xmlns:app="http://geronimo.apache.org/xml/ns/j2ee/application-2.0" 
xmlns:client="http://geronimo.apache.org/xml/ns/j2ee/application-client-2.0"
	xmlns:conn="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2" 
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2"
	xmlns:ejb="http://openejb.apache.org/xml/ns/openejb-jar-2.2" 
xmlns:log="http://geronimo.apache.org/xml/ns/loginconfig-2.0"
	xmlns:name="http://geronimo.apache.org/xml/ns/naming-1.2" 
xmlns:pers="http://java.sun.com/xml/ns/persistence"
	xmlns:pkgen="http://openejb.apache.org/xml/ns/pkgen-2.1" 
xmlns:sec="http://geronimo.apache.org/xml/ns/security-2.0"
	xmlns:web="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
	<dep:environment>
		<dep:moduleId>
			<dep:groupId>project</dep:groupId>
			<dep:artifactId>ProjectEJB</dep:artifactId>
			<dep:version>1.0</dep:version>
			<dep:type>ejb</dep:type>
		</dep:moduleId>
	</dep:environment>

	<ejb:enterprise-beans>
		<ejb:session>
			<ejb:ejb-name>ProjectEJB</ejb:ejb-name>
			<ejb:jndi-name>ejb/ProjectEJB</ejb:jndi-name>
			<ejb:local-jndi-name>ejb/ProjectEJBLocal</ejb:local-jndi-name>			
			<name:resource-ref>
				<name:ref-name>jdbc/projectDs</name:ref-name>
				<name:resource-link>projectDs</name:resource-link>
			</name:resource-ref>
		</ejb:session>

	</ejb:enterprise-beans>
</ejb:openejb-jar>
================= /Example file: openejb-jar.xml =================

================= Error =================
cvc-complex-type.2.4.a: Invalid content was found starting with element 
'name:resource-ref'. One of 
'{"http://openejb.apache.org/xml/ns/openejb-jar-2.2":local-jndi-name, 
"http://openejb.apache.org/xml/ns/openejb-jar-2.2":jndi, 
"http://openejb.apache.org/xml/ns/openejb-jar-2.2":cache-size, 
"http://openejb.apache.org/xml/ns/openejb-jar-2.2":tss-link, 
"http://openejb.apache.org/xml/ns/openejb-jar-2.2":tss, 
"http://geronimo.apache.org/xml/ns/naming-1.2":abstract-naming-entry, 
"http://geronimo.apache.org/xml/ns/naming-1.2":persistence-context-ref, 
"http://geronimo.apache.org/xml/ns/naming-1.2":gbean-ref}' is expected.
================= /Error =================


Am Thu Jul 19 03:06:25 2012 schrieb Yi Xiao:
> Could someone check the build/source and tell me the result?
>
> Thank you sincerely :)
>
> On Wed, Jul 18, 2012 at 6:05 PM, Yi Xiao <xiaoyijhondevelop@gmail.com <mailto:xiaoyijhondevelop@gmail.com>>
wrote:
>
>     Hi devs,
>
>     I've changed all the SNAPSHOT in testsuite and add the SLF4J license.
>
>     Please help to review and vote on the release of Geronimo Eclipse Plugin (GEP) 3.0.0
RC2.
>
>     GEP 3.0.0 supports Geronimo server 3.0.0, 2.2.1, 2.1.7 and Eclipse 3.7, 3.8, 4.2.
>
>     [Known issue]
>     1. GEP 3.0.0 uses maven-eclipsepde-plugin v1.1, which means it can not be built successfully
on 64bit win7 and 64bit macos. See following JIRAs for details.
>     - https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-737 Could not build GEP3.0
under win7-64bit
>     - https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-674 Could not build GEP3.0
under macos-64bit
>     2. Also, please use maven v2.2.1 to build GEP 3.0.0 as following JIRA is still open.
>     - https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-694 Can not build GEP with
maven 3.0
>     3. The plugins/org.apache.geronimo.st.v11.schemas/v11/xml.xsd uses W3C license and
plugins/org.apache.geronimo.st.schemas/v30/persistence_2_0.xsd uses Eclipse Public License,
 so the rat check on them are failed.
>
>     The source code zip is here:
>     https://repository.apache.org/content/repositories/orgapachegeronimo-064/org/apache/geronimo/devtools/geronimo-eclipse-plugin/3.0.0/geronimo-eclipse-plugin-3.0.0-source-release.zip
>     https://repository.apache.org/content/repositories/orgapachegeronimo-064/org/apache/geronimo/devtools/geronimo-eclipse-plugin/3.0.0/geronimo-eclipse-plugin-3.0.0-source-release.tar.gz
>
>     The tag is here:
>     http://svn.apache.org/repos/asf/geronimo/devtools/eclipse-plugin/tags/geronimo-eclipse-plugin-3.0.0/
>
>     The deployable zip file is here:
>     http://people.apache.org/builds/geronimo/eclipse/3.0.0/geronimo-eclipse-plugin-3.0.0-deployable.zip
>
>     The p2 repo zip file is here:
>     http://people.apache.org/builds/geronimo/eclipse/3.0.0/geronimo-eclipse-plugin-3.0.0-p2repo.zip
>
>     Notice: As update site format is not recommend in eclipse, now only provide the p2
format.
>
>     If you would like to review and/or comment on the release notes, you can find it
here:
>     http://people.apache.org/builds/geronimo/eclipse/updates/PLUGIN_RELEASE-NOTES-3.0.0.txt
>
>     Finally, I've created a Staging Site that can be used to test the update manager
functions of  Eclipse (Indigo SR2 and Juno):
>
>     http://people.apache.org/builds/geronimo/eclipse/updates/
>     The vote will be open for the 72-hour minimum.
>     [  ] +1 about time to push this out the door
>     [  ]  0 no opinion
>     [  ] -1 not this one  (please explain why)
>     --
>     Best regards!
>
>                                                                                     
           John Xiao
>
>
>
>
> --
> Best regards!
>
>                                                                                     
       John Xiao
>

--
Johannes Weberhofer
Weberhofer GmbH, Austria, Vienna

Mime
View raw message