geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Forrest Xia (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GERONIMO-6325) Unable to build oracle plugin
Date Tue, 17 Apr 2012 14:14:19 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-6325?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13255582#comment-13255582
] 

Forrest Xia commented on GERONIMO-6325:
---------------------------------------

Hi Stephen, 

Thank you for contributing this patch!

But seems this patch includes more than the change you mentioned in the jira description,
can you help revise it?
                
> Unable to build oracle plugin
> -----------------------------
>
>                 Key: GERONIMO-6325
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-6325
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: sample apps
>    Affects Versions: 3.0-beta-1
>         Environment: Windows 2008 x64 r2.
>            Reporter: Stephen Davidson
>              Labels: build
>         Attachments: 6325.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> error when building oracle datasource plugin in the daytrader 3.0-beta-1.
> [ERROR] Failed to execute goal org.apache.geronimo.buildsupport:car-maven-plugin:3.0-beta-1:package
(default-package) on project daytrader-oracle-datasource: could not package plugin: Can not
load adapter class in classloader org.apache.geronimo.daytrader.plugins.daytrader-oracle-datasource-DEPLOYMENT
[107]: oracle/jdbc/pool/OracleDataSource: *** Class 'oracle.jdbc.pool.OracleDataSource' was
not found. Bundle org.apache.geronimo.daytrader.plugins.daytrader-oracle-datasource-DEPLOYMENT
[107] does not import package 'oracle.jdbc.pool', nor is the package exported by any other
bundle or available from the system class loader. *** -> [Help 1]
> Resolution was to modify
> daytrader-3.0-beta-1/plugins/daytrader-oracle-datasource/pom.xml
> <dependency>
>   <groupId>org.tranql</groupId>
>   <artifactId>tranql-connector-oracle-xa</artifactId>
>   <type>rar</type>
>   <version>1.3</version>
>   <scope>provided</scope>
> </dependency>
> To:
> <dependency>
>   <groupId>org.tranql</groupId>
>   <artifactId>tranql-connector-oracle-xa</artifactId>
>   <type>rar</type>
>   <version>1.7</version>
>   <scope>provided</scope>
> </dependency>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message