Hi, although we are trying to make the deployment plan compatible among different versions,there are still differences. e.g. some OSGi metadata are imported in the latest 3.0 release. So, if the users would hope to use the same application package for different versions, there may be an issue. I am thinking that we could use version as suffix for the deployment plans. For the web application, Geronimo will first try to find a geronimo-web_3.0.0.xml in the WEB-INF directory, if not it will uses geronimo-web.xml file. With this, it may get the life easier.
Thoughts ?

--
Ivan