geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan <xhh...@gmail.com>
Subject Re: svn commit: r1149409 - in /geronimo/server/trunk: framework/configs/karaf-framework/src/main/filtered-resources/etc/ framework/modules/geronimo-main/src/main/java/org/apache/geronimo/main/ plugins/openejb/openejb/src/main/filtered-resources/etc/
Date Fri, 07 Oct 2011 03:35:22 GMT
In the past, we have a plugin named jee-specs, which contains all the
dependencies for those spec APIs, I am thinking that whether we could have
one in Geronimo 3.0. So that, the EARConfigBuilder could adds it as the
defaultEnvironment, with this, we might have less issues for those
applications who ship un-wanted spec APIs. Thoughts ?

2011/10/7 Jarek Gawor <jgawor@gmail.com>

> David,
>
> I think these additional jar added to startup.properties are not
> always present. For example, when starting the framework assembly
> (which used to start without any errors) I see the following errors
> (although the server still starts up ok):
>
> Artifact
> org/apache/geronimo/specs/geronimo-jms_1.1_spec/1.1.1/geronimo-jms_1.1_spec-1.1.1.jar
> not found
> Artifact org/apache/xbean/xbean-asm-shaded/3.8/xbean-asm-shaded-3.8.jar
> not found
> Artifact
> org/apache/servicemix/bundles/org.apache.servicemix.bundles.dom4j/1.6.1_2/org.apache.servicemix.bundles.dom4j-1.6.1_2.jar
> not found
> Artifact
> org/apache/geronimo/javamail/geronimo-javamail_1.4_mail/1.8.3/geronimo-javamail_1.4_mail-1.8.3.jar
> not found
>
> Jarek
>
> On Thu, Jul 21, 2011 at 7:58 PM,  <djencks@apache.org> wrote:
> > Author: djencks
> > Date: Thu Jul 21 23:58:52 2011
> > New Revision: 1149409
> >
> > URL: http://svn.apache.org/viewvc?rev=1149409&view=rev
> > Log:
> > GERONIMO-5893 use a start level for the config we start so it starts
> after features. Start a few more bundles in startup properties so they are
> more sure to get started early enough
> >
> > Modified:
> >
>  geronimo/server/trunk/framework/configs/karaf-framework/src/main/filtered-resources/etc/startup.properties
> >
>  geronimo/server/trunk/framework/modules/geronimo-main/src/main/java/org/apache/geronimo/main/Bootstrapper.java
> >
>  geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/etc/org.apache.karaf.features.cfg
> >
>  geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/repository/org/apache/geronimo/features/openejb-feature/3.0-SNAPSHOT/openejb-feature-3.0-SNAPSHOT-features.xml
> >
> > Modified:
> geronimo/server/trunk/framework/configs/karaf-framework/src/main/filtered-resources/etc/startup.properties
> > URL:
> http://svn.apache.org/viewvc/geronimo/server/trunk/framework/configs/karaf-framework/src/main/filtered-resources/etc/startup.properties?rev=1149409&r1=1149408&r2=1149409&view=diff
> >
> ==============================================================================
> > ---
> geronimo/server/trunk/framework/configs/karaf-framework/src/main/filtered-resources/etc/startup.properties
> (original)
> > +++
> geronimo/server/trunk/framework/configs/karaf-framework/src/main/filtered-resources/etc/startup.properties
> Thu Jul 21 23:58:52 2011
> > @@ -62,22 +62,28 @@ org/apache/mina/mina-core/${mina.version
> >
>  org/apache/sshd/sshd-core/${sshd.version}/sshd-core-${sshd.version}.jar=30
> >
>  org/apache/karaf/shell/org.apache.karaf.shell.ssh/${karaf.version}/org.apache.karaf.shell.ssh-${karaf.version}.jar=30
> >
> >
> -org/apache/geronimo/specs/geronimo-osgi-registry/1.1-SNAPSHOT/geronimo-osgi-registry-1.1-SNAPSHOT.jar=35
> >
> +org/apache/geronimo/specs/geronimo-osgi-registry/${geronimoosgiregistry.version}/geronimo-osgi-registry-${geronimoosgiregistry.version}.jar=30
> >  #feature service has trouble with this repackaged bundle
> >
> -org/apache/xbean/xbean-asm-shaded/${xbeanVersion}/xbean-asm-shaded-${xbeanVersion}.jar=35
> >
> +org/apache/xbean/xbean-asm-shaded/${xbeanVersion}/xbean-asm-shaded-${xbeanVersion}.jar=30
> > +
> >
> +org/apache/geronimo/specs/geronimo-stax-api_1.2_spec/1.1/geronimo-stax-api_1.2_spec-1.1.jar=31
> > +org/codehaus/woodstox/stax2-api/3.1.1/stax2-api-3.1.1.jar=31
> >
> +org/apache/geronimo/bundles/woodstox-core-asl/${woodstoxVersion}/woodstox-core-asl-${woodstoxVersion}.jar=31
> >
> +org/apache/geronimo/specs/geronimo-activation_1.1_spec/1.1/geronimo-activation_1.1_spec-1.1.jar=31
> > +
> >
> +org/apache/servicemix/bundles/org.apache.servicemix.bundles.dom4j/1.6.1_2/org.apache.servicemix.bundles.dom4j-1.6.1_2.jar=32
> >
> +org/apache/geronimo/specs/geronimo-jms_1.1_spec/1.1.1/geronimo-jms_1.1_spec-1.1.1.jar=32
> >
> +org/apache/geronimo/javamail/geronimo-javamail_1.4_mail/${javamail.version}/geronimo-javamail_1.4_mail-${javamail.version}.jar=32
> > +
> >
> +org/apache/geronimo/bundles/jaxb-impl/${jaxbImplVersion}/jaxb-impl-${jaxbImplVersion}.jar=32
> >
> +org/apache/geronimo/specs/geronimo-jaxb_2.2_spec/1.0.1/geronimo-jaxb_2.2_spec-1.0.1.jar=32
> > +asm/asm-all/3.2/asm-all-3.2.jar=32
> >
> >
>  org/apache/servicemix/bundles/org.apache.servicemix.bundles.xstream/1.3_3/org.apache.servicemix.bundles.xstream-1.3_3.jar=40
> >
>  org/apache/servicemix/bundles/org.apache.servicemix.bundles.xpp3/1.1.4c_3/org.apache.servicemix.bundles.xpp3-1.1.4c_3.jar=40
> >
>  org/apache/servicemix/bundles/org.apache.servicemix.bundles.cglib/2.1_3_4/org.apache.servicemix.bundles.cglib-2.1_3_4.jar=40
> >
>  org/apache/servicemix/bundles/org.apache.servicemix.bundles.commons-jexl/1.1_3/org.apache.servicemix.bundles.commons-jexl-1.1_3.jar=40
> >  commons-lang/commons-lang/2.5/commons-lang-2.5.jar=40
> >
> -org/apache/geronimo/bundles/jaxb-impl/${jaxbImplVersion}/jaxb-impl-${jaxbImplVersion}.jar=40
> >
> -org/apache/geronimo/specs/geronimo-activation_1.1_spec/1.1/geronimo-activation_1.1_spec-1.1.jar=40
> >
> -org/apache/geronimo/specs/geronimo-jaxb_2.2_spec/1.0.1/geronimo-jaxb_2.2_spec-1.0.1.jar=40
> >
> -org/apache/geronimo/specs/geronimo-stax-api_1.2_spec/1.1/geronimo-stax-api_1.2_spec-1.1.jar=40
> > -org/codehaus/woodstox/stax2-api/3.1.1/stax2-api-3.1.1.jar=40
> >
> -org/apache/geronimo/bundles/woodstox-core-asl/${woodstoxVersion}/woodstox-core-asl-${woodstoxVersion}.jar=40
> > -asm/asm-all/3.2/asm-all-3.2.jar=40
> >  commons-cli/commons-cli/1.2/commons-cli-1.2.jar=40
> >
>  org/apache/geronimo/bundles/sxc-jaxb/${sxcVersion}/sxc-jaxb-${sxcVersion}.jar=40
> >
>  org/apache/geronimo/bundles/sxc-runtime/${sxcVersion}/sxc-runtime-${sxcVersion}.jar=40
> >
> > Modified:
> geronimo/server/trunk/framework/modules/geronimo-main/src/main/java/org/apache/geronimo/main/Bootstrapper.java
> > URL:
> http://svn.apache.org/viewvc/geronimo/server/trunk/framework/modules/geronimo-main/src/main/java/org/apache/geronimo/main/Bootstrapper.java?rev=1149409&r1=1149408&r2=1149409&view=diff
> >
> ==============================================================================
> > ---
> geronimo/server/trunk/framework/modules/geronimo-main/src/main/java/org/apache/geronimo/main/Bootstrapper.java
> (original)
> > +++
> geronimo/server/trunk/framework/modules/geronimo-main/src/main/java/org/apache/geronimo/main/Bootstrapper.java
> Thu Jul 21 23:58:52 2011
> > @@ -113,6 +113,7 @@ public class Bootstrapper extends Framew
> >             BundleInfo info = new BundleInfo();
> >             info.location = file;
> >             info.mvnLocation = mvnLocation;
> > +            info.startLevel = 60;
> >
> >             startList.add(info);
> >         }
> >
> > Modified:
> geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/etc/org.apache.karaf.features.cfg
> > URL:
> http://svn.apache.org/viewvc/geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/etc/org.apache.karaf.features.cfg?rev=1149409&r1=1149408&r2=1149409&view=diff
> >
> ==============================================================================
> > ---
> geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/etc/org.apache.karaf.features.cfg
> (original)
> > +++
> geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/etc/org.apache.karaf.features.cfg
> Thu Jul 21 23:58:52 2011
> > @@ -25,5 +25,5 @@ featuresRepositories=mvn:org.apache.gero
> >  #
> >  # Comma separated list of features to install at startup
> >  #
> > -featuresBoot=openejb-feature
> > +featuresBoot=specs-feature,openejb-feature
> >  #  config,ssh,management
> >
> > Modified:
> geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/repository/org/apache/geronimo/features/openejb-feature/3.0-SNAPSHOT/openejb-feature-3.0-SNAPSHOT-features.xml
> > URL:
> http://svn.apache.org/viewvc/geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/repository/org/apache/geronimo/features/openejb-feature/3.0-SNAPSHOT/openejb-feature-3.0-SNAPSHOT-features.xml?rev=1149409&r1=1149408&r2=1149409&view=diff
> >
> ==============================================================================
> > ---
> geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/repository/org/apache/geronimo/features/openejb-feature/3.0-SNAPSHOT/openejb-feature-3.0-SNAPSHOT-features.xml
> (original)
> > +++
> geronimo/server/trunk/plugins/openejb/openejb/src/main/filtered-resources/repository/org/apache/geronimo/features/openejb-feature/3.0-SNAPSHOT/openejb-feature-3.0-SNAPSHOT-features.xml
> Thu Jul 21 23:58:52 2011
> > @@ -1,21 +1,43 @@
> >  <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
> >  <features xmlns="http://karaf.apache.org/xmlns/features/v1.0.0"
> name="openejb-feature-${project.version}">
> > +    <feature resolver="(OBR)" description="specs-feature"
> version="${project.version}" name="specs-feature">
> > +        <details>specs-feature details</details>
> > +        <!--<bundle
> start-level="33">mvn:org.apache.geronimo.specs/geronimo-osgi-registry/${geronimoosgiregistry.version}</bundle>-->
> > +        <!--<bundle
> start-level="34">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.dom4j/1.6.1_2</bundle>-->
> > +        <!--<bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/1.1.1</bundle>-->
> > +        <!--<bundle
> start-level="34">mvn:org.apache.geronimo.javamail/geronimo-javamail_1.4_mail/${javamail.version}</bundle>-->
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jaxws_2.2_spec/1.1-SNAPSHOT</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jaxrs_1.1_spec/1.0</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-servlet_3.0_spec/1.0</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jsp_2.2_spec/1.0</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-annotation_1.1_spec/1.0.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-interceptor_1.1_spec/1.0</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-el_2.2_spec/${geronimoel.version}</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-validation_1.0_spec/1.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-atinject_1.0_spec/1.0</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jcdi_1.0_spec/1.0</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-stax-api_1.2_spec/1.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jaxb_2.2_spec/1.0.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-activation_1.1_spec/1.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-saaj_1.3_spec/1.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jaxrpc_1.1_spec/2.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-j2ee-management_1.1_spec/1.0.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-j2ee-connector_1.6_spec/1.0</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jacc_1.4_spec/1.0</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jaspic_1.0_spec/1.1</bundle>
> > +        <bundle
> start-level="34">mvn:org.apache.geronimo.specs/geronimo-jpa_2.0_spec/1.1</bundle>
> > +    </feature>
> >     <feature resolver="(OBR)" description="openejb-feature-feature"
> version="${project.version}" name="openejb-feature">
> >         <details>openejb-feature details</details>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-annotation_1.1_spec/1.0.1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.myfaces.core/myfaces-bundle/${myfacesVersion}</bundle>
> >         <bundle
> start-level="35">mvn:commons-collections/commons-collections/3.2.1</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jaxws_2.2_spec/1.1-SNAPSHOT</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jaxrs_1.1_spec/1.0</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-servlet_3.0_spec/1.0</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jsp_2.2_spec/1.0</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.bundles/jstl/1.2_1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.commons-codec/1.3_2</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.bundles/commons-digester/1.8_1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.bundles/commons-discovery/0.4_1</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.dom4j/1.6.1_2</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.javassist/3.12.0.ga_1</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.javamail/geronimo-javamail_1.4_mail/${javamail.version}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.openejb/openejb-core/${openejbVersion}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.openejb/mbean-annotation-api/${openejbVersion}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.openejb/openejb-api/${openejbVersion}</bundle>
> > @@ -37,22 +59,13 @@
> >         <bundle
> start-level="35">mvn:org.apache.openejb/openejb-client/${openejbVersion}</bundle>
> >         <!--<bundle
> start-level="35">mvn:org.apache.openejb/commons-dbcp-all/1.3-r699049</bundle>-->
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.modules/geronimo-openejb/${project.version}</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-interceptor_1.1_spec/1.0</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/1.1.1</bundle>
> >         <!--<bundle
> start-level="35">mvn:org.ops4j.pax.logging/pax-logging-api/1.6.1</bundle>-->
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-el_2.2_spec/${geronimoel.version}</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-validation_1.0_spec/1.1</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-atinject_1.0_spec/1.0</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jcdi_1.0_spec/1.0</bundle>
> >         <!--<bundle
> start-level="35">mvn:org.codehaus.swizzle/swizzle-stream/1.0.2</bundle>-->
> >         <bundle
> start-level="35">mvn:org.apache.openejb/openejb-ejbd/${openejbVersion}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.openejb/openejb-server/${openejbVersion}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.openejb/openejb-multicast/${openejbVersion}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.openejb/openejb-osgi-core/${openejbVersion}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.bundles/jaxb-impl/${jaxbImplVersion}</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-stax-api_1.2_spec/1.1</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jaxb_2.2_spec/1.0.1</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-activation_1.1_spec/1.1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.wsdl4j/1.6.2_2</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.bundles/woodstox-core-asl/${woodstoxVersion}</bundle>
> >         <!--<bundle
> start-level="35">mvn:org.codehaus.woodstox/stax2-api/3.1.1</bundle>-->
> > @@ -64,7 +77,6 @@
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.framework/geronimo-cli/${project.version}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.framework/geronimo-common/${project.version}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.framework/geronimo-kernel/${project.version}</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-osgi-registry/${geronimoosgiregistry.version}</bundle>
> >         <bundle start-level="35">mvn:asm/asm-all/3.2</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.cglib/2.1_3_4</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.xstream/1.3_3</bundle>
> > @@ -76,23 +88,15 @@
> >         <bundle
> start-level="35">mvn:commons-lang/commons-lang/2.5</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.6</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.framework/geronimo-management/${project.version}</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-saaj_1.3_spec/1.1</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jaxrpc_1.1_spec/2.1</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-j2ee-management_1.1_spec/1.0.1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.framework/geronimo-naming/${project.version}</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.howl/1.0.1-1_1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.components/geronimo-transaction/${txmanagerVersion}</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-j2ee-connector_1.6_spec/1.0</bundle>
> >         <bundle
> start-level="35">mvn:commons-beanutils/commons-beanutils/1.8.3</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.bval/org.apache.bval.bundle/0.2-incubating</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.modules/geronimo-persistence-jpa20/${project.version}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.modules/geronimo-connector-1_6/${project.version}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.components/geronimo-connector/${txmanagerVersion}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.framework/geronimo-security/${project.version}</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jacc_1.4_spec/1.0</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jaspic_1.0_spec/1.1</bundle>
> >         <!--<bundle
> start-level="35">mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.boot/3.0.0-SNAPSHOT</bundle>-->
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.components/geronimo-jaspi/1.1.1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.bundles/sxc-jaxb/0.7.2_1</bundle>
> > @@ -101,7 +105,6 @@
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.modules/geronimo-transaction-1_6/${project.version}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.geronimo.framework/geronimo-core/${project.version}</bundle>
> >         <bundle
> start-level="35">mvn:org.tranql/tranql-connector/1.7</bundle>
> > -        <bundle
> start-level="35">mvn:org.apache.geronimo.specs/geronimo-jpa_2.0_spec/1.1</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.openwebbeans/openwebbeans-ee-common/${openwebbeansVersion}</bundle>
> >         <bundle
> start-level="35">mvn:org.apache.yoko/yoko-spec-corba/${yokoVersion}</bundle>
> >         <!--<bundle
> start-level="35">mvn:org.osgi/org.osgi.core/4.2.0</bundle>-->
> >
> >
> >
>



-- 
Ivan

Mime
View raw message