geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan <xhh...@gmail.com>
Subject Re: Files disappearing during the build
Date Fri, 12 Aug 2011 07:23:41 GMT
I am thinking to use a thread local in the FileUtils to record all the temp
files created in the deployment process, and it should be OK as all the
actions occur in the single thread.
Also, in the past, a array list is used to keep all the temp files, and a
shutdown hook will be added to delete those files. From my side, I never see
this work, and there might be simultaneous issue, will remove those codes.

2011/8/12 Ivan <xhhsld@gmail.com>

> I have fixed the issues, really sorry for it, I might be too eager to clean
> up those temporary files ...
>
>
> 2011/8/12 Shawn Jiang <genspring@gmail.com>
>
>> I met some strange "cant' find artifact" error when building the CTS
>> build.   But after I deployed a geronimo server snapshot manually(30 minutes
>> ago).   Now both server and cts server build work well in AHP.
>>
>>
>> On Fri, Aug 12, 2011 at 12:55 PM, David Jencks <david_jencks@yahoo.com>wrote:
>>
>>> I've started having some build problems today and wonder if they might be
>>> related to rev 1156562 (GERONIMO-6106).
>>>
>>> What I've seen so far is that:
>>>
>>> 1. the JarUtils.DUMMY_JAR_FILE gets created in the static initializer but
>>> seems to usually get deleted before it can be used.
>>>
>>> 2. At least one jar seems to get deleted out of my local maven repo
>>> (o.a.g.plugins:sysdb-portlets:3.0-SNAPSHOT:war)  I see this because I've
>>> blocked downloads of any geronimo artifacts so my builds of osgi related
>>> branches aren't confused by the regular trunk jars.  However, I think it
>>> would probably prevent deploying any more recent jar.
>>>
>>> Anyone have any ideas what might be going on?
>>>
>>> thanks
>>> david jencks
>>>
>>>
>>
>>
>> --
>> Shawn
>>
>
>
>
> --
> Ivan
>



-- 
Ivan

Mime
View raw message