geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GERONIMODEVTOOLS-763) "Source not found" message when debugging a project
Date Fri, 01 Jul 2011 04:01:28 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13058207#comment-13058207
] 

Jarek Gawor commented on GERONIMODEVTOOLS-763:
----------------------------------------------

About 1). No idea why & how that happens but the early source path computation was triggered
by the following code:

URL.setURLStreamHandlerFactory(streamHandlerFactory);

In OSGi this will always throw an Error on this call since the framework itself sets a default
factory (and only one can be set). The call to this function was in a proper try {} catch
block but somehow it still caused Eclipse to fire the breakpoint hit event. 


> "Source not found" message when debugging a project
> ---------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-763
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-763
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 3.0
>            Reporter: Jarek Gawor
>            Assignee: Jarek Gawor
>
> Under certain circumstances one can see "Source not found" message while debugging a
project that exists in the workspace and is deployed to the server.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message