On Thu, Jun 2, 2011 at 2:01 PM, Forrest Xia <forrestxm@gmail.com> wrote:


On Thu, Jun 2, 2011 at 11:22 AM, David Jencks <david_jencks@yahoo.com> wrote:
Hi Forrest,

I've pushed today's source to people.apache.org.  It compiles for me :-)  I just committed an update to OWB that makes it more compatible with aries proxying/weaving so you may want to build owb also.
OWB is in the build chain already :)


I'll probably be around on and off tonight so if you run into problems soon I might be able to fix them tonight.
Triggering an execution just now, so far no problem. thanks!
Hi David J,

After compiling the snapshot dependencies of aries, I still get compilation error at plugins/aries/geronimo-aries and geronimo-aries-builder.

[INFO] Compilation failure
 
 /home/tcker/tckdata/tckbuildsrc/djg30/plugins/aries/geronimo-aries/src/main/java/org/apache/geronimo/aries/GeronimoApplication.java:[52,46] [deprecation] createDeploymentMetadata(java.io.InputStream) in org.apache.aries.application.DeploymentMetadataFactory has been deprecated
 
 /home/tcker/tckdata/tckbuildsrc/djg30/plugins/aries/geronimo-aries/src/main/java/org/apache/geronimo/aries/GeronimoApplication.java:[63,31] cannot find symbol
 symbol : constructor SimpleBundleInfo(org.apache.aries.util.manifest.BundleManifest,java.lang.String)
 location: class org.apache.aries.application.utils.management.SimpleBundleInfo

I tried to fix them, but confused around variant aries util/utils classes.

Forrest